Skip navigation

Safari failed reinstall on Lion 10.7.3

226 Views 3 Replies Latest reply: Nov 20, 2012 11:13 AM by baltwo RSS
blackfrancis75 Calculating status...
Currently Being Moderated
Nov 20, 2012 4:46 AM

I'm on Mac OSX 10.7 Lion I uninstalled, and then reinstalled Safari 5.1.1, but now Safari wont run and I see this in the error report:

Dyld Error Message: Library not loaded: /System/Library/Frameworks/Accounts.framework/Versions/A/Accounts Referenced from: /System/Library/StagedFrameworks/Safari/Safari.framework/Safari Reason: image not found

There is no /Accounts subfolder at all under /System/Library/Frameworks on my machine.

I got the installer image from http://appldnld.apple.com/Safari5/041-2421.20111012.Mxtov/Safari5.1.1Lion.dmg

Any ideas how to fix this?

iMac, Mac OS X (10.5.4)
  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Nov 20, 2012 10:32 AM (in response to blackfrancis75)

    Are you sure you didn't install Safari 6? AFAIK, Lion doesn't come with or need the Accounts.framework. It's not on my machine and I'm running 5.1.7, disdaining the iOSified version 6.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Nov 20, 2012 11:13 AM (in response to blackfrancis75)

    Reinstall Lion. That should replace all the Safari 6 specific pieces and leave you with Safari 5.1.7.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.