Previous 1 2 Next 18 Replies Latest reply: Nov 24, 2012 5:37 AM by makey
makey Level 1 Level 1 (0 points)

I've finally tried installing Snow Leopard (I've been putting off the installation because, as expected, it doesn't work properly due to the Quick Time Player later version that comes with the upgrade.).


The problem is that imported STILL images just no longer run in iMovie HD6.  They do run in the clip shelf but when they are dragged into the timeline they do not appear when the 'Play the movie' button is pressed.


I have an installation disk for QTP 7.5.5 (which does work) and I tried to install it with Snow Leopard but it only goes as far as the install on Mac HD but then it won't allow it because (quote) 'cannot be installed on volume Mac HD because a newer version is already installed'.  I completely UN installed the new QTP, using AppCleaner, then tried again.  It still wouldn't allow QTP 7.5.5, with the same above message - even though the newer version is no longer showing on the system.  I found all the uninstalled QTP items lurking in the trash, so I emptied the trash but even that didn't help.


I've now completely erased the Mac HD and re-installed the backed up original system from my external hard drive.  Of course it's all working properly as before.


I would still like to upgrade to Snow Leopard but at the moment I won't - unless someone out there can tell me if I can overcome the problem.  Am I not doing the installation properly, so that I can keep QTP 7.5.5.?


Please help.

iMac, Mac OS X (10.5.8)
  • AppleMan1958 Level 7 Level 7 (27,370 points)

    It has been a long time since I had Snow Leopard, so my memory may not be too good. But I had to install the current version of QT7 from the Snow Leopard Install disks. I think you go to the Utilities section of the Installer.


    I just checked and I have QTP 7.6.6 which I believe came with Snow Leopard. You will need that one. You can have QTP 7.6.6 and QTP X on the same machine.

  • Klaus1 Level 8 Level 8 (45,425 points)

    Mac OS X 10.6 includes QuickTime versions 10.0 and 7.6.3. The QuickTime 7 player will only be present if a QuickTime Pro key was present at the time of installation, or if specified as part of a custom install, or individually downloaded:



    Snow Leopard update 10.6.4 included an update to 7.6.6 (if installed). You can install it from the above link  even though it says for 10.6.3. It's the same version of QuickTime Player 7.6.6.


    (Only QuickTime Player 7.6.3 or 7.6.6 can be updated to "Pro".)


    A Mac OS X v10.6, OS X Lion, and OS X Mountain Lion-compatible version of QuickTime Player 7 is available for use with older media or with AppleScript-based workflows. QuickTime Player 7 can be used to playback formats such as QTVR, interactive QuickTime Movies, and MIDI files. Also, it supports QuickTime 7 Pro registration codes for access to QuickTime Pro functionality.

    How to install Quicktime Player 7 on Snow Leopard, Lion and Mountain Lion when it is not already present:

  • makey Level 1 Level 1 (0 points)

    Thanks for your reply.  My whole problem began when I first upgraded from QTP 7.5.5 to QTP 7.6 and that's when I found out that only 7.5.5 would work properly in HD6.


    Does this mean that I can't have 7.5.5 with Snow Leopard?

  • makey Level 1 Level 1 (0 points)

    Thanks for your reply.  Unfortunately when I upgraded to QTP 7.6 a long time ago is when it all went wrong and I had to revert to QTP 7.5.5. which was the last QTP that worked properly with iMovie HD6.


    This suggests that I have to give up on Snow Leopard.  Or do you think there might be a work around?

  • AppleMan1958 Level 7 Level 7 (27,370 points)

    7.6.6 is working for me in Snow Leopard, Lion, and Mountain Lion, but I have not tested it extensively. I use mainly iMovie 11 and Final Cut Pro X so you may have found a bug that eluded me.

  • Klaus1 Level 8 Level 8 (45,425 points)

    Presumably you have are running iMovie 6.0.3?

  • AppleMan1958 Level 7 Level 7 (27,370 points)

    Actually 6.0.4

  • Klaus1 Level 8 Level 8 (45,425 points)

    AppleMan1958 wrote:


    Actually 6.0.4

    Do you have a link to that? Presumably for Intel Macs only?

  • AppleMan1958 Level 7 Level 7 (27,370 points)

    Unfortunately I don't.

    6.0.4 was introduced as a free offering to anyone who purchased iLife 08 and wanted the old version. When iLife 09 was introduced, it was withdrawn. To get it, you had to purchase iLife 08 and download it during that year.


    I went back and double checked and guess what? Senility is sinking in. I had 6.0.3 (267.2) all along. This makes sense because I had already paid for iLife 06 so I did not need the free download.


    My QuickTIme Player says QuickTIme Player 7.6.6 / with QuickTime 7.7.1 underneath. I do not have QT Pro, since I haven't found anything I needed it for.


    The good news is that it is working for me with 6.0.3 and QTP 7.6.6. Like I said I haven't tested it thoroughly. Just a couple of DV projects to see if I could see any difference with iMovie 11 when I was selling my 8MM camera on eBay.

  • Klaus1 Level 8 Level 8 (45,425 points)

    Yep, that computes! Same here!

  • makey Level 1 Level 1 (0 points)

    I only used iMovie HD6 which I obtained via my new iMac with iLife 08 installed.  I don't like iMovie 11 and don't need any Pro versions.  As I said, it seems that anything later than QTP 7.5.5 will not allow stills to run.


    Have you tried inserting any stills into the time line of iMovie HD6 to see if they run properly with QTP 7.6.6?

  • makey Level 1 Level 1 (0 points)

    I'm running iMovie HD 6.0.4, the last of the series.  My reply above to AppleMan1958 explains my problem with any QTP version higher than 7.5.5.

  • Klaus1 Level 8 Level 8 (45,425 points)

    I run iMovie 6.0.3 with Quicktime 7.7. Never had a problem with stills, whether created from an iMovie frame or inserted from iPhoto library.

  • thesurreyfriends Level 2 Level 2 (475 points)


    My understanding is that iMovie HD 6.0.3 and iMovie HD 6.0.4 are identical.The former originating from an install disk with upgrade, the latter a download for those that had iMovie 08 as was your case.

    I run Snow Leopard and I have iMovie HD 6.0.4 and QuickTime 7.6.6  .

    Although Snow Leopard came with QT X I downloaded QT 7.6.6 from the Apple site as mentioned above by Klaus 1.

    I have recently used iMovie HD 6.0.4 with many  stills plus video in the same project and all was ok. I can't see why it is not working for you.

Previous 1 2 Next