1 Reply Latest reply: Nov 20, 2012 2:52 PM by Jon Walker
screw this Level 1 Level 1 (0 points)

i have just bought quick time pro but can't register it. i have just downloaded quicktime 7 and have quick time x. do i have to delete the x version


iMac, OS X Mountain Lion (10.8.2)
  • Jon Walker Level 6 Level 6 (18,125 points)

    i have just bought quick time pro but can't register it. i have just downloaded quicktime 7 and have quick time x. do i have to delete the x version

    No. The Question is, what version of QT 7 did you download and attempt to install. QT 7 for Leopard (and earlier versions of OS X) cannot be installed on Snow Leopard (or later) operating systems. Snow Leopard, Lion, and Mountain Lion operating systems require a special version of QT 7 Player GUI (currently v7.6.6) that is compatible with the QT structures now embedded in the latest operating systems. You can find the download HERE and installation/keying instructions HERE.

     

    SJAUG.png