8 Replies Latest reply: Nov 26, 2012 3:50 PM by shuttersp33d
Michael Marcheschi Level 1 Level 1 (5 points)

I am having issues after moving from a Macbook Air 13" to a Macbook Pro 13" Retina.  I have a Canon Powershot S110 that I use when

I travel.  I normally use a 1DS Mark II.  The S110 is a new camera on the market and was unsupported in Aperture until version 3.4...  When I updated the software on the Air to 3.4.2, I believe, the file format finally was recognized and life was good.  However, I have now transferred everything over to the Pro 13" Retina and I cannot get it to recognize the image format...  I have been to the Apple Store and worked for two hours with a Genius and nothing.  I have tried completely wiping the drive and reinstalling the most recent version of the OS and then only installing Aperture 3.4.3 and it still will not work...  I do not understand how it could be working on the Air and not on the Pro.  I would greatly appreciate any insight any of you may have.  Thanks!

  • Aye Es Oh Level 2 Level 2 (330 points)

    Looks like there's an issue with attempting to install the latest RAW update on the recently-announced Macs.

     

    You'll need to edit your /System/Library/CoreServices/SystemVersion.plist file to be able to install it, then change it back after the install is done. If you're comfortable with the Terminal you can use pico/vi/emacs to change the ProductBuildVersion from 12C2034 to 12C1999, do the install, then change it back.

     

    If you're not comfortable with the Terminal, then navigate through your "System" folder on your hard drive to find the "SystemVersion.plist" file, copy it to your desktop, then make another copy of it (for backup purposes). Open it in TextEdit to change the ProductBuildVersion from 12C2034 to 12C1999. Copy the edited version back to the CoreServices folder, and you should be able to install the RAW updater.

     

    After the install is finished, change the version number back by renaming the backup copy you made back to its original name and copy that back into the CoreServices folder.

  • Michael Marcheschi Level 1 Level 1 (5 points)

    Thank you for your help!  I did exactly what you said.  I was able to download the RAW update but, unfortunately, it is still not working.  You can see from the image below that everything is up to date but still no joy...

     

    screen-capture.jpg

     

    Any other thoughts or ideas?  I really appreciate your help!

  • léonie Level 9 Level 9 (67,830 points)

    have you rebooted after installing the raw updateß

  • Michael Marcheschi Level 1 Level 1 (5 points)

    Yes, I have.  Still no luck.  Thanks for your suggestion.

  • léonie Level 9 Level 9 (67,830 points)

    Sometimes reregistering the "Core types bundle" with the OS has helped. You need the Terminal to do this:

     

    • Quit Aperture, if it is running.
    • Launch a Terminal (from the Launchpad, or from the Applications > Utilities folder, or typing "Terminal" into the Spotlight search field)
    • Then enter:

     

     

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -R /System/Library/CoreServices/CoreTypes.bundle/Contents/Library

     

    All in one line and without spaces - the only spaces go directly before and after "-R" (the server inserts random blanks into long lines when downloading a post - remove them). Hit return.

     

    Then reboot and try again, if Aperture recognizes the raw format now.

     

    Regards

     

    Léonie

  • Michael Marcheschi Level 1 Level 1 (5 points)

    Léonie,

     

    You are kind to try to help.  I did what you suggested and it is still not working.  Would there be anything with this 13" Pro Retina from a hardware perspecive that could be an issue.  Anything to do with the graphics?  I am at a loss to know what to do at this point.  I suppose I will call Apple tomorrow and see if there is anyone there who can help.

     

    Thanks again,

    Michael

  • léonie Level 9 Level 9 (67,830 points)

    Micheal, I have no idea. If Apple can find a solution, please post it here.

     

    On your rMBP, what is your MacOS X version? Have you upgraded to Max OS X 10.8.2 or is the system there still Max OS X 10.8.1? Afaik, the update for the late 2012 rMBPs has not yet been released. Maybe you need to wait a little, until you can update the MacOS X version.

     

    Léonie

  • shuttersp33d Level 4 Level 4 (1,540 points)

    Have you tried simply reprocessing the original since installing the RAW update? Select the images with which you are experiencing the issue, Go to the Photos menu > Reprocess Original...

     

    Would you let us know if that helps.