1 Reply Latest reply: Nov 23, 2012 12:32 AM by léonie
rjs001 Level 1 Level 1 (0 points)

It appears that Aperture 3x is only compatible with OS X Lion.  I just wanted to confirm that my Snow Leopard OS 10.6.8 cannot run the current version of Aperture.  Is there any way around this?


Aperture 3, Mac OS X (10.6.8)