7 Replies Latest reply: Nov 23, 2012 11:55 AM by deggie
Nicole1271 Level 1 Level 1 (0 points)

everytime i go to download an app it says 'this app requires iOS 4.3' or 3.0? i think i have 2.1 and everytime i see if i can update it it says no updades?

 

Can i not get these apps at all or can i somehow update it?


iPod touch, 2nd gen