Previous 1 2 Next 21 Replies Latest reply: Jan 25, 2013 12:23 PM by bobluce41
Stijnley Level 1 (0 points)

Dear fellow iPhone users!


I have my 4S since January 2012 and I'm very happy with my purchase.

I didn't experience any problems, untill I updated a few weeks ago to ios 6.0.1 (I even had no problems using 6.0)


Since my purchase I installed a new wireless router so I could use wifi at home. It all worked fine!

Since 6.0.1 my wifi at home keeps dropping. It fails to connect on a daily basis and drops most of the times when I re-enter my house.

It's driving me crazy! It looks like a software problem because my wifi worked fine untill the last update!? Nothing else happened.


When I experience the wifi-problems, I try switching off and on the Wifi-button or airplaine-modus, but this doenst't work most of the times.

When I try a hard-reset the Wifi button turns grey after te reboot. After a new hard reset I can acces wifi again, untill it loses signal again after maybe 1 or more hours at home...


I'vr read that the iphone5 users are experiencing the same problem, but what to do with my 4S?


I don't want to miss my iPhone for "warranty repair" for several weeks (we don't have a genius bar in Belgium) because it's possible that the problem isn't fixed after "repair".


I tried a hard reset, complete restore (+ backup), nothing works


Who can help me with this problem?


Thank you in advance,


Best regards!

iPhone 4S, iOS 6.0.1
  • Lawrence Finch Level 7 (34,951 points)

    Go to Settings/General/Reset - Reset Network Settings. If that doesn't fix the problem do a Restore and do not restore the backup.

  • Stijnley Level 1 (0 points)

    Thank you for your reply Lawrence Finch


    I tried resetting the network several times, without success.


    So first thing in the morning (it's 10pm here), I'll do a new restore - install as new - and then restore my backup, am I correct? I tried restoring before (also without success) but I immediately selected restore from backup.


    I'll keep you posted!

  • Lawrence Finch Level 7 (34,951 points)

    Do not restore your backup right away. First test to see if the problem is resolved. If it is your backup is probably corrupt. If the problem is still there on a "virgin" phone, and it also happens with other networks, you have a hardware problem.


    One other thing to check is WiFi interference. Try changing the router to a fixed channel instead of Automatic, and, if it is already fixed change the channel. Choose a channel other than 6 or 11, which are the default channels for most routers.

  • Stijnley Level 1 (0 points)

    Thanks a lot for your information.


    I'll try the virgin-iPhone this weekend. The router of my wifi has "automatic channel" installed (now I'm using channel 10). I'll see how the virgin-iPhone works, if the problem stays I'll try a new fixed channel. I'll post back asap!


    Thank you again!

  • Stijnley Level 1 (0 points)

    ok I just did a full restore without replacing my backup. I'm now using a clean phone...


    When the restore was finished...the wifi button was grey. I did a hard reset and the wifi button worked again. I found my wifi at home, but failed to connect after entering the password. I switched the wifi-button off and on again, and he failed to locate any wifi-spots near my house now (there are 4, 1 is mine). The phone keeps "searching network".


    I did a new hard reset, the wifi button was grey, after 2 new reboots the wifi button worked again, but still keeps failing to find any wifi-spots?! My home wifi channel is still 10, like some hours ago when everything went well?!


    What is happening? My phone is completely messed up since the last update?! I can't be the only one with this problem? How can this not be software-related, because everything worked fine until 6.0.1!?


    Any help is appreciated! Thank you!

  • Stijnley Level 1 (0 points)

    So I tried a new clean recovery...the wifi worked, I could connect to my local wifi network.


    I went out, came back in to my house and saw that wifi failed to connect. I tried searching for wifi-spot but it keeps "searching network"...


    I did a new full restore and replaced my backup, the wifi button stayed grey the whole time, even after 5 hard resets...


    Again a new full restore, replaced my backup, now wifi works for 10 minutes, but for how long? This can't be a hardware problem right?


    This sure s*cks! What to do? I've read hundreds of posts with the same problem! Where is Apple in this?

    Should I wait for a new ios update? The nearest Genius-bar is a 400 miles roundtrip...but then I get a refurbished one?! I want mine or a brand new one... In January I have my iPhone for 1 year... (Belgium has 2 year warranty but I've read that Apple doesn't want to give this 2 year warranty?)



  • Lawrence Finch Level 7 (34,951 points)

    Have you set the router to a fixed channel rather than automatic? Have you verified that the router has the latest firmware version?


    How could it be a software problem if the millions of people who have upgraded to 6.0.1 do not have the problem? I upgraded to 6.0.1; why do I not have a problem with WiFi?

  • Stijnley Level 1 (0 points)

    I'll try the fixed channel now. The router is pretty new, I'll check this to be surr, thanks.


    It seems like software, because everything worked before 6.0.1?

    I was home the entire day today, half of the time wifi failed to connect, the other half was good wifi, without doing anything...


    I can't think of any explanation?

  • Lawrence Finch Level 7 (34,951 points)

    That sounds a lot like interference. Do you have any 2.6 GHz cordless phones?

  • Stijnley Level 1 (0 points)

    I don't have any, but maybe my neighbours? I live in an appartement so...


    I just woke up and had wifi for 10 minutes. Now my phone keeps searching for wifi networks (also the other spots near my house can't be found...)


    I've read on tis forum that many people on 6.0.1 have problems with wifi (most of them have greyed out wifi buttons), so I guess I'm not the only one?


    It's just weird that my wifi buttons also greyed out a couple of times. 1 hour later my wifi works fine and another hour later i can't find any networks? Very frustrating since I only use wifi at home for my I just pay bills without ejoying good connection...


    thank you for help!

  • Stijnley Level 1 (0 points)

    I tried the fixed channel "1" but it didn't work either. It fails to connect after 30 minutes standby and then keeps searching for network.


    I tried lowering the wifi-security level from WPA2-PSK tot worked for 10min and then loses connection again. I did a reboot and the wifi button greyed out again, after 5 reboots I could use the button again...


    My router is 10 months old and should be updated automaticaly by my internet provider. It's a rental router so I don't know how to update it myself...


    What to do?

  • Lawrence Finch Level 7 (34,951 points)

    Stijnley wrote:



    I've read on tis forum that many people on 6.0.1 have problems with wifi (most of them have greyed out wifi buttons), so I guess I'm not the only one?


    If you read further you will find that "many people" on iOS 5, 4, 3, 2, and 1 and all intermediate versions have reported similar problems with WiFi, so the problem really isn't the version. The fact that Apple has a Knowledge Base article ( about it that has been available for as long as there have been iPhones tends to indicate that it is a long standing problem. If none of the diagnostic steps in the article help you probably have a failed or intermittent RF chip, so you need to contact Apple for a replacement. If you have an Apple store near you they can diagnose it.


    One rather bizzare "cure" that some people have reported success with is to put it in a sealed plastic bag (to protect it from condensation) and put it in a freezer for 15 minutes.

  • Stijnley Level 1 (0 points)

    Thank you for your time,


    Do you believe this is hardware related? It's just weird that my wifi works half the time so the hardware does work.

    On the otherhand my phone searches for wifi networks the other half of the day without finding them.


    I jut hate it, the nearest apple shop is a 400 miles round trip...

    I'll try the freezer tomorrow, you never know!

  • Lawrence Finch Level 7 (34,951 points)

    If it happens with all networks it is probably hardware related. You can also call Apple and arrange an exchange by "mail" (probably FedEx).

Previous 1 2 Next