3 Replies Latest reply: Nov 25, 2012 10:02 AM by JAFedigan
JAFedigan Level 1 Level 1 (0 points)

Like a lot of people, I upgraded to Mountain Lion 10.8.2 (or .1 for somepeople) and had my Windows 7 Boot-camp-made partition corrupted, scrambled, messed up... i don't know the technical term. I read somewhere that after upgrading, if you looked in Disk Utility at your Windows partition, that if it was unmounted, mounting it would fix it. I didn't know this then so I re-installed Windows 7.


After about 5-6 re-installs, using a handful of different guides ranging from the official to the Apple Employee recommendations on these forums, I would get an error message after finalizing the installation.


This happened every install.  I tried googling it and could not find much information about it. Regardless if I click 'Try Again' or 'Continue', it continues on with the installation (briefly). 'Cancel' will cancel the installation, obviously. Once I click either one of the above mentioned, the installation window goes away and a "Starting..." message comes up. Followed up a "Windows is updating system files" message or something to that effect. Very, very, very, very quickly and error message pops up and goes away as quick as it came up. "Shutting Down..." shows up and the computer reboots.


More research on this message has turned up nothing.


If I attempt to boot from the Windows partition, it will instead want to boot from the DVD, "Press any key to blah blah..." If I don't hit a key, it freezes after 5 periods. No HD spinning, no optical drive, it freezes. If I remove the DVD, and boot from the Windows partition, I get a blinking _ in the top left corner.


Any suggestions? Anyone else having this issue?

iMac, OS X Mountain Lion (10.8.2), Boot Camp
  • JAFedigan Level 1 Level 1 (0 points)

    I restored my OS X partition fully (deleted the Windows partition and expanded OS X back) through the Disk Utility and then re-did the BCA and Windows 7 installation. Same thing occured with the first red error message, but I did not get the millisecond error message (2nd picture).


    Any help or input would be huge. Can't find anything on the internet regarding the first message and all of my Mac/Windows Friendly friends are lost as well.

  • JAFedigan Level 1 Level 1 (0 points)

    Tried using the repair tool via Windows 7 Installation and got another error message. Something about the wrong version of Windows Repair Tool being incompatible with Windows 7.... Really getting lost at things to try.

  • JAFedigan Level 1 Level 1 (0 points)

    Co-worker helped me out with this. This is his message, copied and pasted.


    Fixed! Think the problem was that it was an OEM version of Win 7, which Bootcamp advise against using... they advise to use retail only. Fixed like this:

    1. Put the Windows 7 installation disc in the disc drive, and then start your computer.
    2. Hold down Option key till all available disks are displayed and select DVD. Press a key when you are prompted.
    3. Select a language, a time, a currency, a keyboard or an input method, and then 4. click Next.
    5. Click Repair your computer.
    6. Click the operating system that you want to repair, and then click Next.
    7.In the System Recovery Options dialog box, click Command Prompt.

    Type (these commands are safe)
    Code: Bootrec.exe /FixMbr
    Code: Bootrec.exe /FixBoot
    Code: Bootrec.exe /RebuildBcd
    *Press ENTER after each command.*
    *Restart your computer.*

    Done. Rockin'


    If Command Prompt doesn't work, instead try SHIFT-F10 to get to a command prompt