2 Replies Latest reply: Nov 24, 2012 1:51 AM by Klaus1
kimseven77 Level 1 Level 1 (0 points)

Im trying to upload my new ipod nano but I need to upgrade to at least 10.6.8.. I currently have 10.5.8. Any suggestions?


MacBook, iOS 5, ipod nano