5 Replies Latest reply: Nov 29, 2012 7:29 AM by planb77
Deanna Carpenter Level 1 Level 1 (0 points)

I'm frustrated.  I have an 80GB iPod classic and have tried to sync it lately with absolutely miserable success.  I have/had iTunes 10.7.  I plug in my ipod and it starts to sputter and gag and eventually crashes and I have to force quit.  I've used advice on this site to use time machine to go to an earlier version and of course have run into "your library can't be read because it was made by an newer version of iTunes".  Blah blah...got that unscrewed and STILL can not synch.

 

- what version of itunes still supports ipod classic???


MacBook (13-inch Aluminum Late 2008), Mac OS X (10.6.8), also have ipod shuffle