4 Replies Latest reply: Nov 24, 2012 11:45 AM by rickymoro
rickymoro Level 1 Level 1 (0 points)

I first installed Aperture 2.1.1 (dvd) on a Macbook Pro running os x 10.5.8.

I then purchased the dvd to upgrade to Aperture 3 and I recently downloaded the update 3.1.2  (no more updates available for os x 10.5).

I just installed os x 10.6 (sorry for delay) and updated it to 10.6.8, and here is the problem: Aperture doesn't open anymore.

I tried to disinstall Aperture following these steps (http://support.apple.com/kb/HT3805):

 

" On Mac OS X v10.6. Snow Leopard:

  1. Open the Applications folder.
  2. Drag the Aperture application to the Trash.
  3. Open the Utilities folder within the Applications folder.
  4. Open the Terminal application.
  5. On the command line, type the below command (which is case-sensitive) and then press Return: sudo pkgutil --forget com.apple.pkg.Aperture
  6. When prompted, enter your user password and press Return.
  7. Insert your Aperture disc and install Aperture.
  8. When finished, choose Software Update from the Apple () menu to update your software to the latest version.

For further information on settings or installation, please refer to the Aperture documentation available on your installation discs. "

 

but, after typing " sudo pkgutil --forget com.apple.pkg.Aperture ", and putting the password, I get the following error:

 

Unknown error Error Domain=NSCocoaErrorDomain Code=4 UserInfo=0x10025f3d0 "“com.apple.pkg.Aperture.bom” couldn’t be removed.".

Forgot package 'com.apple.pkg.Aperture' on '/'.

 

Does anyone know what I should do? Can I go on reinstalling Aperture 2 and then upgrade to 3 using the dvd I have or may I have some problems in the future?

 

Really appreciate any help.

 

Ric


Aperture 3, Mac OS X (10.6.8)
  • 1. Re: Problems reinstalling Aperture
    léonie Level 9 Level 9 (51,795 points)

    Aperture doesn't open anymore.

    Ric,

    what exactly happened, when Aperture does not open anymore? Do you get any error messages? Which message?

     

    Since you are now running Snow Leopard, and have an install DVD for Aperture 3, it is not necessary to reinstall Aperture 2. Follow the procedure described here for reinstalling from DVD:

    Aperture 3.4: May quit unexpectedly on launch after updating

    and reinstall Aperture 3 directly from the DVD, then upgrade using Software update. But you will have to enter both serial numbers, for Aperture 2 and Aperture 3.

  • 2. Re: Problems reinstalling Aperture
    rickymoro Level 1 Level 1 (0 points)

    After upgrading to os x 10.6.8, I opened Aperture (version 3.1.2) and got a message saying Aperture and the os x were not compatible.

    Today I tried to first reinstall Aperture 2, then Aperture 3 (the latter is an upgrade only dvd, not the complete version).

    I just didn't care about the step suggested to be done in the Terminal utility during disinstallation.

    Updated software and it looks everything is working now.

    Thanks for the help.

    Ric

  • 3. Re: Problems reinstalling Aperture
    léonie Level 9 Level 9 (51,795 points)
    After upgrading to os x 10.6.8, I opened Aperture (version 3.1.2) and got a message saying Aperture and the os x were not compatible.

     

    Ric, did this message contain something like "certificate expired"? The older installers on the installation media sometimes are not accepted by the newer MacOS versions - security issues. If this happens again, change the date in the System Preferences, so MacOS thinks it is still before February 2012, then the installer should work.

     

    But great that you could solve your issue, and now have a working Aperture 3 installation!

     

    Regards

    Léonie

  • 4. Re: Problems reinstalling Aperture
    rickymoro Level 1 Level 1 (0 points)

    Nothing about certificate was mentioned. Still don't understand what the problem may have been. Anyway, it should be ok now...

    Thank you again Leonie for your kind help.

    Regards

    Ric