1 Reply Latest reply: Nov 23, 2012 10:43 PM by mende1
drumgirl42 Level 1 Level 1 (0 points)

I have a macbook osx version 10.5.8, and I just bought a ipod nano 7th generation. I tried to update itunes to itunes 10.7 so that it would run, and it said I needed osx version 10.6.8 or later....can I get that on my mac? or is it too old?


MacBook (13-inch Early 2008), Mac OS X (10.5.8)