7 Replies Latest reply: Oct 13, 2015 1:04 PM by Josielee1101
laul Level 1 (0 points)

Hi !

First, I of course know this question was asked lots of time but... maybe any solutions were found and not displayed.

As lots of people, I encrypted a pages document and (it's normal) I forgot it. Of course, I don't need to tell that my document was pretty important for me...


Do you think it would be any way to open my document ?? My first idea was that by typping a wrong password more than 3 times, a popup windows would propose me to help founding the lost password.But no.


I also thought I would be able to "open content of package" but this option is not displayed since the file is encrypted. 

Finally my last hope was that the password would be saved in my icloud account (since I've pages and documents on the cloud, seemed logical) ; But, again, no.


So : any idea / help ?!

Thanks a lot

iWork pages, OS X Mountain Lion (10.8.2)
  • Jerrold Green1 Level 7 (29,955 points)



    You are not the first person to come with that problem. The answer is the same as always - if the password is lost, the content is lost too. Are you sure you didn't save the password anywhere? You were prompted for a Hint when you applied the password. Did you provide one?



  • SkyJester Level 1 (0 points)

    If you lost your Document password in Pages, there is a way to recover the password but only if it's a recent recent Document, the system password settings are correct and most importantly, you are the System Administrator.


    In the Applications Icon on the Dock, open your Utilities File and click on "Keychain Access."  After it opens and in the far left column under "Category," click on "...Passwords."  If they are not Alphabetized already, click "NAME" at the top of the column it will alphabetize all the Passwords Names.  Find "Password.pages," click on and it will bring up the "ATTRIBUTES/ACCESS CONTROL" and click the "SHOW PASSWORD" box.  Enter the System Password and it will show you the password.


    I heard there is another way to hack the password through "TERMINAL" but it's very involved and rather lengthy. I lost a password for an older document and hope that someone has the knowledge to open it by using another program or the steps necessary to open it through Terminal.


    But Come'on Apple!... There has to be a way to open the Document. If Team *GhostShell can Hack and Publish one million records, allegedly from banks, government agencies, consulting firms and others, a simple document should be opened if the password is lost or forgotton.  I believe privacy concerns will not allow any Apple Employee to help but there should be a way if the System Administrator on a single system lost or forgot their password.


    *http://news.cnet.com/8301-1009_3-57501931-83/hackers-vow-hellfire-in-latest-majo r-data-leak/

  • laul Level 1 (0 points)

    To be honest, that's not me, but my father wo did... so, I don't know if he was asked for a hint. But what I'm sure is that popup window for the password never let me know the hint if it was one...

  • laul Level 1 (0 points)

    As told before, I didn't create the password but my father. I'll asked him to have a look on your explanation. However, I'm pretty sure it's an old file, older then his computer. But I keep my fingers crossed !


    I already tried using terminal to show the content of package. I also tried virtually zipping and unzipping. but unable to perform.


    I totally agree with your last sentences ; and, really, apple would think a way to improve all it's cloud files management system to be more efficient and helpfull for users... The proof is probably written by Jerrold Green1 : "You are not the first person to come with that problem".

  • Jerrold Green1 Level 7 (29,955 points)



    Please don't mistake my comment. I beleive that if you apply a password and then forget or lose the password, the file should be lost. If it is possible to bypass the password, the password feature is of little value.


    I'm sorry about your misfortune.



  • Marc2012H Level 1 (0 points)



    Mine is a bit weird.


    At first, I set a password to a specific document, and been using the same password for almost a thousand time, BUT today I tried to go in my document, but Pages won't let me in and it said it's a wrong password (?!), plus I NEVER change my password and how come suddenly my password didn't work....


    Please help...




  • Josielee1101 Level 1 (0 points)

    Hi! I hope you are seeing this. I have the same problem as him, and my file is a recent one yet I guess is due to the change of OSX, I can no longer find the button u taught. Is there any methods for the latest OS X version that can help me with my file? Thanks loads