12 Replies Latest reply: Nov 26, 2012 10:01 PM by léonie
Michigan One Fly Level 2 (240 points)

I have a strange issue with the help menu.  I am on Mountain Lion on 2 MBP computers and Snow lepoard on an iMac.  The iMac works fine. On both MBP if I select help in th emenu bar and and go to Aperture help and then select a topic I get the screen below.  Same problem with ontacts Help and iCal Help.  Problem may be on all of the programs, but i haven't tried them all. 

I am guessing it is actually a Mountain Lion issue, but questions get more attention on the Aperture and FCPX forums so I thought I would try here first.

Any Ideas?  I deleted the plist for help , but that didn't help ( no pun intended)

MacBook Pro (17-inch Mid 2010), OS X Mountain Lion (10.8.2), Aperture, FCP X
  • Michigan One Fly Level 2 (240 points)

    I foregot to add the screen shot.

    help screen2012-11-25 at 10.16.14 PM.png

  • Aye Es Oh Level 2 (330 points)

    If this is affecting the Help Center for many different applications, you could try reinstalling the Mountain Lion combo updater. Not sure if it'll work, but it's worth a shot.

  • Kirby Krieger Level 6 (12,510 points)

    This is really an OS X question.  I've seen this happen, and I've seen it go away after rebooting or restarting once in Safe Mode.  Weak tea, but warmly served  .

  • léonie Level 10 (90,550 points)

    Starting yesterday it happened on my machines (iMac, MBP) too in iPhoto and Aperture  - in different locations, so it cannot be a network problem. I suspect that the help site really is not reachable, maybe dut to maintainance work on the help database. Which would be great.






  • Frank Caggiano Level 7 (25,715 points)

    Appears to be working now. If you still have probelms post back.

  • Michigan One Fly Level 2 (240 points)

    I just checked and I couldn't get any of the topics in Aperture Help. 

  • Frank Caggiano Level 7 (25,715 points)

    If you open Finder and select Help and then Help Center do you get this splash screen:


    Screen Shot 2012-11-26 at 13.39.52.png


    If so and you click Help for all your apps what happens?


    If even the first Help screen doesn't appear you should reboot your system and try again.

  • Michigan One Fly Level 2 (240 points)


    In all cases I can get the first splash screen including the one you show in your reply.

    In all cases when a select a topic I get the splash screen that says the topic is unavailable. 


    I shutdown my MBP each night as does my wife on her MBP.  I have deleted the plist for help and help view, emptied the trash and restarted, no change.  I am reluctant to reload Mountain Lion as I am on a Satelite system for internet.  I may drag my MBP to the coffee shop and or the Library and try that.  Though I doubt the network ISP has an impact because our iMac on Snow Lepoard loads the help screens fine, though that is a different operating system and different version of the applications, and I don't have Aperture on that machine. 

    Though that might be a good test,  Can I download Aperture from the App store if I bought my original at a Apple Store and loaded it from a disk?

    Later tonight I am going to try Kirby's suggestion and try starting up in Safe Mode.

  • Michigan One Fly Level 2 (240 points)

    I did a Safe Boot,  Apertiure is not available in this mode on my machine because  the graphics card is disabled.  So I tried contacts and then OSX Mountain Lion.  Could not get to a selected Topic in any attempt except the last one listed in Mountain Lion , I don't recall what it was, other than it was another help splash screen of some type.


    A restart in normal mode and no improvement.

  • Frank Caggiano Level 7 (25,715 points)

    In one of your earlier posts you mentioned your wife's MBP when I suggested rebooting your system. Is the problem happening on her systems also or did you just mention the other machine in reference to rebooting?


    Can you access help for any of the topics or for any of the Apps?


    Assuming that the problem IS NOT happening on the other system I would suggest you create a new user on your machine, log in as that user and see if the help system works for that user.


    Post back the results

  • Michigan One Fly Level 2 (240 points)


    Basicly we can't access help topics on either MBP for any application that I have tried and I have tried about half a dozen.


    When you say reboot......I am assuming that would mean to shut it down.......wait a few minutes then restart it.  Or is there some other procedure that should be tried.


    I frequesntly repair permissions,  I am not sure when I did that last.  I give that a shot next.

  • léonie Level 10 (90,550 points)

    What is the last software you installed on both your mac and your wife's mac? Do you use any helper applications that might be blocking the internet access to certain sites, like "Little Snitch"?