Previous 1 2 3 4 5 6 Next 77 Replies Latest reply: Jun 22, 2015 10:01 AM by Kevin Boers Go to original post
  • Hellcat840 Level 1 Level 1

    Thanks I wasted alot of time on this this until I read your post.  This worked!!!  iMessage and Face Time finally working properly on a late 2010 macbook air running mountain lion.  Thanks again for providing an actual solution.

  • mabela Level 1 Level 1

    YES, toddwest24 that worked!

    Thank you.

  • juanmdt Level 1 Level 1

    dude, toodwest24 it works great men... Thanks a lot.

  • HIGHTECHDUDE Level 1 Level 1

    SOLUTION:

    • Step 1 - REBOOT your machine.
    • Step 2 - Login to FaceTime
    • Step 3 - Enjoy 

     

    This has worked everytime for me.  I've encounted this issue on three MacBooks, apparently after a software update.  If this doesn't work for you, then toddwest24's solution seems to have helped a lot of other folks.

  • applecable Level 1 Level 1

    I wish I could share everyone elses enthusiasm here. I have tried all the recommendations (Host file reset, clearing cache, looking for iphone certificates, auto time settings etc etc) and still continue to get the error..! I've all but given up.

  • scotartt Level 1 Level 1

    Absolutely I have tried all these solutions listed here and imessages on the Mac (not on the OTHER MAC, nor on my iOS devices) is HOSED.

  • ahaverick Level 1 Level 1

    Thanks alot man!!! That worked! I ended up having to restart after fixing the hosts file, but Facetime and messages works great now!

  • mediashrink Level 1 Level 1

    Thanks for posting this; I tried replacing the hosts file with no luck but after your post about the serial number, I checked that too. I recently had my MBP logic board replaced (twice) as the video card was defective.  As you suggested, the machine doesn't know it's serial number.  I will make an appt to take it in unless someone can tell me how to fix it myself.  I'm traveling for the next couple of weeks and neither Facetime nor Messages work.

  • Kelly the ex-PC user Level 1 Level 1

    I've read this entire thread and gone through ToddWest24's process, but I am getting a different response than I've seen here: when I try to move the Hosts file back into my Finder from my desktop, here's the message I get: "The item “hosts” can’t be moved because “etc” can’t be modified."

     

    Any ideas?

  • rgummy Level 1 Level 1

    Thanks Todd, it worked for me as well.

     

    Be sure to reboot your computer for it to take effect. WHEW!

  • rgummy Level 1 Level 1

    It asked me to authenticate, which I did, and then had to put in my login password, and then was prompted to replace the file. Once I clicked replace, it did. Then I tried FT and it didn't work. After reboot, it worked like a charm.

     

    Make sure to reboot after doing it.

  • rgummy Level 1 Level 1

    By the way, once I got FT working, I unclicked the auto time zone feature so it wouldn't screw up my calendar and so far so good!

  • scotartt Level 1 Level 1

    After I did all this (for the second time) and rebooted with a PRAM reset iMessage finally came alive and allowed me to login again.

  • chrissymichelle Level 1 Level 1

    Todd, you are my hero.

    Also, I'd like to point out that your experience with Apple Support seems to be common - remember when the iPhone 4 came out and it was tearing through data? Every call we made to Apple was met with a "I've never heard of this issue" but it was all over the forums. Drives me crazy!!

  • scott290 Level 1 Level 1

    Thanks toddwest24.  Worked for me.  Other people say they did not need to restart after fixing the hosts file, but it wouldn't work for me until I restarted, so if todd's solution isn't fixing the problem, try restarting.