11 Replies Latest reply: Nov 26, 2012 8:48 AM by tzbikowski
kathermackey326 Level 1 (0 points)

how can i share my cable internet with my android smartphone?


MacBook, Mac OS X (10.6.8)
  • tzbikowski Level 4 (1,945 points)

    You need to add wireless router or access point to your wired newtork.

    You can use Airport Extreme or simpler Airport Express from Apple Online Store.

  • kathermackey326 Level 1 (0 points)

    isnt there a faster way? like sharing with bluetooth?

  • tzbikowski Level 4 (1,945 points)

    Yes,

     

    if your MacBook is connected via cable you can share the connection over your WiFi card.

     

    here is the link:

    http://www.mactip.net/share-internet-connection-mac/

     

    scroll down to the second section

  • kathermackey326 Level 1 (0 points)

    i tried this already but on the right side it doesnt let me change anything...everything is grey :/..look

    Sans titre.png

  • tzbikowski Level 4 (1,945 points)

    Can you untick it on the left and tick again?

     

     

    Also you cannot share Internet Connection to the same Ethernet interface as it is ticked at the moment.

     

    Share your connection from Ethernet

    and blow when is not greyed out you should choose AirPort

     

    Let me know if this is still greyed out after the un/ticking.

    Also are you sure you want to share all? as per your screenshot above.
    This is not a good practice. Shar only what is needed and untick the rest.

  • kathermackey326 Level 1 (0 points)

    it works !! i hav internet now on my smartphone , but ..can you just tell me how to put a password on my wifi connection now? :/ cause it doesnt have one and everybody can access to it...i couldnt find an option to seal it with a password..

  • tzbikowski Level 4 (1,945 points)

    great.

     

    Yes you should protect it with a wifi key.

    Once you ticked - To computers using:  AirPort

    you should have a new button below (AirPort Options)

    You can change your network name there and setup security.

    Quite straight forward but please let me know if you get stuck.

  • kathermackey326 Level 1 (0 points)

    now everything is ok i put a password, i just needed to untick it again ..but now on my smartphone when i connect and type the password it tells me that my macbook wifi is disconnected :/ sorry to bother you

  • tzbikowski Level 4 (1,945 points)

    not a problem

     

    Your Android device probably remembers the network as unsecured one and tries to connect to it this way.


    On Android you need to go to wifi settings and forget this network.


    And try to connect again.

     

    Also if you can restart both devices after you removed the network before connecting it again.

    Another way would be to change the WiFi network name slightly so Android connectss to a new one.

    If that makes sense.

     

    Let me know if any problems.

  • kathermackey326 Level 1 (0 points)

    After some issues I finally managed to make it xD but you´ll neva guess what the solution was! i was so desperate and tried everything you told me.

    You know when you can change your password there was written that if you want 40 bits you need a 5 caracter password and for more bits you need 13 caracters or so.

    I thought it was minimum 5 so of course I put a longer one to be more secure. But it showed me disconnected on my phone...i was at my end...and then i saw this and jus deleted a few letters of my password to make it up to 5 and it worked then

     

    Thank you very much for your help and patience

  • tzbikowski Level 4 (1,945 points)

    You're right - I would have never guessed - or maybe after a day of furher troubleshooting :-)

     

    All the best.