10 Replies Latest reply: Nov 24, 2015 10:10 AM by jk.mac
elmalo68 Level 1 Level 1

Hi,

 

I have an iPhone 4S and a 13" MacBook Pro. Both pieces of hardware are up-to-date in terms of software.

 

I've been using Messages on the laptop without any problems until this past week. Almost everyday now, whenever I launch Messages, I'm seeing a new text that never made it to my phone.

 

The most recent example was a text that was sent yesterday. It never appeared on my phone, but as soon as I launched Messages on my laptop this morning there was the text.

 

I've searched the forums and Google and I can't find any other instances of this issue.


iPhone 4S, iOS 6.0.1
  • rln5899 Level 1 Level 1

    I have this same problem but with my Ipad, imessage isnt working on my phone at all anymore no matter what i do! when someone texts me using their imessage it goes to my Ipad i get nothing on my phone.

  • Avery Z. Chipka Level 2 Level 2

    Same problem for me

  • Avery Z. Chipka Level 2 Level 2

    I managed to fix mine by turning off iMessage via the iphone system preferences and then turning imessaging back on.

     

    On your iPhone open system preferences. Select messaging. Switch iMessaging to off. When you do this you should see the phone number vanish from your iMessage on all other device. Once you confirm this turn your imessaging on the phone back on and then reanble the number (which will once again show up) on your other devices.

     

    Problem solved.

  • Avery Z. Chipka Level 2 Level 2

    *DUP POST* SORRY

  • ksqmusic Level 1 Level 1

    Old thread, but this just happened to me. It Started out of the blue- and was quite irritating. Would send a imessage on my iphone- and not see that someone replied until I looked at my computer.

     

    Here is what fixed it for me:

     

    Go to Settings -> Messages -> Send & Recieve. Under "Start New Conversations From" - make sure your phone number is selected, not your email adress. This immediately fixed the delivery issue for me.

     

    Hope this helps!

  • YahMonMan Level 1 Level 1

    Avery, you ROCK!

     

    Old thread but current problem and extremely frustrating and annoying! I have consistently been finding important messages on my MacBook Pro a day later when I had my iPhone with me the entire time!  I have spent hours trying to figure this thing out. YOUR method is so simple....

     

    When I turned off Messages in my iPhone my number did NOT disappear from the preferences panel in my Mac's Messages app or anywhere else. But I just waited a couple minutes before turning Messages back on in my phone and, voila, problem fixed!

     

    Thanks Avery!

  • dpasseto Level 1 Level 1

    Avery, that was awesome man.  Thanks for the simple explanation.  Did the trick for me. 

  • drownloader Level 1 Level 1

    I just tried this and it did *not* work. I still have a message showing up on my laptop but not on my phone, although the rest of the message thread with the same person showed up on both. I totally restarted phone a minute or two after disabling the iMessage, but still...no dice.

  • jackfromnorman Level 1 Level 1

    It didn't work for me, either. I need this resolved!

  • jk.mac Level 1 Level 1

    What worked for me was to go to the Messages page under Settings on my iPhone and under Send & Receive I added my iCloud password and login. Then on my mac I was able to select "Start All Conversations from iPhone"