1 Reply Latest reply: Jan 24, 2014 12:32 PM by l f fromsalisbury
JynMeyer Level 1 (0 points)

I recently receved an alert message on my macbook pro via iCal stating,

"The server responded with an error. The request for account "iCloud" failed.

The server responded with “502” to operation CalDAVAccountRefreshQueueableOperation."

It then gave me 2 options to stay online or go offline.


Screenshot below:


Screen Shot 2012-11-26 at 10.00.33 AM.png

Pressing "Go Online" just reloaded the pop-up error message again. After going onto my browser and researching this issue- I found thread after thread of other people with the same issue- some relating it to Yahoo! or Google Cal syncing and some even tried resolving it by deleting accounts and renaming others.


My cal is only used through my iCloud. So I did a little digging.


I went into iCal preferences and clicked on "Edit Account". It hung.

At this point, my uneducated guess was that it was an iCloud communication issue- not an iCal issue.

I then went into System Preferences for my Mac and selected iCloud (under Internet and Wireless) and then 'Manage' at the very bottom. I received this message:

Screen Shot 2012-11-26 at 10.16.15 AM.png

So it was definitely a connectivity issue from iCloud to my device. I clicked my wireless off and then on again to try and reset my connection and it loaded my storage details after.

I went back into iCal and I no longer recieved the error.


So, the moral to this thread is that I figured out how to fix it on my end but I still am not completely sure of what caused it- be a connectivity error or hang up on iCloud or my own device, but if iCal cannot talk to iCloud, it's going to error. Hopefully this helps someone else.

MacBook Pro, Mac OS X (10.7.5)
  • l f fromsalisbury Level 1 (0 points)

    "I then went into System Preferences for my Mac and selected  iCloud (under Internet and Wireless) and then 'Manage' at the very  bottom."

      I tried something different: I entered my Apple ID and pressed Done; then opened the iCal, and found it worked perfectly/

       The reason [in my case] is that I had just had to re-establish my identity - when Apple migrated accounts from @me.com to iCloud, it appears to have lost my details. So I could not log in, and my password was not recognised; and when I tried to work round that by answering my security questions it told me I had entered the wrong information for my own birthday!!

       Googling 'find my apple ID' gave me a link to restore my identity, and provide a new password.

    I believe this caused iCloud to have a spasm, and that stopped iCal, and my gmail account from working.

       So - by clicking 'Manage' on iCloud in the System Preferences [see above], I entered my new password, and restored function.