5 Replies Latest reply: Nov 27, 2012 1:46 PM by tbrucebowers
tbrucebowers Level 1 (0 points)

I have a Mac Book Pro running 10.6.8. Somewhere along the way something got messed up in the permissions (I assume) and none of the user preferences are saved i.e. items added to the toolbar in Safari, iTunes account log in, prefered browser, browser window size and position, etc.


I have run Disk Utility a number of times, and every time it "repairs" dozens of permissions, and when I run it again, it repairs the same ones (pretty sure anyway) definitely dozens of repairs everytime, no matter how many times I repair.


I did a user migration to a clean install, no help, all the old problems came with the migration. I have reinstalled the OS twice since then. Hoping I won't have to wipe the drive and start from scratch.


Thanks, T Bruce

MacBook Pro, Mac OS X (10.6.8)
  • seventy one Level 6 (12,665 points)

    One thing you should not get het up about is the string of repairs consistently arising from repairing permissions.   There are various reasons why this happens but the key to it all is the message at the end.   "Permissions repair complete" in green writing means all is good.

    One last thought.   Have you updated your 10.6.8 via the combo update.   If you haven't you should do.



    Mac OS X 10.6.8 Update Combo v1.1

  • tbrucebowers Level 1 (0 points)

    Thanks for the reply.


    I have not installed that update manually, but I have run Software Update repeatedly until it says that I am up to date with all software.


    I'm not concerned so much about the long list of repaired permissions. It's the problems I am having with user preferences that I described above that are making the machine a real pain. Do you have any suggestions for tracking down the cause of that problem?

  • seventy one Level 6 (12,665 points)

    It would seem to me that you haven't downloaded the 10.6.8 Combo update I recommended.   The point I have in mind is that the software update you have been repeatedly applying is only updating the requirements of your original 10.6.8. not the 10.6.8 system you would have had, had you applied the Combo update.


    One follows the other and in effect tidies up the system.


    tbruce, I am hugely sysmpathetic to your plight but you have to sort out your system in strict order.   The clean install of the OS should only take you to 10.6.3, after that you will need the Combo as a matter of course and then the security updates via software update.


    I do have a problem because I am not acquainted with MacBook and that may be the difference.   It does cross my mind to ask if you are the original owner, if it was bought with 10.6.8 and what "about this mac" says in terms of the version number after one of your clean reinstalls.

  • WZZZ Level 6 (12,795 points)

    First off, Permissions repair won't touch anything in your user. Stop repairing Permissions. Generally a waste of time anyway.


    Do a GetInfo (Cmd-I) on the Preferences folder in your user (home folder) Library. What does it say for Sharing and Permissions?


    It should show that you, your user, has Read and Write and everyone No Access.


    I would suggest using the following procedure to reset your home folder Permissions, which may fix this problem.


    1. Boot from the Mac OS X Install Disc:
      1. Insert the disc.
      2. Shut down the computer.
      3. Turn it on again whilst holding down the C key.
        You can let go when you see a spinning dial.
    2. Click through the menus until you after you’ve accepted a license agreement.
    3. Snow Leopard: At the top, click Utilities -> Reset Password.
      Lion: At the top, click Utilities -> Terminal. Type resetpassword in the Terminal and press Enter.
    4. Click on your main hard drive.
    5. In the dropdown box under “Select the user account” make sure to select your username.
    6. Underneath where it says “Reset Home Directory Permissions and ACLs”, click the Reset button.
    7. Press cmd + Q to Quit the Reset Password application. Press it again if you have a Terminal open.
    8. Click Mac OS X Installer in the top left and click Quit Mac OS X Installer.
    9. Click the Startup Disk button.
    10. Click on your main hard drive and click the Restart button.


  • tbrucebowers Level 1 (0 points)

    GetInfo for my user Pref folder shows admin group (which I am one of) has R/W access.


    The “Reset Home Directory Permissions and ACLs” did the trick.


    Thank you. I had seen that suggestion in my searches, but had not got around to it yet. So, you get the points from me ;-) It even solved an ancillary issue I had with USB devices not communicating with appropriate applications. I've got a brand new squeeky clean computer now, thanks to the efforts of everyone here. Thanks.