6 Replies Latest reply: Feb 17, 2013 4:39 AM by Tom Delpech
alpakkaya Level 1 Level 1 (0 points)

Hello,

 

I've iPhoto 11, I can copy some events(with 80-100 photos) but some events are can't be copied, when i drag&drop to desktop or flashdrive, nothing happens. I tried to repair Disk permissions but nothing changed.

 

Please, it's kinda urgent, anybody can help me?

 

Thanks,

Have a good one


iPhoto '11, OS X Mountain Lion (10.8.2)
  • Terence Devlin Level 10 Level 10 (133,920 points)

    Select one of the affected photos in the iPhoto Window and go File -> Reveal in Finder -> Original. A Finder Window should open with the file selected. Does it?

  • alpakkaya Level 1 Level 1 (0 points)

    It finds the photo, and i can copy it, there is no problem with that.

     

    The thing is i can't copy them all by drag&drop from iPhoto to a desktop folder. I think there is a permission error somewhere...

  • léonie Level 9 Level 9 (75,485 points)

    What happens, when you try to drag and drop these events? Do you get an error message?

    Can you export those events with by selecting them and using the command "File > Export" from the main menu bar?

     

    Regards

    Léonie

  • alpakkaya Level 1 Level 1 (0 points)

    Well, when i drag the event to desktop my mouse pointer turns to a plus sign that tells me it's ok to copy, but when i drop it, nothing happens, no errors, nothing.

     

    This happens for just a few events, there are lots of events that i can easily drag and drop them whereever i want.

     

    Yes, i can export them too, i can copy them when i enter in the event too.

     

    Thanks for all

  • léonie Level 9 Level 9 (75,485 points)

    I'd try to repair your iPhoto library.

    Make a backup copy of your iPhoto Library and try to use the built-in FLibrary First Aid Tools:

     

    • Quit iPhoto if it is open.
    • Hold down the Command and Option keys on the keyboard.
    • Open iPhoto.
    • Keep the keys held down until you are prompted to pick a repair option.
    • Select the options you want to use and try them all in turn, beginning with repairing the library.

    Regards

    Léonie

  • Tom Delpech Level 1 Level 1 (0 points)

    Hi Alpakkaya,

     

    I just ran a quick search on this forum after experiencing this very same problem. However, the answer to fix this doesn't seem to be in this thread. How did you resolve this? With the 'export' from the 'file' menu? ... but what about when you have a mix of photos and videos in your event? does it work fine?

     

    This problem occurred the first time on my mac while I was browsing photos. Suddenly all the thumbnails of my library turned black (with no previews). In a bit of a panic, I restarted Iphoto and it looked fine at first glance.

    But later on, I realised that some photos were rotated in the wrong direction. More bizarrely some old photos I've deleted were back in some events.

     

    It's from that day that I was unable to drag and drop whole events on the desktop or on external hard drives. Some events work fine but other are a real nightmare. Sometimes I can get away by copying entire rows of pix, but sometimes I literally have to drag and drop photos one by one to archive them.

     

    I've tried all the options of re-building and repairing the library but nothing worked,

     

    This is so annoying!!!

     

    If you or anyone else have somehow found the cause of this problem. Please let me know.

     

    Thanks in advance.

     

    Tom