Previous 1 2 Next 29 Replies Latest reply: Nov 19, 2014 1:59 PM by gromit95
James Phoenix Level 1 Level 1



I have tried everything from starting in safe mode to installing original RAM to using disk utiltiy from start up disc and i can't get my iMac to get past the gray screen with the spinning (all gray) icon. Now it isn't recognizing any keyboard touches and won't eject the disc in the drive.


It just sits there spinning the icon or shuts down after trying to start up.

I've tried everthing it says here: // but nothing is working.


Any ideas?



(I started another discussion with this topic but i forgot to put the right title on it)



iMac (20-inch Late 2006), Mac OS X (10.6.8), 4 GB RAM, ILife '11
Solved by BDAqua on Dec 17, 2012 10:53 AM Solved

Great to hear, thanls for the report!

Reply by BDAqua on Dec 7, 2012 4:28 PM Helpful

No Pageouts are reasonable I think.


Have we tried to run a Memory test yet?


Boot off your *original* Install Disk while holding down the *d key*, (not c key), then run the extended Apple Hardware Test. Some disks require you to use the Option key at bootup to select AHT. Some Discs have it inexplicably on Disc #2. Some models have a separate AHT CD.


The Memory test can really only be trusted if it finds a problem, not if it doesn't find a problem.


Memtest OS X...


Rember is a freeware GUI for the memtest ...

All replies

  • BDAqua Level 10 Level 10

    Hi James, I get nothing at the link...



    So not sure what you tried.


    Does holding Mouse button down at powerup eject the Disc?


    Is this a USB KB/Mouse, or Wifi?


    Off hand I'd say it's a serious HW problem, most likely the Hard Drive.


    Intel-based Macs: Resetting the System Management Controller (SMC)...


  • James Phoenix Level 1 Level 1



    Thanks for the replies. I am using my fathers computer in his house to access the intenet so my replies will be delayed some.

    My keyboard and mouse are bluetooth wireless. I'm trying to get ahold of wired ones.


    This is the page for things tried:

    It's basically disconnecting external devices, safe boot, reset of NVRAM/PRAM, disk utility from snow leopard disc and original which is the one stuck now, removed third party RAM and checked cables/power sources.


    With the startup disc i used disk utility to verify disk and it couldn't due to an error. It said to start up the computer with MAC OS X installation disc. Tried that and it said "1 volume could not be reparied because of an error".


    Now it won't eject the disc and it won't go any further than the gray screen with apple logo and spinning icon.

    It just shuts down. Holding mouse button down  doesn't do anything. Neither does holding down the various keys at startup.


    It is an intel mac but i can't reset the SMC as i can't access anything. All i can do is power it up and then it shows me the gray and some progress bars which don't progress and shuts down.



  • BDAqua Level 10 Level 10

    Does it boot to Single User Mode, CMD+s keys at bootup, if so try...


    /sbin/fsck -fy


    Repeat until it shows no errors fixed.


    (Space between fsck AND -fy important).


    Resolve startup issues and perform disk maintenance with Disk Utility and fsck...



    Just recently I ran into a problem when I tried to Verify my hard disk and when it tried to verify the catalog, it responded "Invalid sibling link." Repair Disk didn't work. I searched the web and Apple's site, and couldn't find anything useful except to buy DiskWarrior or reformat the drive. Knowing that OS X is built on Unix gave me a few clues on how to proceed. The solution is pretty simple:

    1. Boot off the OS X CD (reboot, hold C while booting).
    2. The installer will load up, go to Utilities in the menu and run Terminal.
    3. Type df and look for the drive that has your Mac system mounted---you'll have to unmount this. On my MacBook Pro, it was /dev/disk0s2.
    4. Type umount /dev/disk0s2, replacing disk0s2 with whatever disk your OS lives on.
    5. Type fsck_hfs -r /dev/disk0s2. If you umounted the wrong thing, it will complain that you can't repair a mounted drive. Go back and umount the right thing and repeat this step.

    Just for fun, you might want to run another fsck_hfs on your disk (use the -f option because your drive is probably journaled). Hope this helps someone so they don't buy a program that's going to do pretty much what we did with fsck_hfs, and so they don't waste time searching for an answer to no avail. By the way, TechTool Deluxe (3.1.1) didn't find the Catalog problem for some reason (you'll have this on a CD if you have AppleCare), which is why I resorted to fsck.


  • James Phoenix Level 1 Level 1



    I will need to get a wired keyboard from someplace as it's not responding at all to the wireless one.

    Once i get that i will get back to you, hopefully in the nest few days.


    Thanks for your suggestions.

  • James Phoenix Level 1 Level 1



    So i have got a wired mouse and board and got the disc out with no problems.


    I have tried pretty much everything now including the single user mode thing you posted.

    It always says says error and will not correct it each time.


    I used the disk management tool to try and repair the disk but it was unable to complete and still says 'volume needs repair'. So i just did and erase and install on the drive and then did a system restore using time machine which it said was successful but then it would not restart and gave me the gray screen again!

    So once more i did a erase and install and tried to install snow leopard but it would not restart!


    Now i have it with the basic Tiger OS X which works but everything takes a lifetime to do. Starting up or shutting down takes 2 or 3 minutes. Opening applications such as safari or iphoto has a really bad time delay. Even typing is a time consuming exercise. You type a few words and it has to catch up.


    I tried dragging and dropping files to my hard or flash drives and it does it okay.

    I tried using text edit and saving what i wrote and it did that okay too.


    I have tried pretty much everything i can think of or what i can see on the web.


    Any ideas where i can go from here?



  • BDAqua Level 10 Level 10

    See if the Disk is issuing any S.M.A.R.T errors in Disk Utility...




    Open Activity Monitor in Applications>Utilities, select All Processes & sort on CPU%, any indications there?


    How much RAM & free space do you have also, click on the Memory & Disk Usage Tabs.


    Open Console in Utilities & see if there are any clues or repeating messages when this happens.


    In the Memory tab of Activity Monitor, are there a lot of Pageouts?


    Is Spotlight still trying to Index the drives?

  • James Phoenix Level 1 Level 1



    a lot of that is over my head so here is what i do and do not understand.


    Checked disc utility and it has no messages for s.m.a.r.t.


    As for the 'all processes/CPU' i don't know what I'm looking for there.


    I have 4GB of RAM and the hard drive is empty with 229GB of 250GB.


    Console log looks normal with no repeating messages.


    In memory tab, what's a pageout?


    And i don't know what you mean with spotlight indexing the drive, sorry.




  • James Phoenix Level 1 Level 1

    In console.log the last line says:


    95 can't check in with server namwed,metadata.mdserver, error 0x10004004


    Does that mean anything?

  • BDAqua Level 10 Level 10

    OK, the Spotlight DB is messed up...


    For now...


    1. Open the System Preferences.
    2. Go to the Spotlight pane and click the "Privacy" tab.
    3. Drag the all disks to that window.
  • James Phoenix Level 1 Level 1



    Okay now it looks like my disc has vanished.


    The computer won't start up and i can't do another fresh install as there is no destination volume for the software to be installed into.


    Where do i go now?



  • James Phoenix Level 1 Level 1

    So I've got the disc back into it to try and do another fresh install biut it has no destination disc.

    Even in disk utility the 'macintosh' drive is not highlighted. The 232.9 GB WDC drive above it is though.

  • BDAqua Level 10 Level 10

    WDC is the whole drive, Machintosh HD is the single Partition, can you afford to erase the Disk?

  • James Phoenix Level 1 Level 1



    I had to erase the disk for the computer to see it, which worked.

    I then tried to do a fresh install but it's not asking for the second disc now.



  • James Phoenix Level 1 Level 1

    Starting again. I couldn't get it to finish the install.


    Do you have any idea what is causing any of this?


    I don't know about you but i am getting really fed up. It's been a week of trying and I've just saw that the new imac's are out! Ah to have a computer that works.



Previous 1 2 Next