1 2 3 4 Previous Next 48 Replies Latest reply: Mar 23, 2014 12:15 AM by Lonny Eachus Go to original post
  • 45. Re: All my system icons dissapeared (finder, menu bar, preferences)
    crushdeluxe Level 1 Level 1 (0 points)

    I think i've sorted it, worked for me anyway.

     

    went to sys prefs - Users & Groups - unlocked the padlock and clicked on my account.

     

    hit the login items tab whch had a load of old log in things I no longer needed.

     

    I deleted them and left Dropbox, ituneshelper (???) and Suitcase which I use for my fonts.

     

    restared and all back to normal for now

  • 46. Re: All my system icons dissapeared (finder, menu bar, preferences)
    tutenchamun Level 1 Level 1 (0 points)

    There seems to be a solution: its called "applejack"

    look over to https://discussions.apple.com/thread/4498102?start=60&tstart=0

  • 47. Re: All my system icons dissapeared (finder, menu bar, preferences)
    SimonDhaenens Level 1 Level 1 (0 points)

    I have the same problem: Finder, preferences, Safari and Mail do not dispay the menu icons.
    I've tried everything listed in this thread, but nothing works. I never had the problem dissappear (others only have it after hibernation/sleep IIRC). Luckily, I've memorized all the buttons throughout the years...
    My rMBP came with a clean install of ML, btw.

    Next to this issue, I have the slow shutdown bug, Mail sometimes quitting on my for no apparent reason, Aperture funkyness (pink and scrambled (or no) previews and main previews dissappear when making adjustments such as rotate or crop), and graphic glitches after sleep mode (white/green/purple specked screen). Cleaning the Safari cache resolves the slow shutdown bug, but the missing icons bug remains.

  • 48. Re: All my system icons dissapeared (finder, menu bar, preferences)
    Lonny Eachus Level 1 Level 1 (0 points)

    I had this problem too. Button icons on Finder and some on System Preferences disappeared. I tried some things like Onyx but I did not want to lose all my customizations.

     

    I tried booting in safe mode, but it had no effect. Then I downloaded applejack, and it worked.

     

    System: Macbook Pro 3,1 running Mavericks (10.9.2).

     

    Install applejack. Restart the computer in single-user mode (hold Command-S on boot).

     

    When you get the command prompt, type applejack then enter. Do not run in auto mode.

     

    Tell it to fix preferences. After it is done fixing system preferences, it will ask if you want to fix user preferences. Tell it yes. Enter your username. If it says it cannot find the username, type in the path to your user home directory: /Users/<username>

     

    That was it. It said it found two corrupt user preference files belonging to apps. I don't know what those might have had to do with Finder, but I rebooted and the problem was fixed.

     

    if that doesn't work, you might try running it again in auto mode ("applejack auto") and see if that helps.

1 2 3 4 Previous Next