10 Replies Latest reply: Oct 20, 2013 4:30 PM by boroc7
gmrsamson Level 1 Level 1 (0 points)

I have been using Compressor successfully for about a year.  Recently it updated to v4.0.5.   Now I am not able to submit, with the final Submit button greyed out.  I have checked my Destination folder permissions and all appear correct.

 

What could be the cause of this, and what shall I do?  I need to render a program urgently for broadcast.

 

Thanks

Geoff


Macbook Pro, Mac OS X (10.6.5)
  • 1. Re: Submit Button Greyed Out (v 4.0.5)
    gmrsamson Level 1 Level 1 (0 points)

    Just to clarify, I am using OSX 10.6.8, 2.53Ghz Intel Core Duo MacBook Pro with 8Gb RAM.

     

    FCPx 10.0.6 and Compressor 4.0.5

     

     

    I have only one computer, so don't require any "clusters".  I am uncertain if I need to tweak settings in the "Apple QMaster" dialog.  I have tried a number of settings.  It seems Compressor requires a "cluster" of some kind, ..though I don't understand ??

     

     

    When I right-click on the Compressor app icon, I see "Status: No Services" listed.  Is this a problem?

     

    I tried the Compressor Repair Tool, but it didn't seem to help.  (However, I opted not to lose my custom settings as they took quite a while to perfect —Is there a way to save them and reload them?)

     

    I have also rebooted.  Any further advice??

     

    thanks

    Geoff

  • 2. Re: Submit Button Greyed Out (v 4.0.5)
    Russ H Level 6 Level 6 (14,255 points)

    Go to toolbar and from Compressor drop down, choose Reset Background Processing.

     

    No, Compressor doesn't require clusters – and IMO, they're often not worth the trouble to set up and use.

     

     

    gmrsamson wrote:

     

     

    When I right-click on the Compressor app icon, I see "Status: No Services" listed.  Is this a problem?

     

     

    WHere are you doing this…in the Finder?

     

    Russ

  • 3. Re: Submit Button Greyed Out (v 4.0.5)
    gmrsamson Level 1 Level 1 (0 points)

    Yes, the "Status:   " is displayed in the Finder shortcut icon.

     

    Geoff

  • 4. Re: Submit Button Greyed Out (v 4.0.5)
    gmrsamson Level 1 Level 1 (0 points)

    The Support page 'Troubleshooting Compressor' (http://support.apple.com/kb/TS1888) has the following instruction.  However, this folder does not seem to exist.  Is this a problem?

     

    thanks,

    Geoff

     

    Clear the QMaster cache

    You can sometimes resolve issues with batch processing by clearing the QMaster cache.

    1. Quit Compressor and Batch Monitor.
    2. In the Finder choose Go > Go to Folder.
    3. In the dialog that appears, type the following path: /var/spool/qmaster/
    4. Click Go.
    5. Drag the contents of /var/spool/qmaster/ to the trash.
    6. Restart your computer.
  • 5. Re: Submit Button Greyed Out (v 4.0.5)
    gmrsamson Level 1 Level 1 (0 points)

    For what it's worth to anyone else investigating, I seem to have now resolved the problem.

     

    These were my steps, although perhaps only the last one was needed, I don't know.

    1.)   Ran the free Compressor Repair Tool (http://www.digitalrebellion.com/compressorrepair/)

           ( btw - Trashing the Compressor preferences doesn't loose custom presets). 

     

    At first this didn't at frist seem to help, as the submit button was still greyed out.  However,

     

    2.)   I clicked on the "Share Monitor" icon, and its dialog opened up saying something to the effect, "No Clusters Found".  A few seconds later "This Computer" appeared on the left, and all well from that point.

     

    So I'm not sure if trashing the preferences had anything to do with it afterall, or if it was simply launching "Share Monitor" that triggered something.

     

    Regards,

    Geof

  • 6. Re: Submit Button Greyed Out (v 4.0.5)
    vjstalker Level 1 Level 1 (0 points)

    Same problem here but unfortunately your solution didn't work for me, "This Computer" never appeared and the fearsome submit-button remained grey. Even a complete uninstall/reinstall (4.06) didn't do the trick. Now Applecare sent me two links I could follow, no guarantees. For free though! So far for professional software.

     

    http://forums.creativecow.net/thread/20/857850

     

    http://support.apple.com/kb/TS1888

  • 7. Re: Submit Button Greyed Out (v 4.0.5)
    markman-Detroit Level 1 Level 1 (0 points)

    Seriously?!  AppleCare sent you to post from 2007 and 2009?  There have been no fundamental updates to how the application is structured and operates since then?  Seems like if it had problems with these previous versions, it CERTAINLY would/should have been addressed in the new, redesigned versions of the App, doesn't it?  I don't mean to bash Apple (although sometimes it IS justified), but this points out that either Applecare and/or the App developers need to really get their act together.  FWIW, Selecting the Share Monitor icon worked for me.

  • 8. Re: Submit Button Greyed Out (v 4.0.5)
    Rust Level 1 Level 1 (0 points)

    I just resolved a similar problem.  I am running OSX 10.6.8 on a MBP 13" 2010.

     

    Once inside Compressor I'd click on "submit" and the drop down window would show "none" next to "Cluster:" and the submit button was greyed out.

     

    I called Apple Care and they had me delete the preference file "com.apple.Compressor.plist" file from my user>library>preferences folder.  This did not fix the problem on its own.

     

    They then had me delete the Apple Qmaster folder from user>library>application support.  This did not fix the problem on it's own.

     

    I then reinstalled the Compressor application itself.  This did not fix the problem on its own.

     

    I then verified permissions and repaired permissions using disk utility.  This did not fix the problem on it's own.

     

    I then clicked on "Share Monitor" which is found on the Compressor task bar.  "This Computer" was displayed in the left column.  I simply clicked on it in order to high light it.  I left the "Share Monitor" window open and went back to the submit panel and "This Computer" was now displayed next to "Cluster:" and the program is now working again.

     

    YMMV.

  • 9. Re: Submit Button Greyed Out (v 4.0.5)
    shippo_uk Level 1 Level 1 (10 points)

    gmrsamson wrote:

     

    For what it's worth to anyone else investigating, I seem to have now resolved the problem.

     

    These were my steps, although perhaps only the last one was needed, I don't know.

    1.)   Ran the free Compressor Repair Tool (http://www.digitalrebellion.com/compressorrepair/)

           ( btw - Trashing the Compressor preferences doesn't loose custom presets). 

     

    At first this didn't at frist seem to help, as the submit button was still greyed out.  However,

     

    2.)   I clicked on the "Share Monitor" icon, and its dialog opened up saying something to the effect, "No Clusters Found".  A few seconds later "This Computer" appeared on the left, and all well from that point.

     

    So I'm not sure if trashing the preferences had anything to do with it afterall, or if it was simply launching "Share Monitor" that triggered something.

     

    Regards,

    Geof

    BRILLIANT! This worked for me.

    Its definitely clicking on "Share Monitor" that makes it work again.

    Good solution.

  • 10. Re: Submit Button Greyed Out (v 4.0.5)
    boroc7 Level 1 Level 1 (5 points)

    Okay...I'm on 3.5 and have the same problem, but I don't see a "Share Monitor" button.  Any other solutions?