3 Replies Latest reply: Nov 28, 2012 2:57 PM by BDAqua
carlor Level 1 Level 1 (0 points)

I have a quite odd issue. Time machine and my time capsule worked perfectly when at some point automated backups failed with a permission error. Interestingly I still was able to mount the disk and volume manually (i.e. through finder) and read and write to it.

After trying some non intrusive procedures I finally decided to delete the sparsebundle and to start from scratch. The data wasn't important at this point. So I tried to change the volume... however the exepected window doesn't pop up instead /var/log/system.log shows:

 

System Preferences[242]: *** -[NSCFString substringFromIndex:]: Range or index out of bounds

 

So I removed the time machines preference file but I still not able to bring up the window to select a different volume.

 

How can I fix this?

 

Thanks


MacBook Air, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (119,365 points)

    Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.

     

    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)

     

    Any change?

  • carlor Level 1 Level 1 (0 points)

    No still the same. As said I can mount the volume and  copy stuff onto it, so doesn't look like a permission problem. I think the issue here is that time machine doesn't allow me to change the volume. When I klick on "Change Volume..." a window should appear but this doesn't happen. Instead

     

    System Preferences[242]: *** -[NSCFString substringFromIndex:]: Range or index out of bounds

     

    This error message sounds like the application trys to access an array with an incorrect index.

  • BDAqua Level 10 Level 10 (119,365 points)

    Yes it is, but you got rid of the .plist for TM right?

     

    Open Console in Utilities & see if there are any clues or repeating messages when this happens.