Previous 1 2 Next 15 Replies Latest reply: Apr 23, 2013 12:37 AM by mhbc
cgawlak Level 1 Level 1 (0 points)

I've recently noticed that my images are coming out very dark when using Aperture to convert RAW files from my Canon G1X. The initial preview is fine but then it changes after a few seconds when I open it for editing. I notice minor differences in all of my images but the problem seems to be most significant among long exposure/night shots. The first image was imported to Aperture 3.4.3 as RAW and exported immediately as JPEG. The second image was opened as RAW in Canon Digital Photo Professional and exported as JPEG using default settings. Can anyone help? I'm using a Macbook Pro 2.2 GHz running OS X 10.8.2.


Aperture 3, OS X Mountain Lion (10.8.2)
  • Aye Es Oh Level 2 Level 2 (330 points)

    Is the poor exposure seen in Aperture itself, or just in exports? Do you have any special settings set on your camera? I wonder if you'd see the same result if you reset the camera to its default settings, aside from exposure settings, of course.

  • cgawlak Level 1 Level 1 (0 points)

    The poor exposure is seen in Aperture. It changes moments after you import a RAW file and select it for the first time. There were no special settings on the camera, just the regular adjustments to things such as aperture and shutter speed.

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Have you tried the latest RawCamera.bundle (4.02 released yesterday). While this problem isn't specifically addressed in the update it might have been fixed.


    If 4.02 doesn't fix it have you sent feedback to Apple concerning this?

  • cgawlak Level 1 Level 1 (0 points)

    Updated to RAW 4.02 and the problem wasn't fixed. I contacted Apple today...

  • mhbc Level 1 Level 1 (0 points)

    I'm having exactly the same problems with my Canon G1X & long exposure RAW images. This only occurs with Apple products - Core Image - Colorsysnc - Preview - Aperture. When using Canon's Digital Photo Professional or ImageBrowser there are no problems with the color cast on RAW images. I have seen this topic elsewhere & the general consensus is that is is an Apple problem.


    I'm running :

    OS X 10.7.5 - 21.5 in 2.5 Ghz & a AMD Radeon HD 6750M

    All software updates are implemented.


    RAW files of short exposure are ok only the long exposure images are a problem. Tried out all suggested corrections - Aperture repair data base - Aperture restore ..... etc. Run Onyx to reset user apps - run colorsync to verify colors ......


    No I think this is a genuine Apple problem but its going to take a while for them to fix it. I hvae a suspicion that they have not adapted their software to the AMD graphics card as I have problems using Core Image fun house.


    One other thing I used the Previe 5.5.3 - Tools - Assign Profile but it does not assign to the new selected profile even though the file is editable. The soft proof profile does work but none of the selected profiles corrects the green image problem.


    Should I find some resolution on this I'll let you know

  • léonie Level 10 Level 10 (82,085 points)

    There have been two previous threads on poor results for raw developement with images with difficult lighting situations: In these cases the images have been taken in artificial light, and the resolution of the details in the background was very poor and the colors were wrong, see:

    Canon 6D RAWs processed awfully bad?!


    Re: Strange blue color

  • Keith Barkley Level 5 Level 5 (5,820 points)

    If you are shooting raw, turn off any highlight optimization. It works fine for JPEGS but the under exposure ends up in the RAW file.

  • mhbc Level 1 Level 1 (0 points)

    Keith, thank you for the input. I generally shoot in Manual mode only & any highlight optimisation is turned off. I see from the manual it is possible to adjust images on the camera so I might try that  & see if it has any effect.


    Could be that Canon DPP app handles the long exposure by using the ITU-R BT.709 conversion.

    I ran a scan for ITU-R BT.709 in the /Applications dir & it showed up in /Canon Utilities/Canon MOV Encoder/ …….

    also in /System dir




    ./Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework /Versions/A/Headers/Transform.h

    I think a simple short cut to resolving how Apple handles sYCC CR2 information is for someone to try out Final Cut Pro X & see if the problem occurs there.

    ------------------------------------------------------------------------------- ------------

    The following makes interesting reading :

    Canon CR2 specs

    Canon CR2 files sYCC


    ITU-R BT.709 conversion

    A different form of Y′CbCr is specified in the ITU-R BT.709 standard, primarily for HDTV use. The newer form is also used in some computer-display oriented applications. In this case, the values of Kb and Kr differ, but the formulas for using them are the same. For ITU-R BT.709, the constants are:

    Kb = 0.0722

    Kr = 0.2126


    Out of interest here's the Exif


    Aperture Value: 5.312

    Color Space: sRGB

    Components Configuration: 1, 2, 3, 0

    Compressed Bits Per Pixel: 3

    Custom Rendered: Normal process

    Date Time Digitized: 2013:03:05 03:35:40

    Date Time Original: 2013:03:05 03:35:40

    Digital Zoom Ratio: 1

    Exif Version: 2.3

    Exposure Bias Value: 0

    Exposure Mode: Manual exposure

    Exposure Program: Manual

    Exposure Time: 40

    File Source: DSC

    Flash: Flash did not fire, compulsory flash mode

    FlashPix Version: 1.0

    FNumber: 6.3

    Focal Length: 17.505

    Focal Plane Resolution Unit: inches

    Focal Plane X Resolution: 5,905.021

    Focal Plane Y Resolution: 5,902.351

    ISO Speed Ratings: 800

    Max Aperture Value: 3.625

    Metering Mode: Pattern

    Pixel X Dimension: 4,352

    Pixel Y Dimension: 3,264

    Scene Capture Type: Standard

    Sensing Method: One-chip color area sensor

    Shutter Speed Value: -5.312

    White Balance: Auto white balance

    AFInfo: 0.4100414, 0.4096201, 0.1799173, 0.1807598, n

    Firmware: Firmware Version 1.00

    Flash Compensation: 0

    Focus Mode: 0

    ImageStabilization: 259

    Lens Info: 15.1, 60.4, 0, 0

    Lens Model: 15.1-60.4 mm

  • mhbc Level 1 Level 1 (0 points)

    LeonieDF, thank you for your prompt reply & links to other Canon user problems. As mentioned in my reply to Keith above I think if anyone is using Final Cut Pro & has no problems with CR2 files that are high ISO - 800 - or long exposure times - 40 secs - then the problem is definately with Aperture.

  • xtravoice Level 1 Level 1 (0 points)

    I'm having the exaxt same problem. Very frustrating. The RAW file looks lovely before the Aperture RAW processing kicks in. Has anyone tried opening the files in Adobe Camera Raw to see if it can handle the files properly? (I need a new version of ACR...CS3 version not compatible with ML, it seems.)

  • Keith Barkley Level 5 Level 5 (5,820 points)

    xtravoice wrote:


    The RAW file looks lovely before the Aperture RAW processing kicks in.

    No it doesn't, you are seeing the JPEG preview. If it is that lovely, shoot JPEG.

  • xtravoice Level 1 Level 1 (0 points)

    Keith, let me choose my words more carefully. "The preview looks fine." I don't understand your snark. I don't want to shoot jpg. I want to be able to shoot RAW - as I always do -  and have the Aperture processing not turn the image black (and green) for these longer exposures.

  • Keith Barkley Level 5 Level 5 (5,820 points)

    Sorry, that did come out harsher than I intended. We of course, are just users like you, make sure you send feedback to Apple.


    (And to put my answer more politely: Until this gets resolved, you might want to shoot RAW+JPEG for these kinds of pics.)

Previous 1 2 Next