4 Replies Latest reply: Nov 30, 2012 11:43 AM by Klaus Blume
Klaus Blume Level 2 Level 2 (310 points)

The default setting on my iCal is always a ‘whole day’ event. I know you can change that by typing in ‘Movie at 7:00 PM.' But I find this an unsatisfactory solution.

 

Sometime ago I found a Terminal command that sets the default for whatever minutes you want to set:

 

defaults write com.apple.iCal 'Default duration in minutes for new event' 60

 

but it doesn’t work. Could someone help me by improving the command?

 

Thanks,

 

Klaus

  • Austin Kinsella1 Level 6 Level 6 (11,520 points)

    Did you quit iCal before entering the command in Terminal?

  • Klaus Blume Level 2 Level 2 (310 points)

    Yes, I did.

     

    I wonder whether some command cancelling the default of ‘whole day’ needs to be given, before the one hour default setting can be issued...

  • Austin Kinsella1 Level 6 Level 6 (11,520 points)

    Hmmm. I tried it here, with 48 rather than 60, and made a new event after restarting iCal - the new event was scheduled to last 48 minutes. You shouldn't need to cancel any previous. What do you get if you give, in Terminal, the command

    defaults read com.apple.iCal 'Default duration in minutes for new event'

  • Klaus Blume Level 2 Level 2 (310 points)

    It DOES read 60.

     

    However, it works now... I am ashamed to admit, but I didn’t do the basic first procedure to fix the problem: restart the computer. Though I quit iCal when doing the Terminal commands, there is probably some setting in the preference file that only gets read once at start-up.

     

    Thank you for your help

     

    Klaus