12 Replies Latest reply: Aug 27, 2013 6:48 AM by boco77
davscanlon Level 2 (220 points)

There is a new clolumn called "iCloud Download" I do not want them in my Library as I have 3000+ purchases, all have either (Clean) or (Explicit) added to the end of the track name to identify swearing. So now i have my normal 5000+ songs plus 3000+ iCloud songs in my library, i'm fully aware these are just links and not taking up HD space, but its a pain sorting my music for DJ-ing.

 

Are those songs there because iTunes is moving towards a Subscription service (Spotify etc)

 

If this is the case, they will lose a lot of money, why buy a song if you cant use it offline for dj-ing?


MacBook Pro (Retina, Mid 2012), OS X Mountain Lion
  • mende1 Level 10 (92,231 points)

    Open View > View Options and unmark iCloud Download

  • davscanlon Level 2 (220 points)

    The songs are still there buddy, that is just a sorting column.

     

    Signing out of the iTunes store solves it, but....

     

    I would like to solve this and remain signed in for automatic podcast & iPhone app downloads......

  • John.U Level 1 (5 points)

    Go to your Preferences for iTunes and in the Store section uncheck "Show iTunes in the Cloud Purchases"

  • ScottN10 Level 1 (10 points)

    It's under iTunes --> Preferences --> Store, and there should be an option to turn off iCloud showing in your library

  • davscanlon Level 2 (220 points)

    Spot on !! Cheers people, i had other issues, but took my time to look for a solution rather than rant on here first

  • psykho88 Level 1 (0 points)

    Unchecking "show itunes in the cloud purchases" option seemed to work fine, but after reboot it will appear checked again..any ideas about why? and above all some issues to give me?

  • Gregory Shadley Level 1 (35 points)

    I have the same problem. I uncheck the "show iTunes in the cloud purchases" and everything is fine. But, if I close iTunes and reopen it later and check preferences, it is checked again. I hate the fact that I have to do this each and everytime I open iTunes. Why can't this stay unchecked?

  • aircanman Level 1 (5 points)

    I also have this issue, for some reason when I restart iTunes or go in and out of the store, the 'Show iTunes in the cloud purchases' comes back on and is ticked.  Wonder when the next update of iTunes is coming up?

  • Qyzylqum Level 1 (0 points)

    I have just the opposite problem as you and Gregory do.  If I check the box to show the purchases then shut down the computer the box becomes unchecked.  I have sent many emails and spent far to much time with iTunes support to say only nasty things about iTunes 11.  There are other ways to get to what you have stored in the Cloud but this is the easiest.  You can turn it on or off under View when you have iTunes open.  It will give you the option of showing all not on your computer or hiding all not on your computer.  But that stupid box needs be checked before any of this works right and it seems to like to check or uncheck itself at random and not because of anything we do.  I have shared this information with iTunes support and hopefully they can fix the problem.  I never thought a person could not be replaceable but in this case Apple is totally rudderless without Steve Jobs.  This crappy software along with Maps in iOS6 would never have gotten past him.  I should note that I have been using Apple products since 1983 and this is the worst I have seen from them.

     

    Message was edited by: Qyzylqum

  • jhersl74 Level 1 (0 points)

    I keep having this same issue.  I hope they release an update soon to fix this problem.

  • howiethemacguy Level 1 (0 points)

    The problem now is that this option keeps turning off on both of my Macs.  I read somewhere that if one Mac has the setting off, and the other has it on, this will cause the one that has the option turned on to turn it off at some point.  If this is true, that's really stupid. It's irritating to go look for my purchases, and find that they're not there AGAIN, and then have to turn it back on.  This issue has been going on for at least three version of iTunes, and there doesn't seem to be a fix.  I have called AppleCare about this twice, and they don't seem to understand that this happens on two systems, and that it turns off by itself.  I'm guessing that no one at Apple with the ability to fix software bugs actually reads these discussions.

  • boco77 Level 1 (0 points)

    This doesn't work. I unchecked that option in the store tab and they are still all there showing.