Previous 1 2 3 4 5 Next 62 Replies Latest reply: Dec 14, 2012 3:41 PM by iphone_traveller Go to original post
  • erwinscott Level 1 (0 points)

    I had the same problem. I just read that unplugging the wired connection and going wireless worked?? Not sure why but sure enough I just did it and it downloaded and installed.. Weird, I know...

  • insainlewey Level 1 (0 points)

    Middle of update  on ATV3. Moving VERY slow. Like 20 minutes to the half point slow. But still going. We shall see.

  • Dave Ings Level 1 (5 points)

    My step 1 took roughly 45 minutes to complete. Step 2 took the normal 2-3 minutes and then all was well.

  • insainlewey Level 1 (0 points)

    Update took 1 hour 15 minutes. And all is well!

  • Mikerbuddy Level 1 (0 points)

    I downloaded it for my atv3 it downloaded just fine from wireless. I find the air play a lot less laggy with mountain lion as I can actually use airplay now

  • 5uck3rpunch Level 1 (0 points)

    Man am I ever glad it was not only me with this issue.  Really, W_T_F is going on at Apple these days?  I think we have seen Apple's best days & we are on the downhill now.  I hope I'm wrong. 

  • adamfromorange Level 1 (0 points)

    Mine took about 90 minutes and the last 50% of the progress bar seemed to take longer than the first 50% but it eventually got there and is working fine without any intervention needed.

  • 5uck3rpunch Level 1 (0 points)

    Did you update on wifi or thru ethernet?  I'm going to try wifi when I get home later.  No luck thru ethernet for me. 

  • Gary Tate Level 1 (75 points)

    Opened ATV this morning and it told me I had an update available right away... d/l went sucessful, update install sucessfull. took aprox. 5 min.


    Servers must have been swamped yesterday.... guess its not a hobby

  • _systemaddict Level 1 (5 points)

    Thank You 


    Your answer worked for me too. I removed the Ethernet cable and the update was successful over WI-FI.

  • 5uck3rpunch Level 1 (0 points)

    @Gary - mine downloaded fine & it sounds like it did like others that posted here.  It just failed during the install.  MANY times.    I will try wifi later like the others & keep my fingers crossed....  We need the old Apple back!

  • danjc2 Level 1 (0 points)

    I was having the same problem, eventually gave up and tried to do a restore via cable and itunes. iTunes 11 didn't recognise my Apple TV, but by chance I plugged my box back into a TV, and it booted with an update notification, blitzed through it in about 2 minutes. So something must be working, it just likes to take its sweet time doing so.

  • WPO Level 1 (0 points)

    After unplugging ethernet and updateing over WiFi -- success!

  • doctrsnoop Level 1 (0 points)

    Unplugging ethernet worked for me too!

  • bravescoach Level 1 (0 points)

    I have an Apple TV 3rd generation wired via Ethernet to a nearby router.


    I had the 5.1.1 update fail on an Apple TV 3rd generation last night and this morning repeatedly. It failed at the end of Step 1 after about 5 minutes (progress bar would hang at the end), then an error message appeared saying that the "update was not successful" and suggested a restart.

    1. Soft restart and update did not work.
    2. Hard restart and update did not work.
    3. Reset to factory default did not work.
    4. Plugging into a PC with iTunes 11 via a micro USB cable gave the error message that hardware could not be located or something along those lines. I tried this on two Windows 8 64-bit PCs with fresh iTunes 11 installs.


    I was going to attempt a restore from an iTunes 10 Mac today, which I have access to at work (BYOT school). Right before leaving for work this morning after several failed updates, I tried unplugging the Ethernet and connecting the Apple TV to my home WiFi network. Sure enough, the update only took about 5 minutes and was successful.


    Bottom line, connect to WiFi for the update. The box is working fine after then reconnecting to Ethernet.


    I wouldn't call this a fix, but a workaround.