Previous 1 2 3 Next 62 Replies Latest reply: Dec 14, 2012 3:41 PM by iphone_traveller
stevekor Level 1 (0 points)

Apparently this update was just released today (haven't checked my ATV3 to verify). Has anyone tried it yet to see if it fixed previous problems?

Apple TV (3rd generation), iOS 5.1
  • thoughtpyramid Level 1 (0 points)

    Tried it twice with the delta update including a restart. Both failed. Restoring the device now and trying once again.

  • dchao99 Level 4 (2,055 points)

    I'm going to try the restore method in a few minutes, via the USB cable. I don't trust the automatic update anymore.

  • Gary Tate Level 1 (75 points)

    Tried the update and didn't get pass figuring time for download. Quit download. Black screen. Did a power reset and its back. Buggy update?

  • Tones Level 1 (45 points)

    I think I'll hold off until I see more comments about the update, glad it's happened though. Sounds like the update is taking up to an hour at the moment...

  • stevekor Level 1 (0 points)

    Me too - holding off too based on the negative feedback I've seen on the 5.1.1 update so far!

  • dchao99 Level 4 (2,055 points)

    Tried the iTunes + USB restore/install method.  No problem.

  • Gary Tate Level 1 (75 points)

    Have a link on how you do this on 2nd Gen?

  • dchao99 Level 4 (2,055 points)

    Same as with 3rd Gen, except you won't need the power cord.  I have both ATV2 and ATV3.

  • WPO Level 1 (0 points)

    Tried about four times (including reset). Update fails.

  • JCShroyer Level 1 (0 points)

    Same here with 3rd Gen Apple TV. Installation fails at end of Step 1. Bar is nearly full then it reports "The update was not successful". Restarted unit & retried, no dice. Unplugged unit, plugged it back in, no dice.


    Who's at the helm these days? A software update that was supposed to fix the major flaws of the previous release and it won't even install. This is getting ridiculous.



    EDIT: I unhooked the ethernet cable (which was working fine on 5.1 for me) and connected to my wifi. Doing so let the update proceed to Step 2 and finish.



  • JCShroyer Level 1 (0 points)
  • indyhill Level 1 (0 points)

    My 5.1.1 update failed as well. Mine was a little worse though. I rebooted the device  as it told me to and it would never boot back up. Screen stayed black and the ATV had the slow blinking light. Tried waiting 15 or 20 minutes several times. Strangly it would boot up without the network cable attached. I tried doing a restore from settings here (no dice since no network connection) and also reset settings. It attempted to go through the initial setup, but kept cycling back to the language selection menu.


    Found the support article about restoring through iTunes. I just upgraded to iTunes 11 today as well. iTunes 11 would detect the ATV, but if I clicked the "Restore AppleTV" button I immediately got a "Device not found" error message. On my Macbook Pro running 10.8.2 and my Windows 8 machine.


    Long story slightly shorter; I had to downgrade to iTunes 10.7 which finally let me restore the AppleTV. It put version 5.1.1 on it during the restore BTW.


    Hopefully this saves someone all the troubleshooting time I had to do until Apple gets this update fixed and preferably get iTunes 11 capable of restoring an AppleTV still on 5.1 considering they both came out at the same time.

  • chipfromhermitage Level 1 (0 points)

    Just downloaded and installed in under 10 minutes on my Apple TV 2nd Generation over Wifi! Nothing seemed glitchy or buggy during the installation.


    I definitely don't reccomend updating via iTunes 11 as you have to restore and lose all data if you didn't previously have an iTunes backup. Also don't try downloading a developer beta as the process is through iTunes and always bugs out, it destroyed my first Apple TV 2nd Gen (had a registered account and UDID).

  • Rdcapebt Level 1 (0 points)

    Failed 5 times so far. Factory reset -still failed - what a joke! Only had it 48 hours- probably just going to return it! Very disappointed that all the shows I already pay for cost money - not at All what I expected - my advice to apple - hire a better negotiating team and get off your high horse - time to realize the world is integrated and if you keep trying to stand alone - ie no Flash etc etc on and on - then just watch google leave you in the dust!


    These update issues have been going on since 2011 from what I see online so what's the problem?

Previous 1 2 3 Next