Previous 1 2 3 4 5 Next 69 Replies Latest reply: Jan 29, 2015 11:47 AM by johnnynogood Go to original post
  • chatbleu Level 1 Level 1 (0 points)

    Same thing here with iTunes U.

     

    For example, I was keeping my guitar teacher lessons (video and audio) in iTunes U (iTunes 10).

     

    Now, with iTunes 11,  the new ones are  Movies or Music media kind, and I cannot change their media kind anymore.  Oddly enough the old ones (with media kind changed in iTunes 10) still show up in iTunes 11...iTunes  U.... Go figure !

     

    I hope Apple will fix this bug.

     

    Thanks

  • pomme4moi Level 1 Level 1 (35 points)

    I hope everyone is reporting this bug to Apple, so that they know about it and fix it.  To report it, from the iTunes menu click on iTunes > Provide iTunes Feedback.  Apple staff do not monitor this forum ...

  • timwjohn Level 1 Level 1 (5 points)

    Good suggestion pomme4moi. Just did. Everybody else should too!

  • nicholasbarry Level 1 Level 1 (0 points)

    Awesome! Thanks, Borad. I'll try out that solution shortly.

  • Anthony Navarro Level 1 Level 1 (5 points)

    Awesome hint... Thanks! I hope iTunes gets this fixed promptly...

  • Laptop guy Level 1 Level 1 (0 points)

    Praises.

     

    Looks like this has been fixed in version 11.0.1.

     

    Now how about all the other bugs and the idiotic mini-player without always visible volume or progress bars.

     

    One step at a time I guess.

  • Mil337 Level 1 Level 1 (5 points)

    I'm running iTunes 11.0.1 on Win7 x64 and I still have this issue when importing my own videos into iTunes and trying to set Media Kind to TV.

     

    Anyone else?

  • spandrelf Level 1 Level 1 (0 points)

    The iTunes "media kind" metadata is not always right. I have at least one set of audio lectures with Apple's "music" designation burned in, as well as some old podcasts showing up as music. iTunes 11, with its "portrait gallery" approach, looks terrible with all this non-music (without cover art) mixed in.

  • 69elcamino Level 1 Level 1 (0 points)

    I was having trouble changing live concert videos bought from Apple Store from movie to music video. The Media Kind on the options tab was grayed out. I wanted to do this because evidently you cannot stream the audio on a movie over airplay - however you can if it is a music video.

    After playing around with the preferences, under the Store tab I unchecked the Show Itunes in the cloud purchases. After that, I was able to change the Media Kind to Music Video.

    Hope this helps.

  • kkendall35 Level 1 Level 1 (0 points)

    One reason: MST3K files are classified as "Movies" but it was a TV show with distinct seasons, so I want to change them to be TV Shows

  • Teranel Level 1 Level 1 (0 points)

    Two of the podcasts that I regularly listen to refused to download this week in iTunes so I had to go online and manually download them and add them to iTunes. When I tried to change the media kind to podcast (they had imported as music), it wouldn't let me. I upgraded to 11.0.2, which solved that problem, but now iTunes won't let me associate them with the original podcast. (It creates a separate podcast  with the same name and identical info) but won't figure out that it should group them together. Short of manually editing all the id3 info, is there an easy fix for this? Thanks!

  • viper941 Level 1 Level 1 (0 points)

    I was having a similar issue to this when trying to change a set of mp3's from music audiobook. None of the changes I made would apply. When I would look at individual files I noticed that most options were greyed out. At first I thought it must be an itunes 11 issue, but it did the same thing when I downgraded back to 10.

     

    Then it dawned on me that essentially what itunes is doing is modifying the ID tag of the file. I use Windows 7, and a recent Windows update set all files in libraries defalted to 'Read Only'. As soon as I took of the read only attribute on the files I was able to make all the changes as I was able to before.

     

    I don't use a Mac so I don't know if this is the issue for the Mac users, but I suspect for the Windows users this will resolve the issue they are having.

     

    For windows users: Go to the file (or folder of files), right click it, and unselect 'Read Only'. Then apply the change.

    For Mac users someone else will have to test it out and tell you how to fix it.

  • koden Level 1 Level 1 (0 points)

    Could be I'm wrong. But before you add any music to iTunes, switch off your iTunes Match,if you use one. When add media to iTunes. Make all changes with it you have to. Switch on iTunes Match. Works for me.

  • Laptop guy Level 1 Level 1 (0 points)

    Thanks for your reply.  But I never use iTunes Match (it is always off), so this cannot be the problem. 

    Since my original post, I have found that iTunes 11.0.2 WILL allow me to change the media type of podcasts.  BUT for about half the podcasts I regularly subscribe to, iTunes will not reliably allow me to change the title and other ID3 tags when the file is new (within a few days of the file's download).  I can change the name (for example if I want to archive the podcast with the date in its name) but at random intervals thereafter all the tags I have modified will revert back to the way they were before my edits.  This happens even if I have moved the file so it is no longer in the original folder where iTunes downloaded it.

     

    Frustrating, as I have to edit tags as often as five times before the changes stick.  This never happened with previous versions of iTunes.

     

    Don't get me started on the mess that searching has become now.  It was perfect in iTunes 10, where search results would fill a window and included results for all fields from all types of files.  Now you get the drop down menu which disappears the moment you change focus, and includes only a fraction of the results it once did.

     

    iTunes 11 = massive FAIL.