Previous 1 2 3 4 5 Next 69 Replies Latest reply: Jan 29, 2015 11:47 AM by johnnynogood Go to original post
  • koden Level 1 (0 points)

    I'm still convinced you should be able to change media kind. Becouse when I switch off my iTunes Match, my iTunes player become same as yours, just normal.

  • Laptop guy Level 1 (0 points)

    Thank for your reply.  I use a Mac, but the problem is not that tags or file attributes are set for read-only.  I am the 'owner' of the mp3 file with read and write priviledges.   I can make edits to the ID tags (like the name of the file in iTunes) and close the edit window with changes showing as I have made them.  Then minutes or hours later the fields are back the way they were before my edits.  In other words the edits do not persist.  Ridiculous! 


    I have made several 'feedback' posts to Apple, but months later still no fix for this idiotic bug.  iTunes 10 was perfect for me.  iTunes 11 is a massive pain.

  • koden Level 1 (0 points)

    If after a wile , after you made changes, everything back to past settings. Maybe reinstal iTunes. Could be some bug, or some preferences glich.

  • vadulak Level 1 (0 points)

    This is exactly what is happening @ the file level. It looks like a Windows 'undocumented feature,' unless iTunes is doing something during the add or import process.


    I rolled back to iTunes 10.7 from 11 and still had the problem, so I knew it wasn't solely iTunes.


    Your solution worked like a charm for me. It's just a pain to have to add one more step to the media management process. This stuff is supposed to be seamless! (yeah. not.)


    Thanks again.

  • koden Level 1 (0 points)

    Oh yes, it's a pain. But then you like all media is in the right place, it's worth it.

  • jmolleru Level 1 (0 points)

    I imported an audio book CD and it was imported as "music" so I wanted to change to Audiobook.  However, the "media kind" was grayed out and not available to change.


    Finally, I turned off iTunes Match and once I did that, the "media kind" box was available and worked fine!

  • jlpurvis2001 Level 1 (0 points)

    I have this same problem.  Media Kind is greyed out entirely for everything, and I don't have itunes match turned on.

  • MrPetter Level 1 (5 points)

    This is a Windows 7 (x64, but should work for x32 as well) based solution, which did the trick for me.


    I browsed my way to the files I wanted to change, right clicked properties and realised that these were set as "Read only". Might be Match that does that or something else - not sure, but changed they are. Clicking that box until it is unchecked, you enable the files and thus the ID3 information to be written once more.


    Running iTunes as Administrator (right click the software icon and choose "Run as administrator" - and, by the way, feel free to try without this, it shouldn't be necesary, really) and change media type is back to normal.


    This, along with what is described in the Mac articles, strongly suggests that the issue has less to do with rights management as such and more to do with iTunes, for some reason, setting file attributes to non-changeable. Strange behaviour and it is quite conceviable that any implemented iTunes fix for this issue will only sort new files, and leave existing files in "locked down mode". Not necesarily, but quite a real possibility. Anyway - hope it works for those still struggling in Windows!






  • canadianstarbuck Level 1 (60 points)

    Here is what worked for me !


    I turned OFF ( Show Itunes in the cloud purchases )


    Go to : Edit > preferences > Store preferences > Check OFF ( Show itunes in the cloud purchases )



  • slyfoxa Level 1 (10 points)

    I have finally solved the problem ! After many hours and unsuccessful tries, I have finally found an excellent little app called Typecast by Red-Sweater software.



    1. Open the app.

    2. Drag and drop your mp3 files

    3. Give the podcast a title

    4. Click send to iTunes

    5. Enjoy your manually created podcast on iOS7 Podcasts app!



    Big thanks to Daniel from Red Sweater Software!

  • Mac Campbell Level 1 (15 points)

    This is nasty, for whatever reason some of my files have been re-tagged and I can't fix them within iTunes. For instance "When Harry met Sally" purchased on iTunes is now considered a song from the Florence and the Machine album Cermionies... I can't change the type back to movie... this is issue has fubared multiple files in my library. Apple please fix - this is brutal.

  • Musicdear Level 1 (0 points)

    As a preamble, you should know that I don't let iTunes "manage" my files. All my video files/folders are on a separate drive.


    Here's how I solved the problem of mass tagging mp4 files in iTunes 11 +


    1) I Changed the "date last modified" on all video files so they are all the same date, using the program: "Attribute changer" - which allows changing parameters across folders


    2) I deleted all the video entries in iTunes (this doesn't delete files, since files are not managed by iTunes)


    3) I reimported all the videos, so they all have the same "date added"


    4) After that, I had no problem mass editing tags including setting all my videos to "music videos" (which they mostly are, in my case).


    This allows all video files on my iPhone to have correct information. Otherwise, home movies or "movies" are without title, unless purchased


    It appears that "same kind" means same "added date" and same "last modified date"

  • ldrspr1882 Level 1 (0 points)

    Hi there just wanted to say thanks ... this was driving me mad, a bit ocd I know but if its an audiobook, I want it it in the audiobook folder on itunes, i followed your clear and simply explained instructions and its worked a charm, .. just wanted to say thanks ! .nath

  • Peyton Williams Level 1 (0 points)

    For what it is worth after experimenting with an audio book on CD that I imported, importing as an AAC file would NOT allow me to change media kind.  Importing as an .mp3 however would allow me to change the media kind.

  • Peyton Williams Level 1 (0 points)

    Cancel that.  It worked until iTunes Match got it's hands on the files.