Previous 1 2 Next 17 Replies Latest reply: Dec 11, 2012 5:37 PM by cmny12589
cmny12589 Level 1 (0 points)

mcp 10.8.2 (june 2012), latest iPhoto

I followed article, created volume, will not automount, must go to disk utility to 'attach', then open iPhoto

For other users it does not even show up on disk utility....library will not open

  • Terence Devlin Level 10 (137,945 points)

    Add it to the Log In Items in each account.

  • cmny12589 Level 1 (0 points)

    Nice, really close!

    This fixed the issue for my account (standard, not admin), works great.


    But it does not for the other two accounts (one standard, other admin) I have on the machine. The other two accounts have the volume now listed on the Login In Items.


    My theory is that the other accounts are not being allowed to 'mount the image'....


    1. They do not show up in Disk Utility in these two other accounts, it should, right?


    2. The volume is in a shared folder and you can see them from all accounts, but they are not 'selectable' from the folder view (Photo Library.sparseimage low-lighted).

    Import Photos.png


    3. I receive a Unreadable Files...unrecognized format...when attempting to File/Import from iPhoto

    Unreadable Files.png

  • Terence Devlin Level 10 (137,945 points)

    Why are you importing a disk image to iPhoto?

  • cmny12589 Level 1 (0 points)

    I may have used the wrong term. I followed support article when creating the shared volume that ignores permissions. In troubleshooting I would go to disk utility and double-click volume and then I'd get a 'attaching image' msg; there'd be the Photo Library sparse image and below that the volume name; then only could I load iphoto pics; but only for my account.

  • Terence Devlin Level 10 (137,945 points)

    Mount the volume




    Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Choose Library' and point it at the Library on the Disk Image.

  • cmny12589 Level 1 (0 points)

    Not possible for other two accounts

    1. It does not show up in Disk Utility

    2. Not selectable via Finder (low-lighted with now right-click option)

    3. At start-up I get the 'Unreadable file...unrecognized format' message.


    If I could mount with the other two accounts then I think I'll be golden? Any other options? I've run 'repair/fix' options via Disk dice....

  • Terence Devlin Level 10 (137,945 points)

    This isn't an iPhoto problem. I'd bring that to the Using Mac OS X forum for your version of the OS.






  • Old Toad Level 10 (135,507 points)

    Don't need Disk Utility.  Just go to the Shared folder and double click on the disk image file.  That should open it in all accounts unless you're running into permissions issues. 


    I know that method is one suggested for sharing a library but the optimal method is to use an external HD connected to the Mac, set it's ownership to be ignored


    and place the library on it. 



  • cmny12589 Level 1 (0 points)

    OT: thanks, but although I can see the image in shared folders I can select, click, etc, please see png above that shows volume low-lighted, non-selectable.

  • Old Toad Level 10 (135,507 points)

    Are you trying to import an iPhoto library in the disk image into another library?  That's what the screenshot seems to imply.  You're in an import window. 




    Or do you want to have the other account open the library that's in the disk image?


    Can the other accounts open the disk image directly by going to the Shared folder and double clicking on it?  If so the image will appear on the desktop:


    Then launch iPhoto with the Option key held down and you should see it in the window:


    Or you can choose the Other Library button and go to the disk image in the Open window:



    But the key is to open the disk image in the other account.  This is what it looks llke from Disk Utility:



    Hope this helps.

  • cmny12589 Level 1 (0 points)

    OT - almost there, thank user is set, after login the shared sparseimage (volume) mounts, iPhoto loads, opens the shared library....


    BUT, not for the other accounts....login, but NO mount of volume, so, when iPhoto opens it can't find the volume.  So what I have to do is go to Disk Utility and double-click then it 'attaches' and NOW I see the volume on my desktop as an external hard drive...and now I can select it from iPhoto and all is good.


    I don't want to manually attach volume then open iPhoto and point to mount; I want it to work as the other user account, volume mounts on startup, the iPhoto points to volume...have read other posts and nada that I can find to fix; I 'removed' volume from Login Items and then re-added....rebooted, etc....nothing...


    Even in Disk Utility when I see this volume name it has 'not mounted' status on status line, of course after File/Open Disk Image, then status is 'mounted'....all users have read&write permissions set and 'ignore ownership on this volume' set


    Appreciation any and all help - thank you!

  • Old Toad Level 10 (135,507 points)

    Here's how you can get it work.


    1 - in each account mount the disk image with Disk Utility.

    2 - make an alias of the open disk image icon.

    3 - put that alias in your Doucments folder and drag it to the Dock.


    4 - eject the open disk image.



    Now when you click on the alias in the Dock the disk image will mount.

  • cmny12589 Level 1 (0 points)

    OT: thank you for the thought, but no dice; short version, i mount image, iPhoto works fine, I create alias, put on dock; log off then login in and when I click on alias, nothing, it does not force the mount.


    Why does it work fine with one user account and not the others?

  • Old Toad Level 10 (135,507 points)

    Could be one is an admin account and the other isn't.  The more reliable and easiest way to do what you want is to use an external hard drive to house the library on.

Previous 1 2 Next