6 Replies Latest reply: Nov 30, 2012 8:42 AM by LordRavenWolfe
LordRavenWolfe Level 1 Level 1 (0 points)

I got a used macbook about 3 months ago, it's the second I've bought and had no issue with it up until about a month ago, when it started giving me the fatal error and saying "please restart your computer" and freezing up. I tried to run disk utility on it and it basically said my hard drive had fatal errors and it couldn't fix it. So I bought a new hard drive.  Got my hard drive today, put it in the macbook, reinstalled OSX Snow Leopard, and it ran fine for about 5 hours, and I was happy as can be... now suddenly, it has started doing this again, and it's really starting to p*ss me off because I've spent so much on a "recertified" macbook that apple won't fix without a crap load of money, and I'm not even sure what is going on with it..

 

I've tried to boot it in safe mode, and it acts fine for about a minute, and then any program I try to open it says it can't "find it" and shuts down. If I try to open system preferences to bring up the specs it immediately freezes and gives me the "hold down power button to restart" stupid thing.

 

When I restart it, sometimes it'll come up and then shut down, and other times it immediately pops up and says something about a fatal kernal error. If I can get it to do the fatal kernal error message again, I will happily post it on here so you can see what it says, but at this point I am seriously ready to just trash this pos and go back to using windows computers because this now makes 3 macs (two macbooks and a imac) that I've had that all start doing this, and it's baffling because I don't download stuff on the internet, etc. I mainly use my macs for recording music.

 

Also, don't know if this helps or not, but in the few instances where it does boot up and won't shut down immediately, if I click on say Apple>About this Mac.... as soon as I click on it, the screen goes blue, and then a few seconds later it comes back like it's just fine.

 

 

I don't know what all you guys would need to see anything, but last time it booted up I was able to get this information before it crashed again:

 

OSX 10.6.8

Model Name: Macbook

Model Identifier: Macbook2,1

Processor: Intel Core 2 Duo

Processor Speed: 2.16GHz

Number of Processors: 1

Total numb of cores: 2

L2 Cache: 4MB

Memory: 2GB

Bus Speed 667MHz

Boot ROM Version: MB21.00A5.B07

SMC Version (system): 1.17f0

Hardware UUID: 00000000-0000-1000-8000-001B6335249D

 

I know that's just the basic info under hardware but I couldn't get any further than that. It goes blank screen and shuts down.


MacBook, Mac OS X (10.6.8)
  • BGreg Level 6 Level 6 (17,500 points)

    The first thing I would want to do is to run the Apple hardware test, which requires the original gray-faced OS X disks that shipped with your MacBook. TechTool Deluxe and Pro can do similar testing if the OS X disks aren't available.

  • LordRavenWolfe Level 1 Level 1 (0 points)

    I don't have the original disks, but i do have Tech Tool Pro 6, and I ran it, and it comes up clean. I had it do a full scan, and it came back with nothing. :/  Meanwhile, the computer just keeps running fine, and then randomly quitting... just a minute ago while typing this message it said "safari must be closed" and closed it.. when I reopened it it was like Java was missing or something. The page opened fine, but I couldn't see any typing, etc, just the pictures by your name. So I closed it, reopened it, and now it's fine. It's annoying as ****.

  • LordRavenWolfe Level 1 Level 1 (0 points)

    It finally did it again, and this time I have everything it says!

    So here is what it says when it greys out and tells me to restart:

     

    panic(cpu 0 caller 0x424d86): "hfs_UNswap_BTNode: invalid backward link (0x00FF0263)\n"@/SourceCache/xnu/xnu-1504.15.3/bsd/hfs/hfs_endian.c:290

     

    Debugger called: <panic>

    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

    0x35873c18 : 0x21b837 (0x5dd7fc 0x3587c4c 0x223ce1 0x0)

    0x35873c68 : 0x424d86 (0x5c8af0 0xff0263 0x35873ccc 0x2)

    0x35873d08 : 0x4196da (0x35873d28 0x4dc0e10 0x1 0x1)

    0x35873d48 : 0x301473 (0x315c3570 0x4cfe004 0x0 0x0)

    0x35873e18 : 0x302646 (0x0 0x4e81c5c 0x8 0x0)

    0x35873e58 : 0x43d764 (0x4dc7f00 0x0 0x4a9ee0c 0x4dc0ce8)

    0x35873e78 : 0x43647b (0x4cfe004 0x2 0x0 0x4ecfd20)

    0x35873ee8 : 0x2e67d6 (0x4cecbd8 0x2 0x4c64934 0x0)

    0x35873f08 : 0x2e2b9e (0x4cecbd8 0x0 0x1 0xbb3)

    0x35873f48 : 0x2efe80 (0x1 0x2e6797 0x0 0x0)

    0x35873f78 : 0x4f82fb (0x4ecfd20 0x4aa5688 0x4c64874 0x1)

    0x35873fc8 : 0x2a251d (0x4aa5687 0x1 0x10 0x529e4e4)

     

    BSD process name corresponding to current thread: L (can't see rest of word, grey restart box blocks it.)

     

    Mac OS version:

    10K549

     

    Kernel version:

    Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PM

    System model name: MacBook2,1 (Mac-F4208CAA)

     

    System uptime in nonoseconds: 334065083020

     

     

     

    This is what it always says when it does this screen. I'm just sick and tired of it and hoping it's not going to cost me a ton of money to fix.

  • LordRavenWolfe Level 1 Level 1 (0 points)

    I can clearly see it's a kernal panic causing the issue, but the only support that Apple offers is pretty much "if it happens repeatedly, do a clean install of mac os x from your install disc."  That does nothing to help me since this IS a fresh install from an install disc. LOL

  • ds store Level 7 Level 7 (30,315 points)

    LordRavenWolfe wrote:

     

    I got a used macbook about 3 months ago, it's the second I've bought and had no issue with it up until about a month ago...

     

    ....now makes 3 macs (two macbooks and a imac) that I've had that all start doing this...

     

    You had three machines with the same exact issues.

     

    So what have you done a month ago that is the same on the other two machines?

     

     

    I don't have the original disks

     

    Model Identifier: Macbook2,1

     

    There is something in common on all three machines, something you have done that is causing this issue.

     

    My suggestion is to treat this as a malware infection, backup and systematically purge everything, reinstall 10.6 and only manually transfer files from backups.

     

    Call Apple for the 10.6.3 White Snow Leopard disks your going to need them.

     

     

    Most commonly used backup methods

     

    How to erase and install Snow Leopard 10.6

  • LordRavenWolfe Level 1 Level 1 (0 points)

    Thats just the issue though.... on this MacBook as soon as I installed snow leopard it was fine, until it did a system update. Then it worked for a few hours and crashed. I havent put any third party stuff on it. In fact I didnt put anything on it. Although I did change my background to another preinstalled background and it immediately froze. Same thing happened on the last two. I didnt have any issues until I changed the screen bg and set the hard disks to sleep after one hour of inactivity instead of the normal fifteen minutes.

     

    On my original iMac I had it three years before it started doing that and applesaid it was a hard drive failure.