13 Replies Latest reply: Jan 8, 2013 6:03 AM by RKimmings
magnabuck Level 1 Level 1 (0 points)

Since updating to itunes 11, Home Sharing is not working.


I am running Windows 7, 64-bit.


All mobile devices are up to date with ios, including 2 apple tvs (2 & 3), iphone 4s and 3gs, ipad1 & ipad2.


I've rebooted twice, turned home sharing off, then signed back in. Still nothing.  Rebooted the mobile devices.  No joy.


Curiously, wi-fi sync is also not working - the devices are not showing up in itunes unless I plug them in. 


Please Help!

itunes 11, Windows 7
  • powdrsnow Level 1 Level 1 (40 points)

    What if you reboot your router?

  • bryanfromsingapore Level 1 Level 1 (0 points)

    I have the same problem after upgrading to iTunes 11.


    I have a main library shared by two other computers.


    Music server:

    Windows 7 32-bit

    iTunes 11


    Client 1:

    Windows 7 32-bit

    iTunes 10

    This client can connect to the shared library fine.


    Client 2:

    Windows 7 64-bit

    iTunes 11

    This client cannot connect to the shared library.


    The router is an Airport Extreme.


    I've tried rebooting all the PCs and routers and it didn't help.

  • john@7129 Level 1 Level 1 (0 points)

    I'm having the same issue.  Windows 7 64-bit.  Lost all libraries after updating to iTunes 11.  Unable to sync over WiFi also.  I've about had it with Apple releasing beta software without proper beta testing.  Also I'm tired of having to wait several weeks before they will even acknowledge any problem.  I guess I will be going back to itunes 10 and wait 3 months for them to release a patch for 11 - since that seems to be the new turnaround time.  So frustrating.  Obviously iTunes 11 was not ready for primetime - 6 weeks after it was supposed to be released and it still is not up to snuff.

  • celloshred Level 1 Level 1 (0 points)

    My ROUTER shows up as a shared device, but neither computer shows up.


    Both are on wireless an runnining Win7.  One is 64b the other is 32b.

  • Charly Brown Level 1 Level 1 (10 points)

    Sorry to tell you this but I spent countless hours trying to resolve the issue with no avail, tried all troubleshooting from Apple, reset all that needed to be reset, updated router firmware, etc, etc, useless. My issue started with iTunes 11 (win7 X64) not showing up my Apple TV 1st Gen, then I tried home sharing and it was not working either, which was suspicious, it is like iTunes stopped recognizing any wireless device.


    My only solution was to revert to the previous version of iTunes and voila! working again, ATV 1st gen showing up as well as Home Sharing is back. At least I proved without doubt that it is an iTunes 11 issue. This webpage helped me on the roll back. I'm afraid it is the only solution right now. I also tried to uninstall/reinstall iTunes 11 3 times, the only thing that worked was iTunes 10




    If it gives you an error after installing the old version, do this. The most important step is step one, create a backup of your library file. Some of the folders on step 4 may not be there after uninstalling iTunes 11 on Windows 7 X64


    http://htodo.com/2010/09/06/how-to-fix-problem-itunes-library-itl-cannot-be-read -because-it-was-created-by-a-newer-version-of-itunes/

  • frustrated_and_tired Level 1 Level 1 (0 points)

    I have apple everything.  Router, three apple tvs, three ipads, three iphones and have been working with this for years.  Its getting worse and I don't have the time to keep fixing installations.  Home sharing is all I am looking to do.  Put my information in the cloud so I can use it?  Don't think so. Tips for fixing home sharing are there to confuse and distract.  The problem is software.  The installations leave files and then you need to clean them up.  Reload drivers for device and cross your fingers.  Don't be distracted by all the posts.  It will suck you in for days with no results.  Uninstall look for file leftovers and reinstall.  If that doesn't work - sit and take it.

    I am done with apple soon. Time = money

  • Charly Brown Level 1 Level 1 (10 points)

    Ok, hold your horses here. This morning I turned on the computer, opened iTunes, and Home Sharing was gone again, as well as my Apple TV 1st Gen. So I figured it was something that reset when cycling the computer, and that the desintallation of iTunes 11 and resintallation of iTunes 10 reset, but then when cycling the computer it went to its previous state.


    So I started testing Windows Firewall settings, and realized that going to Firewall with Advance Settings, clicking Windows Firewall Properties, Inbound connections on the Domain Tab drop down menu, "Allow" (from block (default)) made Home Sharing to start again and my Apple TV 1st Gen to show up again.Crazy (modifying the other two profiles, Private and Public had no effect whatsoever). So thinking this was probably a Bonjour issue with Windows Firewall, I clicked on all Bonjour Service lines on the Inbound Rules of Windows Firewall and made Bonjour allowed on all Profiles (Properties/ Advance/ click on each profile at the top for a check mark). Clicked apply


    Closed iTunes and reopened, it worked. Restarted the computer, Home Sharing came back, as well as my Apple TV. So it seems it is a Windows Firewall issue more than and iTunes 11 or any iTunes issues. Try and let me know


    This page is also useful for TBshooting WFirewall issues


    http://www.tech-recipes.com/rx/18359/troubleshooting-itunes-wi-fi-sync-problems- in-windows/

  • Charly Brown Level 1 Level 1 (10 points)

    Yes, you guessed. After some rebbots it stopped working again .So it seems it is not a Firewall issue. Kept looking and found a suggestion in a forum to disable IPv6, apparently iTunes for Windows doesn't work well with IPv6. So I did, and after several rebbots and tests, both Home Sharing and Apple TV 1st Gen are working. To disable IPv6, follow this link




    It has an MS Fix It that will do it for you. Or if you wnat to go manual, follow this discussion, this guy was having the same issue several months ago




    So far IPv6 is just being rolled out, and it will be a few years until everybody abandons IPv4 and go only with IPv6, so you shouldn't have any issues disabling it. And by then iTunes -I hope- should be fixed to work correctly with IPv6. Try it, and if you find any issues you can always enable IPv6 using another MS Fix it program, or manually reverse what you did


    Hope it is fixed this time!

  • Megsfolks Level 1 Level 1 (0 points)

    Thanks Charly Brown for putting me on the path to solve this. 


    I am running Windows 7 Home Premium (new computer) and had just installed the iTunes 11 upgrade.    Trying to get homesharing to work with my work laptop was a problem.   Here's what solved it for me:


    Go to Windows Firewall

    Select Advanced Settings

    Select Inbound Rules from the left column.   I have 4 Bonjour services

    For each, I did a right click/properties and made sure that the following was set on each:

        Under general:   Allow the connection

        Under Programs and Services:   All programs that meet the specified conditions

        Under Advanced, I checked both Domain and Private to be safe

  • JMC911 Level 1 Level 1 (10 points)

    I've had similar problems after updating various versions of iTunes. Often, I'd see my remote devices on the playback dropdown, but I'd get errors when actually trying to play back (and no sound). I've had to readd the authorization to windows firewall. I figure the firewall does some sort of checksum, so even though it's still set to let itunes.exe pass, it doesn't really let it connect. I'd just delete the old rule and readd the iTunes.exe rule again, and I'd be working again. It doesn't  sound like that'd fix everyone on this thread, but it may help some.

  • Charly Brown Level 1 Level 1 (10 points)

    I'm glad it worked for you. In my case the only thing that finally fixed it was disabling IPv6, the other tryouts fixed them only for a few reboots. Now it has been working like a charms for several days


    But I'm still on iTunes 10, afraid to move over to 11. I will probably wait until the next version of 11 comes out and then install it

  • Zippyspice Level 1 Level 1 (0 points)

    Me too, Since upgrading to ITunes 11 almost all functionality of home sharing has disappeared.  I can see other libraries but cannot do anything with them.  Tried doing everything suggested on support forums but nothing seems to work – this is really infuriating and Apple need to step up and fix this as its so obviously a software Issue with V11.x

  • RKimmings Level 1 Level 1 (0 points)

    Dya know what... since i installed iTunes 11 I had lost both home sharing between Mac & PC (Win7) and access to my 1st gen apple tv...


    Thanks to you guys for saying to disable IP v6 on my windows machine - did that from here




    Re-booted PC - home sharing was back & so was my Apple TV!!!


    Thanks everyone..... I was going mad here!!