9 Replies Latest reply: Jun 29, 2014 10:13 AM by NikesOnMyFeetxD
KurtGehring Level 1 Level 1 (0 points)

I am editing XDCAM EX footage as well as mpeg4/h264. I can't believe Apple didn't resolve this issue yet. It's Version 10.0.6!

I can re-render parts of my timeline, but that's not a solution, it's a workaroud.

iMac 27" i7, Mac OS X (10.6.6), Macbook Pro
  • BenB Level 6 Level 6 (8,620 points)

    It's not an XDCAM issue, its a new 10.0.6 issue.  We are waitint for a bug fix.  XDCAM should work great aside from this new bug on export.


    If you are getting that in the timeline that is a hardware issue.

  • KurtGehring Level 1 Level 1 (0 points)

    I don't think it's a new issue (10.0.6) - We discovered this in 10.0.4 already and then I thought it's a bug. The new updates didn't solve the problem, that's why I am really concerned about this issue. ???

  • mochaL Level 1 Level 1 (0 points)

    I noticed this on my MBP, usually when adding transitions.  What I found was happening was that I was trying to do too much at once for FCPX to handle on my machine, and it would end up dropping frames (i.e. the green frames) every now and again.  Fixes that worked for me- 1: delete the tansition where the dropped frame was, chang the length of the clip, let FCPX background render, and then reinsert the transition.  2: Get a faster computer...once I upgraded to an early 2012 iMac and maxed the RAM, I've NEVER had this problem since. 

  • Tom Wolsky Level 10 Level 10 (113,350 points)

    "chang the length of the clip, let FCPX background render"


    Why do you have to render the clips when there is no transition? What are the specs of the clips?

  • KurtGehring Level 1 Level 1 (0 points)

    Well, as we already know, FCPX renders everything to ProRes422 (or other flavour, set in the prefs) in the background. When there is a mistake in the rendering process, the green frames occur. I know that there are several "solutions". I can change the lenght of the clip, I can force FCPX to re-render the section, I can switch on and off the stabilizer (to force FCPX to re-render the clip), I can even go to the project folder in finder and delete the render files of the project. But: that's not a solution at all. It happens again and again, especially when there are speedramps, slomos or speedups in my edit. When you have a client sitting next to you, or you have really short time to finish your edit (I am running a mobile TV broadcast system)... it's really annoying.


    I could also re-encode my compressed h264, mpeg4 clips before importing to FCPX, that would also fix this issue, but in that case I could work with FCP7 again.

    The green frames never occur when there is only i-frame footage like ProRes in the timeline, so I figured that it's some issue with the GOP-structure of highly compressed footage like h264. Obviously the software is somtimes unable to calculate and display the picture, when it comes to a frame that is somewhere in the jungle between two video-keyframes.


    @mochaL, I don't think it's a performance issue. I own 6 iMacs (iMac 27" i7 3.4 Ghz, 16GB RAM, 10.7.5 with AMD Radeon HD 6970M 1024 MB Graphics card). (I'm renting them to TV-stations for mobile editing)  The problem occurs on all machines as well as on my Laptop (MacBook Pro 15" (2012) 2.6 Ghz Intel Core i7, Intel HD Graphics 4000 384 MB).


    For the moment I think Apple has to fix this. Please keep posting your experiences with this issue.

  • Tom Wolsky Level 10 Level 10 (113,350 points)

    You didn't actually answer my question except maybe in mp4. Is this really MPEG-4 framework media? You need to optimize your footage.

  • Luckinator Level 1 Level 1 (0 points)

    I have been having this issue for a few days now. Just resolved it! Were you using imported Motion 5 templates and titles? It seems there are some issues in FCPX when you are stacking multiple bits of 3D graphics and transitions. Tom's suggesstion may be best.


    I also had this problem with certain footage I have exported from Camtasia and rendered Motion 5 video. Try optimizing your event footage including any compound clips. Right click on your clip --> transcode media --> create optimize media. Re-render your project and all should work. It worked for me. Hope this helps.

  • ffromg Level 1 Level 1 (0 points)

    I know this sounds kindda dumb, but I was having the same issue but I resolved it without doing any updates. I simply put a basic text over the clips and deleted "text" and the green stopped

  • NikesOnMyFeetxD Level 1 Level 1 (0 points)

    I deleted the render files and then re-rendered them and it works great now.


    How to delete render files: http://www.larryjordan.biz/fcp-x-delete-render-files/