9 Replies Latest reply: Dec 1, 2012 10:39 AM by VikingOSX
Dr. Daniel, M.D. Level 1 Level 1 (0 points)

Hello

 

I'm setting up a re-install of Lion after the 10.7.5 update killed it, and Mountain Lion turned out to be a battery-killer.

 

I'm trying to setup the formatting of digits, time and currency in System Preferences, but I cannot see how I can fix the incorrect way it wants to display the Danish currency symbol.

 

In Denmark, our currency symbol is either "kr." (short for "kroner") or "DKK" and it's a suffix preceded by a space. Microsoft has always gotten this partly wrong, chosing the right symbol ("kr."), but prefixing it. It's always been easy to fix, though.

 

On my Mac, the system wants the symbol to be "Dkr" (which is definitely not correct in any way), it wants to prefix it, and it wants to glue it directly on to the amount, not even adding a space, i.e.

"Dkr1.000,00"

 

The correct notation is,

"1.000,00 kr."

 

I can't find any GUI way to fix it, but I know there are tons of settings hidden that you can set using a terminal. Just have no clue if this is one of those, and how to do it if so.

 

Is it, and how?

 

Thanks in advance,

Daniel


Mac OS X (10.7.5)
  • Austin Kinsella1 Level 6 Level 6 (11,520 points)

    I am using 10.6, so it may differ slightly for you ... and I haven't actually tried it

     

    If you are feeling brave, use BBEdit or similar to open /usr/share/locale/da_DK.ISO8859-1/LC_MONETARY

    and edit it. The settings are described in Locale

    and there is a commented view of a typical file here

  • Dr. Daniel, M.D. Level 1 Level 1 (0 points)

    Hi Austin, thanks for replying

     

    That's pretty interesting – the LC_MONETARY file displays thing exactly as they're supposed to be, all with "kr" and "DKK"...

     

    I'm starting to think this problem may have to do with me preferring English as my OS language, even though I'm Danish, and I prefer localized times, dates, and currencies... I had to manually "correct" AM/PM and other types of date settings from US English-style ones to my preferred ISO/Danish ones.

     

    On Linux, I'd have en_DK.UTF8 as my locale, is there any way to get OS X to do the same? To me, it looks like I'm having en_US.UTF8, with me trying to tweak it into my local styles...?

     

    Thanks

    Daniel

  • twtwtw Level 5 Level 5 (4,900 points)

    OS X distinguishes between local currancy and international currency.  If you look at the currency setting when the region is set to Danish (Denmark), which is available when you check the 'show all regions' checkbox, the currency is set correctly according to Danish conventions, but when you view danish currency from an English region it will be shown using international conventions.

     

    you can probably do the same thing with OS X that you did with Linux.  Go to the /usr/share/locale/ folder, create a folder caller en_DK, then make an alias to the LC_MONETARY file in the da_DK folders.  I haven't tested it, but it looks like that's what the other local folders are doing, so...

     

    You'll need admin privileges, of course.

  • etresoft Level 7 Level 7 (26,605 points)

    The ideal solution would be to track down whatever incompatible 3rd party software you were running on Mountain Lion that affected the battery life and caused the 10.7.5 update to fail.

     

    I don't see any "Dkr" symbol. How are you setting your region settings in System Preferences. I just set my region to Danish > Denmark and get this:

     

    Untitled.png

     

    I see you commented in one of the rant threads. Such threads are never productive. I suggest you reinstall Mountain Lion and start your own question if you are having problems with battery life.

     

    I wrote a little diagnostic program to help show what might be causing these problems. Download EtreCheck from http://www.etresoft.com/download/EtreCheck.zip, run it, and paste the results here.

     

     

    Disclaimer: Although EtreCheck is free, there are other links on my site that could give me some form of compensation, financial or otherwise.

  • Dr. Daniel, M.D. Level 1 Level 1 (0 points)

    LOL, that's fantastic – I managed to overlook the "Show all regions" checkbox, and thus never found my proper Danish region. Sorry, and thanks! It's all good now.

     

    About my issues with Mountain Lion, the only third-party apps I had installed were Chrome (first thing I do is get a proper browser so that I can finish setting up things), iTerm2 (need a proper terminal to fiddle with settings and do things on my server via ssh), and Spotify (to listen to stuff while settings up things).

     

    Sure, there may be some workarounds to get things better with ML, but seriously, I'm not paid to be a beta-tester, and if at 10.8.2 it still can't perform properly, I'm not going to be the one working 24/7 to get my laptop regain the lost 50% battery life if I can just wipe the crap and revert to Lion.

     

    This morning, after having reinstalled Lion, I fired up Chrome with my local radio station in Flash, playing news while I prepared coffe and cereal, keyboard backlight constantly on (as I hadn't yet set up anything (I always set a 5-second timeout)), the screen at 50%. Remaining battery life was 7h30m. Same setup with ML was pretty much exactly half that.

     

    But, this isn't about that, and my problem is now solved, so I'm very happy, and thanks for your help All of you.

     

    Cheers, and have a great weekend,

    Daniel

  • VikingOSX Level 6 Level 6 (10,340 points)

    I am not in Denmark. If I run the following in Terminal, I can isolate the Danish language folders in my implementation of OS X. These are located in /usr/share/locale.

     

    locale -a | grep -i '^da'

     

    da_DK

    da_DK.ISO8859-1

    da_DK.ISO8859-15

    da_DK.UTF-8

     

    export LC_MONETARY='da_DK.UTF-8'

     

    and the following will now show the current individual field settings for da_DK.UTF-8 currency settings.

     

    locale -ck LC_MONETARY

     

    int_curr_symbol="DKK "

    currency_symbol="kr"

    mon_decimal_point=","

    mon_thousands_sep="."

    mon_grouping="3;3"

    positive_sign=

    negative_sign="-"

    int_frac_digits=2

    frac_digits=2

    p_cs_precedes=1        0 will cause "kr" to follow currency

    p_sep_by_space=2     1 will separate "kr" and currency by one space

    n_cs_precedes=1        0 will cause "kr" to follow negative currency amounts

    n_sep_by_space=2

    p_sign_posn=4

    n_sign_posn=4

    int_p_cs_precedes=1

    int_n_cs_precedes=1

    int_p_sep_by_space=2

    int_n_sep_by_space=2

    int_p_sign_posn=4

    int_n_sign_posn=4

     

    You will need to decide which one of the four, Danish locale language files to use, and the particulars that need to be adjusted in the LC_MONETARY file in that respective locale folder. The usual caveats apply when editing system files, per the preceding recommendation.

     

    Held og lykke!

     

    Update: I see that you solved it while this post was in progress, so good news!

  • Dr. Daniel, M.D. Level 1 Level 1 (0 points)

    But thank you, Viking, your post is very interesting, too, and it explains a lot about the underlying locale system

     

    I used up all the credits I could give (and I actually should've marked twtwtw's post as the right answer, as it was the one that explicitly said to check the "Show all regions" box), so all I have left is "Thank you!"

     

    Cheers!

  • etresoft Level 7 Level 7 (26,605 points)

    Dr. Daniel, M.D. wrote:

     

    About my issues with Mountain Lion, the only third-party apps I had installed were Chrome (first thing I do is get a proper browser so that I can finish setting up things), iTerm2 (need a proper terminal to fiddle with settings and do things on my server via ssh), and Spotify (to listen to stuff while settings up things).

    Are Safari, Terminal, and iTunes somehow "improper"?

     

    Actually, I was refering more to system modifications. My EtreCheck tool is designed to list those because people sometimes forget about software that only runs in the background.

     

    Sure, there may be some workarounds to get things better with ML, but seriously, I'm not paid to be a beta-tester, and if at 10.8.2 it still can't perform properly, I'm not going to be the one working 24/7 to get my laptop regain the lost 50% battery life if I can just wipe the crap and revert to Lion.

    I am a paid beta tester and developer, just not for Apple. I can assure you there are no significant issues with 10.8.2. There are some poorly-coded 3rd party software that doesn't work well on Mountain Lion. Sometimes developers take short cuts just to get something working and never fix it to work "properly" because, technically, it isn't broken - until the next operating system version comes out that is.

     

    When Lion was released people were also falling over themselves to reinstall Snow Leopard for the same reasons. You can search for old posts from myself and others who said Lion was fine (as Mountain Lion is) and accurately predicted that people would, in due time, be falling over themselves to reinstall Lion.

     

    This morning, after having reinstalled Lion, I fired up Chrome with my local radio station in Flash, playing news while I prepared coffe and cereal, keyboard backlight constantly on (as I hadn't yet set up anything (I always set a 5-second timeout)), the screen at 50%. Remaining battery life was 7h30m. Same setup with ML was pretty much exactly half that.

    Chome, espeically with Flash, is known to have problems in Mountain Lion. I suggest using Safari and the ClickToFlash extension. That way, you get a very similar browser that will first try modern HTML5 methods for streaming that media and only fall back to Flash if necessary. Even without Chrome, Flash is a total CPU and battery hog.

  • VikingOSX Level 6 Level 6 (10,340 points)

    I think at the end of the day, we all appreciate a “thank you.”

     

    Had I not missed that “Show all regions” selection too, my answer would have been equally more helpful and succinct.

     

    Thanks.