Previous 1 2 3 Next 72 Replies Latest reply: Mar 2, 2014 10:34 AM by Cthulhu Branched to a new discussion.
LAFfer Level 1 (10 points)

iTunes 11 might be great for music but I can't tell what I have in my library in the computer and what is in my iTunes store.  I've spent hours on this disaster and want to abandon ship.

  • LAFfer Level 1 (10 points)

    I should have mentioned my problem is not with music but Movies.

  • Cthulhu Level 1 (60 points)

    I am also desperately trying. I used time machine to restore, all the* files in ~/Library/Preferences, anything with the name iTunes in /Library and /Library/Application\ Support, and I am up and running, but I cannot play any authorized music, and I get an "An unknown error occurred -42408" when launching, and when trying to play any purchased music.

  • Limnos Level 8 (46,035 points)

    =Downgrading from iTunes 11 to iTunes 10.7=


    Back up your computer first, in case the wrong things happen.


    Replace the iTunes 11 application with iTunes 10.7.  I can't provide details on this since I do not have a newer computer. With mine it is very simple but I believe on newer computers iTunes has been integrated into the operating system.  On mine I just go to my applications folder and drag iTunes to the trash.  See below for possible suggestions on how to remove.



    Get iTunes 10.7.  Apple does not keep many old version up on its web site.  I always keep an iTunes installer on my archive drive so I can have access to old versions .  This one is hidden but it is on an official Apple site:


    iTunes 10.7 for OS X


    You will have to rescue your old iTunes library from your Previous Libraries folder and rename it iTunes Library.itl because a newer version of iTunes irreversibly updates your library file.  See:

  - turingtest2 11/2012 post on rebuilding empty/corrupt library after upgrade/crash from previous iTunes library file.


    iTunes: How to re-create your iTunes library and playlists -


    Other issues: - solution to mobile devices saying they need to be restored after downgrading

  • LAFfer Level 1 (10 points)

    Thanks for the file.  I've saved it, just incase I get the verve to try and do the rest of it. 


    I have been using iTunes to handle my videos I use in my work.  Now they are all mixed in with the iTunes store and I need to sort and resort everytime I want to look for something.  It will probabley be safe to rename and reoranize my files in some way.


    I wonder what VP is going to get his walking papers over this piece of garbage!


    Thanks again for your help.

  • Limnos Level 8 (46,035 points)

    Correction to bad URL posted in earlier message:

  - turingtest2 11/2012 post on rebuilding empty/corrupt library after upgrade/crash from previous iTunes library file.

  • chouseal Level 1 (0 points)

    Just chiming in to agree—iTunes 11 is horrendous. Seriously, Apple?

  • Limnos Level 8 (46,035 points)

    If you really want Apple to register your feelings:



    People reading and responding here are just other users like you.

  • Pehtis Level 1 (5 points)

    Finally managed to get rid of error -42408.


    This is caused by the following frameworks in /System/Library/PrivateFrameworks/







    You will need to replace them with an older version from your Time Machine or any other backup.

    Not exactly sure which one of them is causing the error, but its better to replace them all, as all of them are updated by iTunes11.


    After this step everything works normally in iTunes10.7.


    And I'm not going back until they put the Album Art back in the song list view!

  • Cthulhu Level 1 (60 points)

    Awesome! That did the trick for me.


    Here are the exact steps I took, and ITunes 10.7 is working great for me


    1) In the terminal, I ran:


         sudo rm -rf /Applications/


    2) Also in the terminal:


         open ~/Library/Music


    3) I used Time Machine to restore the following files:


    • Album Artwork/
    • iTunes Library Extras.itdb
    • iTunes Library Genius.itdb
    • iTunes Library.itl
    • Previous iTunes Libraries/
    • iTunes Music Library.xml


    I suspect this was not really required, I could have just copied an old library from Previous\ iTunes\ Libraries/, but I am just telling everyone exactly what I did since it worked.


    4) Back in the terminal:


         open /System/Library/PrivateFrameworks


    I used Time Machine again to restore the following files (thanks Pehtis):


    • AirTrafficHost.framework
    • CoreFP.framework
    • DeviceLink.framework
    • iTunesAccess.framework
    • MobileDevice.framework


    5) I downloaded iTunes 10.7 from


    6) I installed iTunes using what I just downloaded, and made a copy for future use.


    That's it! Purchased movies and songs work fine, my iPhone syns fine - everything is perfect. I also have no intention of upgrading until they give me back my miniplayer with the progress bar, song name, volume (without opening Airplay - ***?) and such, and restore the other missing features in the larger player windows. I keep saying every update from Apple is the worst ever, so why I ever clicked on "Update" for iTunes without checking the forums is a mystery.


    I think I am going to make the App Store an Applescript that pops up a dialog and says "Think about what you are doing," and then opens the App Store. Ug.

  • gamer004 Level 1 (0 points)

    Thanks a bunch... this worked for me ( after two hours of trying to restore all kinds of files from Time Machine). I share your opinion... No v11 for me until it has cover flow.

  • Steve Englehart Level 1 (5 points)

    Sweet! I spent hours yesterday looking for the reason restoring everything "iTunes" left me with that error. All praise to Pehtis for coming up with the answer. And all catcalls to Apple for iTunes 11. Too often lately, Apple's approach has been "You know that feature you like and use all the time? We just took it out." And this from a guy who bought his first Mac in 1987…

  • jausenbox Level 1 (0 points)

    everytime i want to use timemachine and backup those 5 files it says that i don't have the permission to change anything (i am the administrator)....


    do you know whats wrong? thank you!

  • Cthulhu Level 1 (60 points)

    Try restoring them to your desktop, at which point Time Machine should ask you to authenticate. If it does not, then double check your account has admin privileges. Then copy them from your desktop to /System/Library/PrivateFrameworks, at which point you will need to authenticate a second time. Let us know how that worked for you, if you you solved it another way.

  • jausenbox Level 1 (0 points)

    thanks for your answer!


    i could solve it in another way! (but i think it basically was the same...)



    - erase v11 with terminal (i use mountain lion, had to use the sudo command)

    - download 10.7

    - download pacifist (shareware but free trial version)

    - doubleclick dmg

    - drag the "install itunes" to desktop

    - start pacifist and drag "install itunes" to it

    - start installing

    - press replace everytime youre asked if "duplicate, do nothing or erase"


    as fas as i could see it replaced those 5 framework files and some others but i dont know if theyre important to the integrity of itunes.


    anyways, it works normal. no more errors and my iphone connects as it should.


    thanks for your help!



    and im bloody mad at apple... how can you screw up so badly?

Previous 1 2 3 Next