Skip navigation

can I downgrade to itunes 10 from 11?

30638 Views 72 Replies Latest reply: Mar 2, 2014 10:34 AM by Cthulhu RSS Branched to a new discussion.
  • TheStig111 Calculating status...
    Currently Being Moderated
    Dec 6, 2012 8:33 PM (in response to Pehtis)

    Cthulu and Pehtis, thank you both so much.  IT11 was driving me insane(especially the mini player) and you guys helped me fix my last few errors.  Thank you!

  • louK3000 Calculating status...
    Currently Being Moderated
    Dec 7, 2012 4:45 PM (in response to Cthulhu)

    I don't find any of the .framework files you mention.

  • louK3000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2012 4:53 PM (in response to jausenbox)

    Can you tell me where the framework files are?

  • TheStig111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2012 6:35 PM (in response to louK3000)

    Macintosh HD/System/Library/PrivateFrameworks

  • TylerAllen86 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 7, 2012 8:32 PM (in response to LAFfer)

    I've already UPGRADED from iTunes 11 to 10.7! Its like going from a tablet to a computer!

  • Grégory R. Calculating status...
    Currently Being Moderated
    Dec 8, 2012 12:14 PM (in response to Cthulhu)

    Thank you, for the trick !!!

    This iTunes 11 it's just ******** !!!

  • IanR94521 Calculating status...
    Currently Being Moderated
    Dec 8, 2012 2:17 PM (in response to Grégory R.)

    This could be a lifesaver. I got iTunes 11.0 forced on me in a Mountain Lion update, then when I opened the new iTunes, it told me it could not locate over 5500 files! ***!

    I tried ot restore 10.7 from a TimeMachine backup, but it would not let me do that "as it is part of the system". Is anyone at Aplle paying attention to this? They are really losing direction with their software these days.

     

    I'll try the method detailed above to get back to 10.7. Thanks for the advice.

  • Daryl DuLong Level 1 Level 1 (35 points)
    Currently Being Moderated
    Dec 12, 2012 6:14 AM (in response to jausenbox)

    This worked perfectly.  Thank you!

  • dutchmike1966 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 12, 2012 12:38 PM (in response to Cthulhu)

    I was a bit concerned when starting the downgrade process, but it worked great. Exactly followed the steps of Cthulu. Thank you. For me main reason was the horrible performence of Airplay in iTunes 11 (drop outs of the stream). It looks like it works all fine again under 10.7.

  • William Keele Calculating status...
    Currently Being Moderated
    Dec 12, 2012 2:01 PM (in response to Cthulhu)

    So apparently I'm not the only one HATING iTunes 11.  I've even given it a couple weeks to grow on me, and this is probably the first time since being an iTunes and Mac user (since 2005 and Aug2007 respectively) that the more I use an update, the more I hate it!  And I'm not even a person that uses the mini player too.  I'm finding what use to take one click, or none at all, now takes two or three.  After the nonsense Apple tried to pass off for iSO 6 for iPhones, I should have known better than to decide to upgrade to iTune solely off their own description of the update.  I'm really getting the feeling that my concerns about some issues following the death Steve Jobs are not coincidental, and that the company really is taking a nosedive.

     

    That said, has anyone that's made the UPGRADE BACK to iTunes 10 have issues with files added to iTunes since the regretful move to 11?  I've bought several apps and albums since going to 11.  I updated to 11 on 29Nov and I've made any update to Lion offered since then (currently 10.7.4).  I have a lot of backups to choose from in Time Capsule.  As much as I want to get back to a more function iTunes for me, I don't want to lose purchased files either. 

     

    I've only once came close to reverting back to a previous update, but Apple came out with a fix for that update before I pulled the trigger.  Looks like that not going to happen for iTune 11 or Maps for iPhone (I've never had so many map search returns for another continent).  This has sold me on not considering upgrading to Mountain Lion and has me second guessing buying an iPad mini.  Way to go Apple on embarrassing a continually proud convert of over five years.  I'll be sending some nice feedback formally to Apple in the next few days.

  • William Keele Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 12, 2012 5:09 PM (in response to William Keele)

    *Sorry, make that Lion 10.7.5.

  • DrJeff_92677 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 15, 2012 7:52 PM (in response to Pehtis)

    MobileDevice.framework has a permissions problem. I can copy the other files from an archive disk t had an earlier iTunes, but the MobileDevice.framework permissions won't allow it to be overwritten, and the number of files is simply too many to check each one.

     

    I don't buy iTunes music, so maybe the problem isn't important. I can still visit the iTunes store, I don't care about their Genius stuff anyway, but it would be nice to remove the error message.

     

    I have a MacBook with Mountain Lion and the removed the simple web server support that uses the "sites" directoy. Now they want another upgrade fee to put the features back.

     

    Not sure what's up with Apple these days, but the polish is wearing thin.

  • Cthulhu Level 1 Level 1 (60 points)
    Currently Being Moderated
    Dec 16, 2012 1:54 PM (in response to DrJeff_92677)

    Well DrJeff, I certainly agree about the polish, but I think I can help on both problems.

     

    As far as the permissions, you should be able to restore the /System/Library/PrivateFrameworks/MobileDevice.framework/ directory to someplace like your desktop. If the Finder does not allow you to authenticate, you might need to use the command line. Assuming the directory is on your desktop, quit iTunes, then try this in the terminal:

     

    sudo cd /System/Library/PrivateFramework

    sudo mv MobileDevice.framework MobileDevice.framework.orig

    sudo mv ~/Desktop/MobileDevice.framework MobileDevice.framework

     

    That should prompt you for your password. If all goes well, and iTunes works fine, you can:

     

    sudo rm -r /System/Library/PrivateFramework/MobileDevice.framework.orig

     

    If not, you can always put back the original without Time Machine:

     

    sudo cd /System/Library/PrivateFramework

    sudo rm -rf MobileDevice.framework

    sudo mv MobileDevice.framework.orig MobileDevice.framework

     

    The permissions should be right, but you can always change them manually as well:

     

    sudo chown -R root:wheel /System/Library/PrivateFramework/MobileDevice.framework

    sudo chmod -R 755 /System/Library/PrivateFramework/MobileDevice.framework

     

    As far as losing the ~Sites Web server (sorry all, I know this is off topic) the server is still there, but you need to edit a file. See http://reviews.cnet.com/8301-13727_7-57481978-263/how-to-enable-web-sharing-in-o s-x-mountain-lion/ for instructions.

  • DrJeff_92677 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 16, 2012 2:39 PM (in response to Cthulhu)

    Thanks for the reply. I can issue the commands, but I'm not a Linux expert, so it's not something I could figure out on my own.

     

    Again, much appreciated.

  • louK3000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 16, 2012 9:41 PM (in response to TheStig111)

    Thanks.

     

    I've reinstalled 10.7 with no errors of any kind.

     

    Just needed to know where to find those files to get rid of the error dialogs.

     

     

    Thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.