9 Replies Latest reply: Jan 14, 2014 9:01 AM by LostInTechieTalk
Achim Schietinger Level 1 (0 points)


Aperture shows an empty import panel. Sometimes it is available after a reboot. The problem occurs, since I have Aperture installed the first time. Remove and reinstall does not help. OS X and Aperture are up to date.

Does anyone know what could cause this?

Regards, Achim



MacBook Pro (15-inch Early 2011), OS X Mountain Lion (10.8.2)
  • Frank Caggiano Level 7 (25,722 points)

    When the UI messes up like this a good first guess is to remove the preferences file. See Aperture 3: Troubleshooting Basics and go the section

    Delete the user preferences


    Post back if that doesn't fix it.



  • Achim Schietinger Level 1 (0 points)

    Tried this one. The import panel was working again but only for one Import.

    I have 20000+ photos in 300 projects in a folder structure on a samba share which I want to migrate into Aperture. Don't like the idea of deleting the prefs 300 times.

    Any suggestion is appreciated!

    Regards, Achim

  • Achim Schietinger Level 1 (0 points)

    Apparently this is a problem of samba.

    After moving all files to an USB drive, I could import all photos into aperture.

    Is import limited on local file systems?

    Regards, Achim

  • léonie Level 10 (90,960 points)


    I see the image files on a Samba server without problems. Is your network connection reliable?



  • Achim Schietinger Level 1 (0 points)


    yes, I'm directly connect to the server through a gigabit switch and all components are working properly. Maybe it's a problem of the samba implementation of my synology.

    I understand that I cannot store my library on the synology because it does not support hpfs but import should not be limited on the file system, right? 


  • léonie Level 10 (90,960 points)

    I have seen no official Apple document, that restricts importing from a network volume, but quite a few users had problems storing their referenced originals image files on samba servers. You are not trying to import referenced, are you?

    As a general advice: when importing from foreign file systems, it is safer to go for simple file names and to edit the filenames before trying to import, if necessary:

    • avoid "umlaute" and other ethnic characters,
    • avoid any character, that the unix shell may treat special as a pattern, like "*", "/", "^" or "~";
    • take care, that the filenames are unique, even with capitalization ignored,
    • and use very short filenames, on no account longer than 32 characters, to be on the safe side.
  • Achim Schietinger Level 1 (0 points)


    no I tried to import the files with move option (into another directory on my USB drive).

    Thank you for the advice. The filenames are generated by the camera and I did not change them: 12 digit alphanumeric characters.

    Anyway - moving them to the local fs before importing solved the problem.

    Regards, Achim

  • nanowire Level 1 (0 points)



    I have the same problem;

    After importing image files from SD-card, storing the originals as referenced on a synology nas (samba I assume?), the import panel in Aperture disappears. Very annoying indeed since it need a reboot or pref. file delete.


    Do you know anything about this and could perhaps point me to more info on the issue I would be gratefully.


    Best regards,


  • LostInTechieTalk Level 1 (0 points)



    I have exactly the same problem wirting referenced picture to a Drobo, with AFP.  I'm assuming there is no solution yet?  I have to delete the preference file after every import.