Skip navigation

My iMac PowerPC G4 will not connect to my Belkin N  router. I have not been able to connect for so long that I actually gave up on this computer until today, so it is a little out of date software wise. It is running OS 10.3.9.

392 Views 4 Replies Latest reply: Dec 3, 2012 9:41 AM by borgeano RSS
Shyno Calculating status...
Currently Being Moderated
Dec 1, 2012 9:55 AM

First off i apoligize for the title length, a bit new to help forums and didnt realize thats what that was .

 

Anyways;

 

My iMac PowerPC has been having this issue for quite a few years, prompting me to flat out replace it. I recently had a friend come to need a computer, and told them they could have it once i got it working.

 

The unfortunate problem that i luckily discovered: my friend and i use the same brand / model of Router, the Belkin N+ (N plus incase it removes the plus sign like it did in the title).

 

Ive tried everything i know, which isnt much. I've verified the password is correct, ive restarted the computer, and ive restarted my modem and router. Nothing works.

 

I should mention also that the computer is out of date program wise (obviously) since i havent been able to connect with it in so long. I am still using Internet Connect, and the computer still gives me the option to try .Mac.

 

Any help would be greatly appreciated.

 

Dean

iMac, Mac OS X (10.3.x)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.