4 Replies Latest reply: Dec 1, 2012 4:36 PM by Rambling Joe
dyonysys Level 1 Level 1 (0 points)

i just bought a new iphone 4 and my imac g5 doesnt seem to be compatible. itunes says i need the newest version and when i try to download it, it says my os needs to be updated, but i think sence my computer is older i dont have an intel imac?? help??


iPhone 4, Mac OS X (10.4.11)