12 Replies Latest reply: Jan 26, 2014 8:07 AM by baldfox
KGriff Level 1 Level 1 (20 points)

I have two PC's both initially had windows 7 installed 64 bit version with iTunes (x64) both had home sharing enabled and worked fine. Both had windows firewall and were running Microsoft Essentials security software free version. I had no problems with home sharing from either PC to my apple TV version 2. One computer and my apple TV are hard wired to my network and the other Pc is linked via 802.11n wireless and all were working fine in regards to home sharing.

 

In recent days I have completely wiped and re-installed one PC (linked over wifi to my network) with the new windows 8 operating system 64 bit and yesterday installed iTunes v11 (x64). I have enabled home sharing on this upgraded pc and whilst my apple tv can see both pc's when I now choose the windows 8 PC it tries to access the shared library but then fails. I have not installed any third party firewall or anti-virus software in fact I have even disabled the windows 8 firewall both for private and public networks and still home sharing fails to work with windows 8.

 

I have tried rebooting the pc ... I have restarted the router and ensured upnp is turned on... I have even uninstalled and reinstalled all apple software in add/remove program's including the bonjour software, apple mobile device, iTunes etc... But still my apple tv remains unable to access the library.

 

So my question to the community here is quite simple can anyone confirm for me that they have home sharing working with windows 8 (64 bit version) and iTunes 11 software... I have spent two whole days on this with no joy at finding an answer to my problem and wondering now if there is a bug in iTunes 11 or more likely windows 8 that needs a developers fix or whether I need to spend some more time on this issue. I am quite certain my router is not the problem here as home sharing on my other windows 7 pc is still working fine and without a problem so it is looking more likely to be an issue with windows 8. I have not altered any of the routers settings at any stage.

 

The apple TV is running the latest firmware and also updated yesterday.

 

Thanks in advance to anyone with windows 8 (x64) who responds to this Question.

 

Kind regards.... Ken Griffiths

  • benmx Level 1 Level 1 (0 points)

    Confirmed. 

     

    I have exactly the same problem.

     

    New Sony Vaio Win8 64-bit... Working fine on iTunes 10.7, upgraded to iTunes 11, and home sharing jacked.

     

    Can sometimes play a from my video library to the ATV, but no more. 

     

    Can control ATV thru iTunes 11 using AirPlay.

     

    Downgraded to 10.7... Still on Win8, same problem.  Looks like an incompatibility issue.

     

    -Ben

  • KGriff Level 1 Level 1 (20 points)

    Thanks Ben for the reply... I have tried everything I can think of to get home sharing working on windows 8. It seems crazy that my windows 7 pc works fine, but that windows 8 with itunes 11 will not share a thing.

     

    I have even gone to windows 8 compatibility wizard settings and made both iTunes and bonjour apps compatible to running in windows 7 environment and still that has not made a difference. Frustrating considering that v11 of iTunes was delayed for additional testing prior to release, albeit I suspect that added security in windows 8 is the root cause of the problem.

     

    Looking through the other discussion groups here, it seems others have issues too with home sharing i.e. was working prior to the upgrade but v11 is causing a few problems .. So let's hope we see a fix in the near future.

  • WadePC Level 1 Level 1 (0 points)

    I too am experiencing the exact symptoms.  I have no issues with syncing devices with Windows 8 Pro 64bit and iTunes 11 64bit. 

     

    What fails is Home Sharing and Apple TV streaming.  Have tried all the options listed above (re-installs, compatibility mode, etc.) but with no success.

     

    Essentially, it works one time (playing a song or a video) but when I change songs or select another video it hangs indefinitely.  Sometimes if I restart iTunes or log in or out of home sharing it will work again but only one time.

     

    I do have iTunes 11 running on my Lenovo laptop with Windows 7 64bit and everything works like a charm. 

     

    I'm really hoping for a quick resolution to this as well.

  • benmx Level 1 Level 1 (0 points)

    WadePC... You nailed it.

     

    It's strangely satisfying that we all have the same exact problem...  At least we know it's not something we're doing incorrectly.

  • WadePC Level 1 Level 1 (0 points)

    I hate to speak too soon but wanted to let you know that after upgrading my dlink routers to the latest firmware (both updates claiming ipv6 improvements) my iTunes, windows 8 pro and Apple TV are working again.  I just skipped around to 4 or 5 different videos and songs with good success!

     

    Here's the details:

    My primary Router is an Arris wireless gateway provided by my ISP. It is my primary dhcp server.

     

    I have a dlink 645 in my entertainment cabinet.  It is being used only as a wireless access point and was running firmware 1.01 that is now upgraded to 1.03.  The Apple TV (latest version/firmware) is wirelessly attached in the same cabinet.

     

    My upstairs PC is my iTunes host and its Ethernet attached to a 655 that is also functioning as a wireless access point.  I upgraded its firmware from 2.01 to 2.10.

     

    Will post one more update if things continue to go well.

  • KGriff Level 1 Level 1 (20 points)

    WadePC ... Thank to you stating you had iTunes 11 home sharing working with windows 8 x64, as a result of your post, I decided to set some more time aside to re-look at my issue.

     

    As stated, I have two PC's almost identical hardware, one running windows 7 x64 and the other recently upgraded to windows 8 x64... The windows 7 PC shares all music, movies and pictures without any problem to my apple TV version 2... But the windows 8 PC (with no firewall etc) would not share at all.

     

    I spent a lot of time today with the windows 8 PC and tried everything I could think of... But still no joy... You could say this went as far as a complete reinstall of the operating system and other software.

     

    I then went on to check all my network links  and router and still that did not make a difference. My home sharing would not work with my windows 8 PC.

     

    The final thing I decided to do this evening was look at the apple TV box itself which, like I said, was working fine with my windows 7 PC and has done so since I first purchased the apple TV in March this year. I went into the settings and tested the network etc and that showed no problems at all... I tried messing around with times/dates and a variety of other settings but still no joy.... Then I decided to do a full factory RESET of the apple TV device and set it all up again from scratch... And 'VOILA' ... The **** thing worked.

     

    So strangely it seems it was my apple TV needed a reset after the recent firmware upgrade. Odd really considering it had always worked with my windows 7 PC ...?

     

    Anyhow both PC's are now happily sharing their libraries without a problem. So if anyone else out here has a similar issue perhaps they too may want to try the factory reset of their apple TV device. Hope this thread helps someone else who encounters a similar problem.

  • benmx Level 1 Level 1 (0 points)

    No joy for me on the reset.

     

    Like before, the AppleTV plays the first video fine, but subsequent requests to stream from the PC just hang.  I'm still on iTunes 10.7... and I'm still leaning toward it being a Win8/64bit issue.

     

    Tomorrow I'm going to try launching the library from my old Win7/64bit machine and if it's able to play two videos in a row, that'll tell me all I need to know.

  • jelkar Level 1 Level 1 (0 points)

    Had same problem.

    Tried to start iTunes as administrator and sharing worked just fine.

    Then I thought, hey maybe Windows Defender is not playing along!

     

    After entering "Control Panel" -> "Windows Defender" -> "Settings" -> "Exclude processes" and adding C:\Program Files (x86)\iTunes\iTunes.exe to the list everything worked fine, even as non-admin users.

     

    Hope this work for you guys?

  • Shrinkapp Level 1 Level 1 (0 points)

    Thought I'd add my 2 cents. I have a Win8x64 PC wi two Win7 (x64 & x32 lptp)...Had trouble wi Homegrouping wi the Win8  until I realize there seems to be a pecking order, i.e. the Homegroup would only set up from the lptp and activated subsequently only if the lptp was on????? Anyway, seems like the Homesharing has the same protocol bec I couldn't get initial additions to Homesharing even though its iTunes said it was Homesharing unless I opened the non-sharing PC before the others on the network and d/c'd and re-entered 'turn on Homesharing'. Then all worked fine.

  • The_Brain Level 1 Level 1 (0 points)

    Hello,

     

    Router, Reset .... wont help at all. I tried alot of things and it doesnt help.

    After alot trys i find the solution.(Also u dont need to restart itunes every day)

    -Go to Windows Firewall

    -Search for BranchCache in Input Output Rules. There must be like 4 Rows with this Point included.

    - Activate them all

    - Now your Homesharing should working fine

     

    I hope this will fix the problems

  • Kurns Level 1 Level 1 (0 points)

    Jelkar I could kiss you. I originally had a Win7 x64 machine working fine for years with Airplay until iTunes 11. Then it stopped, tried what I thought was everything and eventually gave up.

     

    Got a new Win8 x64 machine, Airplay worked fine. Just put the previous issue down to the fact that it was an older machine and I was going to get rid of it anyway.

     

    Then I bought another new laptop and went back to Win7 x64 (sorry Windows 8, I just don't like you). With this new laptop Airplay was working fine so I was completely happy with everything in the world.

     

    Until last night. Airplay wasn't working again on Win7!!!

     

    Using the famous Kepner-Tregoe Decision Making and Problem Solving techniques, I realised the few changes I had recently made on this machine were:

     

    1. Updated the wireless NIC drivers

    2. Install the updated Win7 OS patches

    3. Removed McAfee and installed Windows Defender instead.

     

    I was suspecting the last one and was just about to remove it, when I found your post about excluding the process from scanning and voila! Problem solved.

     

    Thanks a lot Jelkar.

  • baldfox Level 1 Level 1 (0 points)

    Just to let you know, I had this same problem. ATV3, win8.1 and a microserver running WHS2011 (also running itunes no problems). ATV3 can see WHS but not the Win8.1 library.

     

    I tried many fixes...

    1) adding itunes as an exception in defender.

    2) disabling IPV6

    3) enabling branchecontrol firewall...

     

    nothing helped, but then i came across this:

    http://one-miguel.blogspot.ru/2012/06/itunes-home-sharing-not-working-solved.htm l

     

    Disabled QoS and bingo! Homesharing works, restarted itunes, the WHS library came up immediately. I've not changed any of 1-3 above, so it might be a combo, and i have homeserver and share my library working !