Previous 1 2 Next 18 Replies Latest reply: Apr 8, 2013 6:12 PM by futurerichperson
czuriaga Level 1 (0 points)

Since I installed the new MacOSX Mountain Lion in my iMac (mid-2007), I'm experiencing a weird behavior.


Usually when I'm doing a heavy usage (many programs opened like firefox, downloads, mysqld, sometimes, not always, a Virtual Machine,...), the screen freezes, the mouse pointer moves, but no action can be done. No mouse or keyboard action take effect since this moment.


But if I connect from another computer by SSH, I can see all the processes running,  everything I had opened, is still there (including SSH server I use to connect). From this SSH session I can stop or start everything, but the main iMac screen remains frozen (except the mouse pointer that can be moved). Sometimes the mouse pointer becomes a spinning wheel.


I don't know if I can restart anything from the SSH connection, in order to recover my session, because the only thing I can do, is a "sudo shutdown -h now" from the SSH session, loose all my work, and wait for the switch off...


I've read in other article something about restarting the WindowServer process using a command "sudo killall -HUP WindowServer" but the result was a spinning gear (not the rainbow ball) on top of the frozen screen, running forever. The WindowManager did not restart.


Is this a known problem in the  MacOSX? Any coming solution (patch) or, at least, a workaround to recover from the frozen state?

iMac, OS X Mountain Lion (10.8.2)
  • LousyFool Level 4 (2,645 points)

    Please make sure that you have no "old stuff" like apps/drivers/tools on board that is not 100% ML-compatible. A way to verify is booting in Safe Mode and seeing if problems persist. If they don't, you want to clean your machine from that old stuff, or upgrade each item to the latest and greatest ML-compatible version.

  • czuriaga Level 1 (0 points)

    The problem is that I can't reproduce the problem when I want. The only coincidence of all freezes is always an intense use of resources (memory mainly, I think)


    When I opened the VMWare, freezes were more often. Lately, I try not to open VM, but if a have Firefox with several tabs, MySQL server, Transmission with downloads, Mail, Terminal, BBEdit, and I open big .CSV files with Excel for Mac... firstly I notice the hard disk pagination, and sometimes, in last instance, the screen freeze.


    This happens once a day, sometimes I can work more days without rebbot, if I try to close unnecessary applications I'm not using at this moment.    


    The screen is frozen, but all the processes carry on working, I can see them in the SSH session from the other computer, how downloads are updating, or I can connect to mysql, or stop it succesfully.


    Everything works, except the User Interface in the Mac which is frozen.

  • LousyFool Level 4 (2,645 points)

    Maybe your RAM is bad. Test it.


    Launch the Console app and see if you find logs, or at least log entries that contain information on what causes the freezes.

  • bbaggin5 Level 1 (0 points)

    I am having the exact same problem, with the exact same symptoms on my late 2009 iMac. I can be working on something, pause for a second and when I attempt to continue I can only move the cursor, nothing else reponds, clicks, keyboard, etc. The machine is still active though, since I can access it on the network. I don't remember exactly when it started, perhaps only sonce the last Mountain Lion update.

  • nextraterly Level 1 (0 points)

    I have a similar issue. Looking around here I found there is an issue with the appleeventsd process.


    Check on your events log.  On mine, it was taking up 97% of processor time.  End the process here, or in terminal

    "Sudo killall -KILL appleeventsd" seems to solve it, for a while. But the process starts up again before long and you have to keep doing it...

  • bbaggin5 Level 1 (0 points)

    Thanks much for the suggestion. I've started Console and Activity Monitor so I can keep an eye out for anything suspicious. Thus far nothing. I had also found a post about the same symptons related to Safaris. I recently started having a lot of open tabs so I followed that advice as well. It suggested resetting Safari and cleaning the cookies and cache.

  • czuriaga Level 1 (0 points)

    I downloaded the MemTest 4.22, rebooted in Single-User, and made a "memtest all 2". Memory is OK.


    I see many people complaining about the same problem. I haven't notice a process appleeventsd taking the processor time, but I'll check next time.


    If this problem is affecting so many people, probably is a bug in the Mountain Lion, I hope Apple identifies the problem and release a bug fix soon.

  • cute crow Level 1 (35 points)

    I'm having somewhat similar frezes on a 2009 iMac, since I upgraded to Mountain Lion form Snow Leopard. Except I can't move the mouse cusor in my freezes.


    I am have a few other issues too. Two of which, a hanging Archive Utility and a broken Spotlight Cmd+Click function, were fixed by force quitting appleeventsd in Activity Monitor.


    Its worth noting that it will automatically activate again, but the two issues remained fixed even with appleeventsd running again. I haven't done a reboot yet though.


    So perhaps it may fix the freeze issue too?


    Before killing appleeventsd, see can you uncompress a zipped or .bzp2 file using Archive Utility. If it hangs you have that issue too.

  • Eric Root Level 9 (50,612 points)

    How much memory do you have (About This Mac under the Apple menu)?  Adding more might help since it happens during heavy usage. If your computer is out of warranty, you might check here. This company has certified memory amounts above what Apple considered the limit.


  • cute crow Level 1 (35 points)

    I've 8 GB. Sholud be more than ample.


    I'm convonced, its crappy coding in Mountain Lion is causing it for me (as those two other issues would imply too)

  • Eric Root Level 9 (50,612 points)

    I agree 8 GB should be enough. I was wondering about the original poster since my 2008 iMac only had 2 GB, which is the minimum recommended. I have read more than one thread where Archive Utility was causing problems and some of the people much smarter than I am typed it was a bug.

  • futurerichperson Level 1 (0 points)

    Have you tried running the Adobe Flash Uninstaller and seeing if that helps? I tried everything but - fingers crossed - I have not had the issue happen since I uninstalled Flash five days ago. I am curious to know whether I just happened to hit some good luck by coincidence or if removing Flash cured the freezes.


    Some background - 2007 imac, froze after lion/mountain lion upgrade, tried everything apple support could throw at me with no results. Programs like Click to Flash did not help.

  • futurerichperson Level 1 (0 points)

    Never mind. Mountain Lion still crashes using Apple software on supported hardware and even Apple support and the Apple store cannot resolve the problem. Very disappointed that Apple would do something that would make their own hardware unusable. If I wanted to replace a PC frequently I would have bought a cheap Windows box.

  • guilleamodeo Level 1 (0 points)

    On my case this problem have been going on for months, and I am starting to think it does only affect  iMacs, as I have found posts on MacBooks freezing but they can't use SSH to access so it is not the same thing. I have  found no posts on Minis or Pros showing this problem either. My experience with this problem is long and I am not sure why it is happening, but I can tell you what is NOT making it happen:


    - Age of iMac is not an issue. Mine is an i3  3.06 Ghz, mid-2010 and my problems started almost a year ago.

    - It is not Memory size or quality. I started with 4 Gb, when I read was memory size, I added another 4 Gb and now have 16 Gb of certified identical modules.

    - It is not only Mountain Lion. My problems started when I upgraded to Lion, and after months of frustration I upgraded to Mountain Lion hoping that would solve and see where we are.


    I would return to Snow Leopard but I can't. I cannot run the development tools I use on SL. :-(


    I tend to think that the problem resides on the event manager, as the mouse is drawn by hardware and that is why it works, which also indicates the graphic card is working. My suspiction comes from the fact that when the problem happens, if I wait long enough doing nothing, the screen dims, so I tried to make the computer sleep by leaving it all night on, but it didn't go to sleep, but the screen blanked. I also logged in using SSH and tried to make it sleep with this command: sudo osascript -e ‘tell application “System Events” to sleep’ but it didn't work. I am now waiting for it to happen to try another one: pmset sleepnow to see if making it sleep takes it out of whatever loop it is in.

Previous 1 2 Next