Previous 1 2 Next 17 Replies Latest reply: Dec 3, 2012 11:37 AM by Roger Wilmut1
drsyn1967 Level 1 Level 1 (0 points)

OK, I was having this problem before and a simple delete of my cache fixed it, but not this time.  I have deleted everything off of my FTP and cache, published to my empty folder and Fetch'd it back onto my FTP.  Still shows old files???  I have tried to update the software, but the system indicates that this is the latest version of iWeb  (version 3.0.4). Help!

Mac OS X (10.6.8)
  • WALTER-MILANO-ITALY Level 4 Level 4 (2,175 points)

    iWeb will not update because it is no more supported by Apple.

  • drsyn1967 Level 1 Level 1 (0 points)

    Thanks, Walter.

    When did this happen?  I have been making major updates to my site over the past two weeks and they have worked every time until yesterday?

  • Roger Wilmut1 Level 9 Level 9 (72,445 points)

    iWeb has been discontinued for some time now and there will be no further updates to it. However you should be able to publish your site perfectly well using the FTP option in the publish pane.


    Are you sure that this isn't simply a cache problem? Even with Safari's cache switched off I often find that updates (not iWeb) fail to appear - I sometimes have to actually delete the file (even though it has been updated) from the server and re-upload to clear what I assume is my ISP's cache.


    You could try completely deleting the site from the server using Fetch and then uploading the lot from scratch.


    Can you get someone else to check the site for you - or would you like to post the URL here (and tell us how to tell the difference between the old and new pages).

  • Wyodor Level 6 Level 6 (19,655 points)

    To empty the caches along the route, add a ? at the end of the URL.


    BTW, the title of the topic is wrong.


    iWeb does not update the files on the server. The operation is entirely done manually by the user.


    Perhaps a wrong location?

  • Roger Wilmut1 Level 9 Level 9 (72,445 points)

    Wyodor wrote:


    iWeb does not update the files on the server.

    You mean it doesn't do it unless you tell it to? V3 does have an FTP option, though it appears that for some reason the OP has been publishing to a local folder and then uploading from that, successfully up to now.

  • Wyodor Level 6 Level 6 (19,655 points)

    That's what the OP said.


    He backed it up to his FTP (sic) with Fetch.


    So the first thing I would do is to open the file that's on the desktop. I would be surprised if that file is not updated by iWeb when it published that file seconds before.


    And if all else fails, do a clean install of the OS. HaHaHa.

  • Roddy Level 6 Level 6 (17,265 points)

    Are you uploading the whole folder of files produced by iWeb or just the contents?



    If you don't need to publish to a local folder to add SEO info, why not use the iWeb FTP. Its a no brainer to use...


  • drsyn1967 Level 1 Level 1 (0 points)

    This is my reply to all of you - thank you for your kind attempts at helping:  Everything is the same...  as I stated in my original post, here is what I have done:


    1. I had updated my website a few weeks ago with a change of galleries and successfully uploaded the site to my FTP (from my local folder), using Fetch.


    2. I made changes in the past three days.


    3. After attempting to Publish the complete site  (not just site changes) of my Local Folder to no success, I quite iWeb, and went into my FTP and deleted EVERYTHING.  Then quit Fetch.


    4. Then I deleted my Local Folder.  I searched all of my HD and External Drives for any possible matching folder that has the same files  (there are none). 


    5. Finally, I reopened iWeb, "Published Entire Site" - which created a new Local folder on HD.  I relaunched Fetch and uploaded entire new folder to my FTP. 


    6. Launched two different browsers on two different computers  (both have had caches and browsing histories dumped).  The results:  The current changes are still not there! 


    Here is the site:


    The links to "Corporate Logos" and "Corporate Print" should be at the top, and the galleries for all Corporate Print 1 should be one clients work  (not several), with the same setup for most of hte other Corporate Print links  (among other changes)!

  • drsyn1967 Level 1 Level 1 (0 points)

    and the "Automotive" links should be at the top.  I have done the above process (steps 1-6) probably half-a-dozen times and this is not updating.   THANK YOU for any help you can offer. I really appreciate it.

  • Roger Wilmut1 Level 9 Level 9 (72,445 points)

    There are two versions of your home page. The domain name alone leads to



    However there is a slightly different version at



    This is presumably because on one upload you uploaded the contents of your folder, and on the other upload you uploaded the entire folder. It's normally better to upload the contents, but adding the folder name to the URL may be leading to the preferred version.


    The stucture on your server is as follows:


    At root level an index.html file pointing to an index.html file in the folder '' which itself points to 'Mark_Counts_Creative%3A.html' within the folder


    Also at root level the folder ''


    And also the file 'Mark_Counts_Creative%3A.html' and the files for the various other pages.


    It would seem that you originally uploaded the contents of the folder on your Mac, then later you uploaded the folder itself with the amendations, leading to the confusion we have now. You need really to go into the server using Fetch and delete the entire lot. Then upload the contents of the folder.


    All of which leads to the question, as you have iWeb v3, why are you bothering with all this publishing to a local folder? iWeb will publish directly to the server for you using FTP, and when you make a change it will upload only the changed pages.

  • Roddy Level 6 Level 6 (17,265 points)

    You also have a colon in the home page name which is not a brilliant idea.

  • drsyn1967 Level 1 Level 1 (0 points)

    Thanks, Roger...  when I have published directly to the server, it always fails resulting with the pop-up "Publish Error" - There was an error communicating with the FTP server. Try again later, or check with your service provider."  I never had this problem when I published to a Local Folder.


    I'm running in circles at this point. I have deleted everything from my FTP again, deleted my Local Folder, tried publishing again thru the iWeb direct to FTP option and it did not work.  Went thru the process with the Local Folder and it is still not the updated site that I see in iWeb.


    Roger - I appreciate you identifying the two different versions and explaining how that happened  (folder vs. contents).  I had noticed the repitition in the URL some time ago and did not know how that happened. 


    Roddy - regarding the colon... I see that when looking at History, but not anywhere else. I do not know how that got there, or how to change it.  This is all very discouraging. Previously, I had successfully edited this site several times over the past 2 years or so.  Now I don't have a clue what to do next since I have deleted everything again and again.

  • Roger Wilmut1 Level 9 Level 9 (72,445 points)

    There are still two versions of your site up and I don't think I see any changes. Whatever it is you think you've done, you haven't done it.... when you use Fetch to access the server do you actually see the files there as I described them?

  • Roddy Level 6 Level 6 (17,265 points)

    Have a look at the pages I linked to above. The first one shows the difference between uploading the folder and the contents.


    The second one shows the publishing settings. When using the iWeb FTP, leave the Directory/Path field empty.


    You can change the site name in iWeb to something different to simplify the URL and add keywords for SEO.

Previous 1 2 Next