4 Replies Latest reply: Dec 3, 2012 5:45 AM by CassandraOh
CassandraOh Level 1 Level 1 (0 points)
My iPhone 4S has suddenly decided, one week after buying it new, that it will not receive a charge.

I don’t even understand how this is happening. It was working fine three hours ago. My battery started getting low, so I plugged it in. I was still using it, is was still on. I noticed that the battery, even though it was plugged in, was getting lower and lower, until it was completely depleted… But I was still using it. So, I turned it off thinking maybe if I turned it off and let it charge, and turn it back on that it might help. But, three hours later, no charge, and it wouldn't even turn back on.  Just a few minutes ago, it turned on but still held no charge.  I tried to reset using the on/off and home keys, and now I'm back at square one with a phone that won't turn on.

I am so mad.  HAAALP

iPhone 4S
  • carl wolf Level 6 Level 6 (14,360 points)

    By what method are you trying to charge your iPhone?  Are you using the USB port on your computer, or are you using the external iPhone power adapter?

  • CassandraOh Level 1 Level 1 (0 points)

    I've tried both.  I've tried two different cords, two different adapters, and my computer.  Nothing.  It recognizes that it's plugged in, but it won't actually charge or turn on.

  • brad805 Level 5 Level 5 (7,305 points)

    Clean the iPhone charging port with a clean dry toothbrush. See if better, if not, then make Genius reservation or contact Apple Service, this will be handled under Warranty. If this is a complete hassle then take receipt, iPhone box, and all contents to place where you purchased it and return for refund. Then you can buy a working iPhone. I would go the Apple Warranty route, but it is your choice.

  • CassandraOh Level 1 Level 1 (0 points)

    I'm just going to take it back to Best Buy.  Fortunately I'm still within two weeks of my upgrade so they'll either give me a new one or let me pick a different phone altogether.  I'm tired of Apple...  This bug should have been worked out by now.  It's not like the 4S is a new phone.


    <Edited By Host>