Previous 1 2 Next 17 Replies Latest reply: Dec 9, 2012 1:07 PM by meganfromkanwal
Gtrcoop007 Level 1 Level 1 (0 points)

I recently updated my iTunes to 11.0 and now everytime I play a movie in Apple TV when my MacBook Pro goes to sleep, my home sharing gets cut off and the movie stops.  This has never happened before when watching a movie on Apple TV.  I know I can select to "never" have my MacBook go to sleep, etc., but I shouldn't have to do that when I didn't have to do that prior to the new 11.0 iTunes update.

 

Any thoughts?

 

Thanks in advance!


MacBook Pro, Mac OS X (10.6.8), Apple TV 2
  • Gundtoft Level 1 Level 1 (0 points)

    I have the same problem. On a similar note, I have another problem that makes WOL not work on my IMac with ATV:

     

    https://discussions.apple.com/message/20446876?ac_cid=op123456#20446876

     

    Really disappointed that even with a full blown Apple eco system, there are still bugs that do not get fixed and cause pillar features to not work.

     

    Let's hope this new Itunes problem will get fixed soon (it probably will as it basically renders homesharing useless).

     

    In the meantime, have you tried disabling/enabling homesharing (haven't had time to try it myself yet, but it may work)...

     

    Br,

     

    Martin

     

    (sorry about the sour tone, but I am getting increasingly annoyed with again and again finding myself sitting for hours debugging out of the box issues on featured functionality on Apple products).

  • 80297 Level 1 Level 1 (0 points)

    Same here—just updated to iTunes 11.0, and while watching something from my iTunes library on Apple TV, it cut out. As you noted, this never happened in previous versions. Regardless of my settings in Energy Saver, as long as there was a connection through Home Sharing, everything hummed along nicely.

     

    I agree that Apple will eventually figure this out, but I have to file this one under "Really, guys?" And in the meantime, it's "never" for sleep mode, which obviously renders Energy Saver useless.

     

    It's stuff like this that makes people wish they hadn't updated their software.

     

    MacBook Pro (9,2), Mac OS X 10.8.2, Apple TV 3

  • Gtrcoop007 Level 1 Level 1 (0 points)

    Sure hope the Apple techs are seeing this post and have an available update in the works and sent out soon.  I'm sure there are more than three people having this problem.

     

    Thanks!

  • nhurenkamp Level 1 Level 1 (0 points)

    Hi Guys,

     

    I have the same problem. Since the update of iTunes 11 and the new ATV updates my Atv's are useless.

    I have 4 x ATV 3 and 2 Macbook pro's. All wireless connection via an airport extreme

     

    since the update the following happens:

    - Once you have started the Atv up and out of sleep mode, it now takes a while to find the Library.

    - Then I select the show I want to watch and within 5-8 min's it suddenly stops and says no network connection.

    - Then after a minute, the ATV regains network connection, so I select the library and then its says that there is no Home sharing available.

    - After2-3min it finds home sharing and I can get back into my itunes library.

    - Select the same show to continue watching but the same S*^%$ happens again and again. So after doing this 2 or 3 times I give up and put on a DVD.

     

    Has somebody found a fix as this is just so annoying.

     

    hope someone can help

     

    BR,

    Nicholas

  • Moodyblues1977 Level 1 Level 1 (0 points)

    Hi, I visited the Genius bar yesterday and as much as they were very helpful they were unable to solve the problem. I've reinstalled iTunes and Apple Tv 3 times now and I still get the same problem. The chap at the Genius bar said that there was only 2 other people in the WORLD with the same issue?! Ha...I think not.

     

    I can watch all films I have purchased through iTunes without any problems. It's just Homesharing that is giving me a headache.

     

    I have somebody from iTunes calling me tomorrow but I get the feeling that nothing will be sorted.

    Let's hope Apple sort this problem soon. Otherwise I've just got a £99 tea coaster.

  • leemmccormick Level 1 Level 1 (0 points)

    Well, there's quite a few on here so I guess the 'Genius' bar staff don't read thier forums.  Oh well.

  • Gtrcoop007 Level 1 Level 1 (0 points)

    Hmmmm..just from my original post, I count FIVE people in the world that have this problem.....don't have enough fingers and toes to count all the other hundreds of thousands of others out there.....

     

    Issue still happening.  I really DON'T like switching my sleep mode to "Never" so this problem won't happen when watching a video off ATV.

     

    I also find that even when I have iTunes open on my MacBook Pro and then turn on ATV (or at least "wake" it up), it gives me an error message regarding home sharing.  Sooooo....I then close iTunes...open it back up....then go to ATV and "restart" it.  Sometimes it takes and it's successful in finding my library and home sharing works...but not always.

  • Gag1964 Level 1 Level 1 (0 points)

    Make that six people with the same issue. I have turned Home Sharing on both the Mac and Apple TV and I still can't share.

  • Robster322 Level 1 Level 1 (0 points)

    Glad I found this thread, the same thing seems to be happening to me.  I've adjusted my "computer sleep" setting (but not "display sleep") and we'll see what happens.

  • rob kaplan Level 1 Level 1 (0 points)

    make that 7!!!

     

    Apple blamed it on my wifi network!  NOT!

  • fvwessel Level 1 Level 1 (15 points)

    what worked for me was to swith off the option ' put harddisk to sleep when possible' , I guess because my itunes library resides on an external disk connected via firewire.

     

    combined with adjusting computer sleep to never I didn't had any issue anymore, even when AppleTV was playing Itunes content for the entire day.

     

    Regards,

    Frans van Wessel

  • h20medic Level 1 Level 1 (0 points)

    Same problem here.  Didn't happen before iTunes 11 update.

  • nhurenkamp Level 1 Level 1 (0 points)

    Well guys,

     

    - After resetting my extreme and re-configuration/installation to what it was. Same configuration.

    - tell my Mac Pro not to put my hard disks to sleep

    - hooking my Mac Pro to the network by cable

    - switching off wifi on my Mac Pro.

    - linking all atv's to the same wifi network router. I have 2 wifi routers in my house. 1 is downstairs and 1 upstairs. Both on the same network. Now I have linked all 4 to upstairs extreme router. Although the atv downstairs only shows 1 bar, it still connects now to iTunes.

     

    I have now had 1 day without a problem.

     

    So wish me luck if it will stay like this.

     

    Regards and let me know if this helped somebody. Don't want think this was only a temp fix.

  • leemmccormick Level 1 Level 1 (0 points)

    I'd just like to confirm that it works flawlessly if you cut out the Wifi/Router entirely by connecting the ATV directly to the home sharing device via Crossover cable.

Previous 1 2 Next