6 Replies Latest reply: Dec 3, 2012 7:24 PM by dg123456
dg123456 Level 1 Level 1

This morning my MBP, mod 6,2 (8GB, 500GB), started acting strange (would not minimize Word, Safari would crash and re-crash on restart...)

so I decided to reboot it. Never came back.


The system sits on the grey screen forever. In many attempts, once or twice it went to the login screen, and after I entered the password, got stuck on that screen removing the cursor.


So far I have:


- booted ML in recovery mode, checked and rechecked the HD (verify disk, check permissions....) - all ok

(recovery mode runs fine, I can browse the web, run disk utility....without any problem)

- reset PRAM and SMC (even if the problem does not appear related)

- booted the AHT disk and passed the brief test (am running the extended one now)

- booted in verbose mode and learned that the system gets stuck in these steps


Com.apple.launchd          1 com.apple.UserEventAgent-LoginWindow                       #          stopping job

Com.apple.launchd          1 com.apple.UserEventAgent-LoginWindow                                #          Sent Job SIGKILL

Com.apple.launchd           1 com.apple.universalaccessd                                           #          stopping job

Com.apple.launchd            1 com.apple.universalaccessd                                                    #          Sent Job SIGKILL

Com.apple.launchd            1 com.apple.helpd                                                               #          stopping job

Com.apple.launchd            1 com.apple.helpd                                                                        #          Sent Job SIGKILL

Com.apple.launchd            1 com.apple.coreservices.appleid.authentication   #          stopping job


where # is the process ID, which keeps increasing. The first time it appears, reads 249, then works its way up constantly.


Any clue on what could be wrong?? I'm mostly interested in backing up the last few days of work before doing anything

drastic with the system, but need to get in the system to do that.


Thanks in advance

MacBook Pro, OS X Mountain Lion (10.8.2), 8GB, 500 GB
  • KianaDarkrose Level 1 Level 1

    something is going on with your launch daemons. When you're getting stuck on that gray screen, that's the part of the startup process when the mac is loading the firmware needed to boot. If it's not going past that, they may be corrupted, or the computer for whatever reason is just not able to find them. Have you been able to get into safe mode at all? Have you recently installed anything 3rd party? (software or hardware). Worst case, you may just need to reinstall the OS from recovery

  • Radiation Mac Level 5 Level 5

    I would recommend resetting the SMC and the PRAM on your MacBook Pro:



       Resetting NVRAM / PRAM

    1. Shut down your Mac.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.


    Resetting the System Management Controller (SMC)

    Resetting the SMC on Mac portables with a battery you can remove

    Note: Learn about removing the battery on MacBook and MacBook Pro.

    1. Shut down the computer.
    2. Disconnect the MagSafe power adapter from the computer, if it's connected.
    3. Remove the battery.
    4. Press and hold the power button for 5 seconds.
    5. Release the power button.
    6. Reconnect the battery and MagSafe power adapter.
    7. Press the power button to turn on the computer.




    Hope this helps

  • dg123456 Level 1 Level 1

    I should have mentioned that I also tried to boot in safe mode several times.

    It always gets stuck with the progress bar at about 25% progress.

    I don't know how I can boot safe and verbose mode at the same time,

    but feel that the process stops at the same time.


    I did manage to get to the login screen a couple of random times, and I also tried to log in the guest account to see if by chance something was related to my own account, but the process got stuck with the guest account too.


    I have reset the PRAM and SMC. In my case the battery is built in, so I followed the instructions for those MBPs

    and believe the reset worked because my chime got louder after I did the procedure.


    The one other clue I can see while booting is this message:

    unable to read  /var/db/bootcahce.playlist : 2 no such file or directory


    and sometimes two more messages for missing files in



    I'm ok reinstalling ML from the recovery partition but worry a bit about missing my last few days of backup.

    Are my files supposed to be safe in this process???


    Thanks for your help

  • dg123456 Level 1 Level 1

    sorry should have type it more precisely


    unable to read  /var/db/BootCache.playlist :  2 no such file or directory


    file names are case sensitive...


    Nevertheless my main concern at the moment is whether reinstalling ML from recovery is not going to affect my files, which I have not been able to back up (about one week of data). Otherwise I fear my only option is to extract the HD (or boot in target disk mode) clone it, and then run the process knowing I have the original somewhere else.

  • Linc Davis Level 10 Level 10

    If you want to preserve the data on the boot drive, you must try to back up now, before you do anything else. It may or may not be possible. If you don't care about the data, you can skip this step.

    There are several ways to back up a Mac that is unable to fully boot. You need an external hard drive to hold the backup data.

    1. Boot into Recovery (command-R at startup) or from a local Time Machine backup volume (option key at startup.) Launch Disk Utility and follow the instructions in the support article linked below, under “Instructions for backing up to an external hard disk via Disk Utility.”

    How to back up and restore your files

    2. If you have access to a working Mac, and both it and the non-working Mac have FireWire or Thunderbolt ports, boot the non-working Mac in target disk mode by holding down the key combination command-T at the startup chime. Connect the two Macs with a FireWire or Thunderbolt cable. The internal drive of the machine running in target mode will mount as an external drive on the other machine. Copy the data to another drive. This technique won't work with USB, Ethernet, Wi-Fi, or Bluetooth.

    How to use and troubleshoot FireWire target disk mode

    3. If the internal drive of the non-working Mac is user-replaceable, remove it and mount it in an external enclosure or drive dock. Use another Mac to copy the data.

  • dg123456 Level 1 Level 1

    Backing up through CCC...another 6 hours left. Had to use an older mac with USB 2.0 which is probably the bottleneck, since it's going at about 2 min per GB. The new mac (the one with the problem) is in target mode through firewire. The good news is that I can access all my files, which has allowed me to do something useful while the cloning process is ongoing.


    Once the clone is over, I'll get on reinstalling ML - probably good because it is a system that had lived thorugh many upgrades (I believe all the way back to tiger).


    Q: is there any benefit reinstalling ML from the original disk or from the recovery partition??