Previous 1 2 3 Next 33 Replies Latest reply: Jan 11, 2013 3:03 PM by lightspeedguru
D0nEichi Level 1 (0 points)

Hey guys,

I've build up my OSX 10.8 server yesterday and everything worked out well. My website is online, the ports I need are open and the EMail clients are able to connect to my server. But I have a mayor problem...the EMails I send disappear during proccess of sending. I used a account for testing in both ways but the emails just wont be delivered!? Doesn't matter which way I try it! The one thing that is really confusing me is that I'm able to send myself emails betweet two test account I created on the server...


So far I've tested: ports, MX-Records, static IP(I don't use dyndns or something like that)!


Thanks in advance.

Mac mini, OS X Server, Mac Mini running OSX Server 10.8.2
  • Chris Goodwin Level 1 (55 points)

    Thought I was having the same issue, but the only address it fails on is the Apple ID signed in to icloud - just happened to be the external address I was testing outgoing mail with initially. Seems an odd coincidence but every other external address I've tried has been successful.


    Need to move on to testing incoming external mail - tomorrow I think, once my head's cleared!


    Would be interested to know if this has any similarity to your issue.

  • Chris Goodwin Level 1 (55 points)

    Quick update on this...


    After digging through the logs it seems the missing messages were being re-routed to the admin account on the server, and sure enough examining the user details showed an alias of the Apple ID as an entry there. Removing that enabled emails to be sent to the external address. The Apple ID presumably was populated there during intial setup.


    Hope this is useful if anybody else hits the same oddity.



  • pterobyte Level 6 (10,930 points)

    Try and send an e-mail and follow it through in /var/log/mail.log. The log should show you while the e-mail is blocked/disappears.

  • D0nEichi Level 1 (0 points)

    Thanks for your reply...ill check on the .log files!

  • D0nEichi Level 1 (0 points)

    Okay so I tried following the Mail through the mail.log file but I don't really understand what is happening. Maybe one of you could be so kind and tell whats going on.


    This is what is happening in my log file if I send an E-Mail from an server account to a account:


    Dec  5 14:32:14 postfix/smtpd[13879]: connect from[]

    Dec  5 14:32:14 postfix/smtpd[13879]: E4D6F5E75C:[], sasl_method=PLAIN, sasl_username=CJ

    Dec  5 14:32:15 postfix/cleanup[13884]: E4D6F5E75C: message-id=<Edited By Host>

    Dec  5 14:32:15 postfix/qmgr[3495]: E4D6F5E75C: from=<Edited By Host>, size=544, nrcpt=1 (queue active)

    Dec  5 14:32:15 postfix/smtpd[13890]: connect from localhost[]

    Dec  5 14:32:15 postfix/smtpd[13890]: 5F8885E76A: client=localhost[]

    Dec  5 14:32:15 postfix/cleanup[13884]: 5F8885E76A: message-id=<Edited By Host>

    Dec  5 14:32:15 postfix/smtpd[13890]: disconnect from localhost[]

    Dec  5 14:32:15 postfix/qmgr[3495]: 5F8885E76A: from=<Edited By Host>, size=955, nrcpt=1 (queue active)

    Dec  5 14:32:15 postfix/smtp[13885]: E4D6F5E75C: to=<Edited By host>, relay=[]:10024, delay=0.47, delays=0.12/0.01/0/0.34, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[]:10025): 250 2.0.0 Ok: queued as 5F8885E76A)

    Dec  5 14:32:15 postfix/qmgr[3495]: E4D6F5E75C: removed

    Dec  5 14:32:16 postfix/smtp[13891]: 5F8885E76A: to=<Edited By Host>,[]:25, delay=1.4, delays=0/0.01/0.57/0.82, dsn=2.0.0, status=sent (250  <Edited By Host> Queued mail for delivery)

    Dec  5 14:32:16 postfix/qmgr[3495]: 5F8885E76A: removed

    Dec  5 14:33:15 postfix/smtpd[13879]: disconnect from[]

    //The E-Mail gets delivered within seconods..


    But if I reply on the E-Mail nothing happends in my inbox and it's pretty much the same with the log file. The EMail just doesn't arrive at my server then I guess......


    <Email Edited by Host>

  • pterobyte Level 6 (10,930 points)

    The logs show that outgoing mail to was sent out and delivered correctly.


    When you reply, are you saying you see no related log entries whatsoever on your server? Does give you any error messages? Are your DNS and MX records correct?

  • D0nEichi Level 1 (0 points)

    I get a Postmaster EMail after hours telling me that my EMail is delayed because of:


    Final-Recipient: rfc822;

    Action: delayed

    Status: 4.4.7

    Will-Retry-Until: Thu, 6 Dec 2012 15:46:39 -0800


    I've set up two MX-Records: and and I've put them into the backend of my domain provider. I also entered my static IP as an A-Record. My Wiki, Website, Profilemanager are all running perfectly fine. I have just no idea what the whole problem is...

  • pterobyte Level 6 (10,930 points) and have no A record assigned. You need to assign it so that can resolve to your IP.

    Don't add 2 MXs if you only have one actual mail server and IP.

  • D0nEichi Level 1 (0 points)

    Okay....but I have to assign two...I'm using united domains and they're forcing me to do so!


    Bildschirmfoto 2012-12-05 um 21.52.04.png

  • D0nEichi Level 1 (0 points)

    okay so recreated my mx-records without any success!

    I just don't understand why my server is not linking its IP to the mx-records ?!


    Bildschirmfoto 2012-12-05 um 22.07.57.png

  • JaimeMagiera Level 2 (305 points)

    OK, this is a problem I see all the time... You do realize that your MX record has to match an A record (computer record)? In other words, you need both an A (computer)  and a MX record for and MX records have to point to an actual machine.

  • D0nEichi Level 1 (0 points)

    Okay....but I'm not quite sure how to do that :/

  • JaimeMagiera Level 2 (305 points)

    I take it you don't have much experience with DNS. It's pretty essential if you want to have a outward facing server. If you can, I'd suggest purchasing this book...


    First and foremost, you need a computer record (A record) that has a hostname. In the image above, you seem to have created a machine record that just has the domain (""). You need to change that to represent a machine *within* the domain (""). Then, create an MX record that points to the same machine record ("").

  • D0nEichi Level 1 (0 points)

    Okay so I made this now...


    The machines (mx01/mx02) are looking like that:

    Screen Shot 2012-12-05 at 23.52.49.png


    And the MX-Records (mx01/mx02) are looking like that:

    Screen Shot 2012-12-05 at 23.53.47.png


    In general it looks like that now and if I uncheck the show all records and the look into mx01/02 the checkmark for create and MX-Records is checked automatically. I guess it worked then.


    Screen Shot 2012-12-05 at 23.55.46.png

Previous 1 2 3 Next