Previous 1 2 Next 19 Replies Latest reply: Dec 5, 2012 10:07 AM by Tinamj
Tinamj Level 1 Level 1 (0 points)

I have a new Macbook Air with Moutain Lion.  I am using Mac Mail.  When I first started, i could add only a few attachments but now I cannot add a single one.  This renders Mac Mail almost useless.  I've tried adding/deleting accounts, checked all imap options, tried different ISP emails and new user, rebuilt mailbox, and on and on.  I thought it might be a file privelage thing, but I don't think so.  Drag and drop adds an empty icon.

 

Any help is welcomed.  I will need to move onto a different app if I can't fix this.


MacBook Air, OS X Mountain Lion (10.8.2), Mac Mail issue
  • sig Level 8 Level 8 (35,780 points)

    You click on the Attach icon in the new message, navigate to the attachment, select it, then select Choose file, and now what happens?

  • Tinamj Level 1 Level 1 (0 points)

    The attach icon seems to "blink" and nothings happens.  No message or anything.  I tried to send as is to see if I just can't see it attached, but nothings actually gets attached.  I also tried from the pull down and drag and drop.  I checked and unchecked the "windows compatability" and all the other options like innclude at end of file.  Nothing works.  I even tried to share from MSword and Preview to email attachement and still only an empty email.

     

    I did try to forward an attachment and that worked but I couldn

    t add an attachment.

  • Tinamj Level 1 Level 1 (0 points)

    Just to correct a bit, clicking the attch icon, I do get to the select file popup.  When I select, both by double click and choose file, the "blink" happens.

  • sig Level 8 Level 8 (35,780 points)

    Select one at a time.

  • Tinamj Level 1 Level 1 (0 points)

    I have done one and a bunch of combinations.  I cannot get anything to work.  There is a chance this came about when the 10.8.2 update occured.  Looking at the syslog when I try to attach a file looks like:

     

    Dec  3 15:54:21 aaa-MacBook-Air.local com.apple.security.pboxd[228]: kCGErrorFailure: CGSSetHideOnDeact: error getting window tags

    Dec  3 15:54:21 aaa-MacBook-Air.local com.apple.security.pboxd[228]: RVS:-[NSRemoteWindowController setFrame:]:connection not initialized.

    Dec  3 15:54:21 --- last message repeated 5 times ---

    Dec  3 15:54:21 aaa-MacBook-Air.local com.apple.security.pboxd[228]: CGSCopyWindowColorSpace: Invalid window 0x4f5

    Dec  3 15:54:37 aaa-MacBook-Air.local com.apple.security.pboxd[228]: CGSReleaseWindow: Invalid window 1269

    Dec  3 15:54:37 aaa-MacBook-Air.local com.apple.security.pboxd[228]: _NXTermWindow: error releasing window (1000)

  • Linc Davis Level 10 Level 10 (169,275 points)

    Back up all data.

     

    Quit Mail. Then select  ▹ Force Quit from the menu bar. A small window will open with a list of running applications. Mail may appear in that list, even though you quit it. If so, select it and press return. Close the window.

     

    In the Finder, hold down the option key and select Go ▹ Library from the menu bar. Move the following item from the folder that opens to the Desktop:

      

    Containers/com.apple.mail

       
    Relaunch Mail and test.
  • Tinamj Level 1 Level 1 (0 points)

    Unfortunately, I get the same result.  I also tried to shutdown and restart.

  • Tinamj Level 1 Level 1 (0 points)

    Looking at syslog, I seem to have a lot of "ReportCrash" and segementation fault: 11 around SecurityServer, ParentalControl, and FamilyControl.  I am sure not good things and maybe a root cause.

  • Linc Davis Level 10 Level 10 (169,275 points)

    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left.

     

    Click the Clear Display icon in the toolbar. Try the action that you're having trouble with again. Post any messages that appear in the Console window – the text, please, not a screenshot.

    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.

    Please do not indiscriminately dump thousands of lines from the log into a message.

    Important: Some private information, such as your name, may appear in the log. Edit it out by search-and-replace in a text editor before posting.

  • Tinamj Level 1 Level 1 (0 points)

    As instructed, here is the console dump for all messages when trying to attach a file to an email.

     

    12/4/12 9:47:26.178 AM com.apple.security.pboxd[1085]: CGSGetWindowTags: Invalid window 0x381

    12/4/12 9:47:26.178 AM com.apple.security.pboxd[1085]: kCGErrorFailure: CGSSetHideOnDeact: error getting window tags

    12/4/12 9:47:26.309 AM com.apple.security.pboxd[1085]: CGSCopyWindowColorSpace: Invalid window 0x381

    12/4/12 9:47:32.866 AM com.apple.security.pboxd[1085]: CGSReleaseWindow: Invalid window 897

    12/4/12 9:47:32.866 AM com.apple.security.pboxd[1085]: _NXTermWindow: error releasing window (1000)

     

    **************************************

    One minue afterwards I get this:

     

    12/4/12 9:48:50.809 AM ReportCrash[1098]: DebugSymbols was unable to start a spotlight query: spotlight is not responding or disabled.

    12/4/12 9:48:51.105 AM ReportCrash[1098]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    12/4/12 9:48:51.105 AM ReportCrash[1098]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    12/4/12 9:48:51.105 AM ReportCrash[1098]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    12/4/12 9:48:51.105 AM ReportCrash[1098]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    12/4/12 9:48:51.105 AM ReportCrash[1098]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    12/4/12 9:48:51.106 AM ReportCrash[1098]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    12/4/12 9:48:51.106 AM ReportCrash[1098]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    12/4/12 9:48:51.106 AM ReportCrash[1098]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    12/4/12 9:48:51.106 AM ReportCrash[1098]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    12/4/12 9:48:51.106 AM ReportCrash[1098]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    12/4/12 9:48:51.156 AM com.apple.launchd[1]: (com.apple.familycontrols[1071]) Job appears to have crashed: Segmentation fault: 11

    12/4/12 9:48:51.430 AM ReportCrash[1098]: Saved crash report for parentalcontrolsd[1071] version 26 to /Library/Logs/DiagnosticReports/parentalcontrolsd_2012-12-04-094851_-MacBook-Ai r.crash

  • Linc Davis Level 10 Level 10 (169,275 points)

    Disable Parental Controls and test.

  • Tinamj Level 1 Level 1 (0 points)

    I didn't know it was on.  It looks like it may be a default for the guest account. 

     

    There doesn't seem to be the crash or segmentation faults, which is good.  I rebooted and the mail attachments still doesn't work.  There is still something with the security server and the keychain.  The "keychain sandbox" statement shows up 100's of times.  I did remove the mail container too.

     

    12/4/12 10:31:29.327 AM xpcd[162]: restored permissions (100644 -> 100744) on /Users/.../Library/Containers/com.apple.mail/Container.plist

    12/4/12 10:31:29.588 AM Mail[232]: Using V2 Layout

    12/4/12 10:31:30.028 AM librariand[234]: MMe quota status changed: under quota

    12/4/12 10:31:30.206 AM Mail[232]: Unable to find message to restore.

    12/4/12 10:31:30.878 AM com.apple.SecurityServer[15]: Session 100009 created

    12/4/12 10:31:31.117 AM Mail[232]: Keychain sandbox consume extension error: s=-1 p= Cannot allocate memory

  • Linc Davis Level 10 Level 10 (169,275 points)

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Triple-click the line below to select it, then drag or copy the text — do not type it — into the Terminal window and press return:

     

    ls -1A {/,}Library/Mail/Bundles 2> /dev/null

     

    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • Tinamj Level 1 Level 1 (0 points)

    Nothing shows up.  Returns with a blank prompt.

Previous 1 2 Next