5 Replies Latest reply: Sep 14, 2013 1:08 PM by dodonian
Daniele Outline Level 1 (0 points)

Dear sirs,


we bought Mac Mini Server Version 10.8.2


We start Server App and we switched on Web Sites service.


It worked fine.


Then, we switch off the service, but we found httpd process in Activity Monitor, so we kill all httpd processes.


Then, we start again Server App, but if we try to switch on Web Sites service, nothing happen (no error) but we can not see httpd process in Activity Monitor and the web service doesn't run.


If we run from a terminal:


sudo apachectl -k start


the web service start but with the wrong root directory.


If we run from a terminal:


sudo serveradmin start web


the result is:

web:state = "RUNNING"

web:status = 0


Wait for a suggestion.




Mac mini, OS X Server
  • Camelot Level 8 (46,650 points)

    It's almost impossible to say, given the limited data available, but there are many possibilities.


    The fact that the web service starts manually but 'with the wrong root directory' implies you have multiple Apache installations. Did you manually install your own web server setup? If so most bets are off.


    Second to that, have you tried stopping the web server via serveradmin (sudo serveradmin stop web). It may be that ServerAdmin isn't noticing the fact you killed and restarted Apache while it wasn't looking, so telling it to stop might help.


    Beyond that, what do the logs say?

  • Daniele Outline Level 1 (0 points)

    We can repeat the problem on a new Mac Mini.


    Same procedure.


    Run Mac OsX Server 10.8.2 and start Server App.


    Enable/Disable WebSites service and everything works fine (Switched on we can access to web server page "Server" and switched off the web server is off).


    Then we close WebSites Services and we close Server App.


    Check in Activity Monitor and see httpd process running (why?).


    Then kill httpd process in Activity Monitor.


    Open ServerApp and starts WebSites Service. It doesn't start.

    No Error.

    No additional info in /var/log/apache2/access_log

    No additional info in /var/log/apache2/error_log


    It is the same behaviour of the other MacMini Server.


    They are new Mac Mini Server with preinstalled release.

    We don't install anything.


    On both two Mac Mini:

    sudo apachectl -k start

    The web server starts and we can see the web page "It works" (it is not the "Server" web page, it has a different root directory)


    sudo apachectl -k stop

    The web server stops


    sudo serveradmin start web

    web:state = "RUNNING"

    web:status =0


    The webserver doesn't start

    No new info in access_log and error_log

    What can we check?


    How can we "reset" the webservices?

    How can we see additional report?

  • Daniele Outline Level 1 (0 points)

    After a lot of tests, the problem is in "Enable web Php" feature.


    If I switch on it, httpd crash. In reports:

    [Tue Dec 11 11:28:15 2012] [notice] caucht SIGTERM, shutting down


    If I switch off it, then httpd works fine.


    Some ideas?

  • Daniele Outline Level 1 (0 points)

    cd /usr/lib

    sudo ln -s libpq.5.4.dylib libpq.5.dylib

  • dodonian Level 1 (0 points)

    Hello Daniele,


    I have the exact same problem, althouth PHP doesn't seem to be the issue. I have tried everythin else (re-installing Server.app etc) with no luck. The command you suggested produces the following:


    sudo ln -s libpq.5.4.dylib libpq.5.dylib

    ln: libpq.5.dylib: File exists


    The /usr/lib has the following relevant entries:


    -rwxr-xr-x  1 root  wheel  163840 Sep 13 23:23 libpq.5.4.dylib

    lrwxr-xr-x  1 root  wheel      15 Nov 16  2012 libpq.5.dylib -> libpq.5.4.dylib

    lrwxr-xr-x  1 root  wheel      15 Nov 16  2012 libpq.dylib -> libpq.5.4.dylib


    Could you please help?


    BTW, in our case we never touched the Websites configuration. When I wanted to activate it, it never started.


    Thanks in advance